Answered

Sonos zones dropping out after adding turntable

  • 16 October 2018
  • 6 replies
  • 244 views

Badge
I've just added a turntable to the system. Through one zone, no problem. Through two, three, or four zones; dropouts to point that it's unlistenable. I tried the "fix" of changing the compression to compressed. That didn't help. The Sonos stream is compressed enough when playing services like Spotify. Part of the reason I got a turntable was to bring back the deep, full sound of vinyl. I will tried switching the input to the AirPlay device instead, because I read that it buffers more. That helped some, but did not solve the drop out issue. Set it to uncompressed and AirPlay. Actually, when it does cut out, it cuts out on every device except the Connect that the turntable is directly plugged into. My setup at the the turntable is; Turntable Preamp Line out, Connect line in, Connect Line out to Amp for that zone. Wireless to the Connect Amp in the closet. I can hardwire a CAT5 to the Sonos network instead of wirelessly connecting if that will help. I need to call and submit a diagnostic report, but looking for an advanced using that has solved this problem that may know something that works.
FYI; my Sonos systems consists of (1) Connect, (2) Connect Amps, (1) Playbar + Sub, and (1) Play5.
icon

Best answer by Chris 17 October 2018, 18:34

I’m in midlo too off robious.

It may help hardwiring the connect amp the turntable is hooked to. But sonosnet really should be able to keep up.

Have you checked your sonosnet channel vs your routers channel.

I would also go into settings, advanced, and submit diagnostic. Post the number here for Sonos to look for interference.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Badge
Diagnostics Report #1072432795 if anyone on the Sonos Mothership is out there.
Userlevel 7
Badge +22
Try connecting the most convenient Sonos unit to your router via ethernet. The go into settings...advanced. Make sure Sonos Channel communicating on is at least 5 channels removed from the channel your router is using (only use channels 1, 6, 11) chose one in your router and one for sonos.

That should get all music bandwidth off your router and help with the bottleneck in bandwidth.
Badge
Thanks, Chris. I see you are in Richmond. I work in Richmond and live in Midlothian. Currently, I already have one of my two Connect Amps physically connected to my router via CAT5. Also, the 2nd Connect Amp is network hard wired from the 1st Connect Amp. All other Sonos zones, including the Connect that the turntable is plugged into, is connected wirelessly. I'm thinking I need to physically connect the ehternet to the 2nd Connect Amp network passthrough to give it a greater data stream than wirelessly connecting.
Userlevel 7
Badge +22
I’m in midlo too off robious.

It may help hardwiring the connect amp the turntable is hooked to. But sonosnet really should be able to keep up.

Have you checked your sonosnet channel vs your routers channel.

I would also go into settings, advanced, and submit diagnostic. Post the number here for Sonos to look for interference.
Badge
FYI, just as a closer for this, and to all that see this question in the future; the best resolution to come up with was to set the input to “uncompresssed”, set the naming of the input to AirPlay, for a larger data buffer, (then renaming it Turntable Records), and then hardwiring all the zones with CAT5 or CAT6 terminated cable into the Sonos network. That was lots f work, but the only way to prevent the other zones not directly connected from dropping out.
So to sum up; my system and how it worked for me; Turntable set to line out to Line in of Connect. Line out of Connect to small amp driving two speakers in the Arcade Den zone. Connect hardwired CAT6 to a Connect Amp, which is hard wire looped through to another Connect Amp, which is plugged into the internet router. The Playbar is hardwired to the Sonos Net loop through, so all of my zones are hardwired into Sonos Net, except for the Sub (which is paired with the Playbar), and the portable Play5. YMMV, but this works for me. Don’t believe that you can play a turntable wireless connected to the Sonos Net and expect it to work. The data stream is too large for then wireless Sonos Net to handle, and dropouts happen. Hardwire every zone possible into the Sonos Net, especially if you plan on running a high data stream hog like a turntable. Yes this is long winded, but I wanted to share so that others can benefit from my trials. Thanks Chris “RVA” for the help. Pleasure talking with you.
Userlevel 7
Badge +22
Glad you got it going