Sonos system stopped working!

  • 5 November 2017
  • 18 replies

I've had a working Sonos system for years, comprising of a sonos amp, a sonos connect, a sonos play:5 1st gen and a sonos play:5 2nd gen. The sonos connect uses a wired connection all the others are wireless. I have a sonos bridge wired to a Netgear router. All have worked perfectly until today and now I can't get anything to work, regardless of what I do.
All Sonos apps (PC and Android mobile) are no longer seeing any of the wireless devices. I have rebooted the router (twice), rebooted the sonos bridge, tried hard wiring one of the sonos play:5's to my network, performing an update, but nothing seems to work.

When updating the windows PC sonos app, the app ends with "Update problem - There was a problem during the update of your Sonos system. - Try again". That's just great!!!!! I have tried again many times, but nothing works!

When I hard wired the sonos play:5 2nd gen to my network I was able to add it and then play music on it. When I removed the network connection it no longer works and disappears from the app.

So, what's going on Sonos? Why have all my wireless devices suddenly disappeared and why can't they be added back in. I'm really getting VERY frustrated trying to resolve this issue, which is wasting my time.
I'm sure you're going to tell me it is my wireless network that is causing the issue, but all my other wireless devices are working fine!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

18 replies

Ok, let’s take it one step at a time. You’ve updated the PLAY:5 gen 2 to the latest firmware by wiring it directly to the router. I’d recommend doing the same thing with the gen 1, and the CONNECT as well. If you can connect both of the to the router with an Ethernet cable at the same time, it would be faster, but you can do them individually, if that’s required. Once everything is on 8.1.1, you can remove the Ethernet cables between the router and the speaker/CONNECT, and leave the BRIDGE plugged in.

At that point, everything should be on the same software/firmware version, which is 8.1.1 I think. Then go ahead and run the app, and see if everything shows up.

If it doesn’t, post back. It would be useful at that point to submit a systems diagnostic from the controller app.
I'm also having the EXACT same issue. I have submitted an incident and diagnostic number. My system was fine UNTIL I went to update the latest release. Desktop AND Android App does not recognize my system. 1 Boost, 1 Play5, 2 Play3, 2 Play1, 1 Soundbar and 1 Sub Woofer. All NOT working! Tried to re add and your apps are saying "Cannot Find Player, try moving closer to Router"! They were perfectly fine and WORKING BEFORE UPDATE!

I'm sure you're going to tell me it is my wireless network that is causing the issue, but all my other wireless devices are working fine!

Unfortunately wireless audio streaming is more susceptible to network issues than devices like printers and computers. Sonos is no exception and I doubt there are any - I haven't of heard of any for sure.
And "it was working fine before the update" also doesn't hold water; an update exposes underlying issues that in the course of time would have surfaced.
Send the diagnostic and quote the number in an email to Support as done by clifrunner.
Kumar, please don't try to tell me the issue is with my home network. It is NOT. My home network hasn't changed and consists of a number of wired and wireless devices, all of which are working perfectly. The ONLY thing not working is my Sonos system.

Tonight I started up a laptop I haven't used for a week or so. It connected to my home network using wifi - no problem there. I then started up the Sonos controller and it displayed the two PLAY:5 speakers and the Connect Amp, which is also wireless. It didn't display the only wired Sonos hardware I have; a connect.

I noticed an update was waiting (to 8.1.1) and so went ahead with it. This update failed and asked me to Try Again, which I did and it asked me to Try Again, which I did etc. etc. Not very helpful! Now, the wireless sonos devices have disappeared from my Sonos controller. Now despite the update not working, the About window is showing my controller is at Version 8.1.1! How is that possible when the update failed and asked me to try again?

If I had to guess what is causing the problems I would have to say it is this new update as I had similar issues on my main desktop PC.

So, it's over to you Sonos. Two of us here are having issues after attempting to install this update. So what's going on? What have you broken? Why has this screwed our Sonos systems and how do we get them back up and working without wasting hours of our life?
Like clifrunner I have submitted a support diagnostics with confirmation number 8051566. Does anyone from Sonos monitor this forum?
My issue is exactly the same as clifrunner's; everything was working fine up until yesterday afternoon and now it doesn't work on either Windows 10 PC's or Android mobiles.
milleniumaire, do you want to get your system running or do you want to argue with people who have years experience in getting systems up and running over who or what is to blame? If the latter, we can't help you. If the former, then the fact is, connection problems which appear suddenly are often caused by network problems, not Sonos problems. The typical cause is duplicate IP addresses. These often show up after an update or power outage because a reboot requires the device to request a new IP, and the router, having lost track of current IP assignments, issues a new IP that is in use by another device. To cure this, do the following:

Reboot/power cycle your devices in the following order:

Switches or hubs
Wired Sonos units
Wireless Sonos units
Wireless devices - phones/tablets etc.

Allow each device to come back up before proceeding to the next. Note that you can permanently prevent duplicate IP addresses by assigning an IP to each device's MAC address in the router setup. See your router manual for details.
I have the same problem after the last update, and you cant tell me it is a network problem if the system is constantly telling me about a problem with my update, and to try again. How is that a problem with my network?
I'm not sure I follow your logic about it being or not being a network issue.

If the speakers are disconnecting occasionally from your network due to, say, a duplicate IP issue, which would be addressed by jgatie's process as listed, it would be able to be occasionally/sporadically/frequently/often connected to your wifi without any issue, followed by a sudden disconnection. This disconnection would cause any current process to fail, such as an update, or playing of a file, which would hopefully recover after the speaker reconnects to the wifi and bumps the other device off of the network. But many processes have a limited amount of tolerance for interruption, hence the possibility of the system telling you about the problem with the update.

I'm certainly open to more knowledge if I'm incorrect.
Userlevel 7
Badge +19
Hi there, Rwick3142. Thanks for posting and welcome to the Community. If you are having problems with updating your Sonos, please check out this article which should give some insight into the errors and some common fixes. If you still run into problems, please feel free to submit a diagnostic report and reply with the confirmation number it gives at the end. I will be happy to take a look and advise.
My issue has nothing to do with my speakers, distance, interference. I was prompted to update my system. In the process of the update, I received a problem with my update message, please try again. I tried again, I received a message that my system was already updated. I attempted to open spotify, connection to spotify was lost, attempted to open Amazon music, same.uninstalled Sonos, re-install Sonos. Now I was prompted to add my favorite music services. I add Spotify, and I am told Spotify is already installed. Give it a shot.....same thing. Now here is the interesting part. I was gathering the information for a detailed email to Sonos, ran the diagnostic, everything is on 8.4, send it, and the Sonos starts playing music in all the selected rooms. Go Figure.:?
and its down again. I'm saying its not a network issue because it started as a update issue. I have now installed, uninstalled, reinstalled, configured my router with different ip addresses, gave the speakers priority to bandwith, and am right back to not just 1 error message but multiple. From unable to connect to Sonos, which is on my wired PC, to unable to play selected choice, to unable to find your Sonos system. All starting with an update that had a failure, try again, already updated. that sounds like a programming issue of sort, not my network. I am running Amplifi with 150+mbs throughout my house.At a complete loss
Userlevel 7
Badge +19
Rwick3142: Might I suggest that it would be best that you give our support technicians a call? From the sounds of it, we should probably have a technician take a look at this in real time. Thanks!
Hi Sonos, I have the exact same problem as those above. Started when I updated software to 8.4. Finally got it working after several attempts, but lasted for 10 mins, then it wanted to index my music, 1 hour later, it works, then it's off again. Rebooted the router and tried to reconnect to Sonos. Wouldn't let me because it told me there was no system there. All lights perfectly working in white. I have had this system for 8 9 years no problems until this update. Do you ever let people go back to an earlier version? I changed channel from 6 to 11 and it started working. Then it stopped again. There have been no changes to my network for a year. Also I have a fixed IP on the Sonos ZP, always had. This is a simple system, one Bridge, one Connect into my Amp. Bridge is 1 foot away from router, Connect is 20 feet from Bridge, been in that position all 8 years. If I shut down my PC and open it again.....Sonos is gone. I think you are trying to get too many services working on your system instead of doing what you started with. I can't spend time on this every time I want to listen to music. This was the most reliable product out there with great software back in the day.
Userlevel 7
Badge +22
The problems have nothing to do with 8.4 but it is strange that it sounds like IP address conflict when you have a fixed IP. Have you tried changing that fixed IP just to check and then rebooting sonos and router.

I would also go into settings...advanced...submit diagnostic and post the diagnostic number here for Sonos to check your system out (after having tried the IP address change).

Sounds like the PC is your controller and houses all the music you are indexing. Maybe make sure it is on a fixed IP address different as well in case it is the one having the troubles.

Have you tried controlling Sonos from a mobile device to rule out network connectivity with PC as the issue (of course using an online source for the music not your music library as it would have issues as on the PC).

P.S. I would post your question and the diagnostic its own thread so that Sonos won't miss it (as it could easily at the bottom of this thread).
I restarted everything and now it's working fine for the last 6 hours. I just don't understand that the software on my computer says that the Sonos is there and connected but the PC cannot control it, neither did my Galaxy S6 phone. Computer kept saying"unable to browse music". Now it's functional, not sure why and why did it need to re index my music for an hour yesterday? Then started working and then stopped. I went through all the re-starts you recommend. Maybe moving to channel 11 fixed it. Last time I had this issue moving to 6 fixed it! Thanks for replying promptly and hopefully it will continue to work.
Userlevel 7
Badge +22
Still sounds to me like some IP address issues. Do you have fixed ip addresses for your desktop and galaxy.
Hi Chris, I wanted to wait some time before saying the system is up and running fine, which it is. My music is on a network drive and not on a computer. All my devices are now functional but I didn't change anything regarding the system. I have never seen the device re index my music automatically other than 2am in the morning. It took forever. I have no idea why I was going around in circles. It told me there was nothing wrong with the system but wouldn't let me connect to the system.
Userlevel 7
Badge +22
Glad to hear it’s all working