Sonos skipping songs on Spotify all the time

  • 20 August 2014
  • 3 replies
  • 956 views

I have Sonos Play 5 that is wired and Play 1 that uses Wifi. Spotify is skipping songs. Sometimes every song skips, and sometimes one, two songs play fine until next song skips after 30s - 2 minutes. I have tried to change wifi channels but the problem still continues on 1, 6 and 11. I have a 50 mbit internet connection and Airport extreme AC router.  I have sent a diagnostics report with number 3956286.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 5
Badge +3
Hello Ketilarm,

Thank you for including the diagnostic, I am seeing the Spotify errors that you have been experiencing. Please try the following steps to help narrow down the issue:

Reboot your router and test the service again. Unplug your router from power for about 30 seconds, then plug it back in to power. Wait for the network to come back up.Then test again. Please clear your queue and then re-add and test playback. 
Remove and re-add the Spotify Service. To do so from your computer, please select: Manage > Service Settings > select Spotify > 'Remove' or ' - ' then select 'Add' or ' + ' > Spotify > enter your username and password
Test other services on the system. Test Internet Radio and other services to see if you experience the same skipping. 
- Take a look at your router settings. Verify which wireless channel your router is set to or if it is set to 'auto-channel'. Your Sonos system is currently set to channel 1, try setting your router to 11 so that they do not conflict with one another. 

Please also submit another diagnostic after these tests- I'll be happy to take a look. 
I'm having this problem as well. Also on my Sonos Play 1 but it's happening through Spotify. I stopped using the Sonos app. Any further suggestions?
Submit the diagnostic he was suggesting?