Sonos S2 a joke!!

  • 4 March 2021
  • 3 replies
  • 117 views

After soon 10 years as a dedicated Sonos fan. I’m really impressed of how useless and bad the new app. 
Nothing really works now. It did previously. But not any more. 
All 3 speakers can only play as a group a few times a week. Music comes and goes on all speakers. The app is so extremely slow and hard to use. I’m considering of selling or throwing this junk away. 
It really must be a system with better performance and ease of use than this. 
 


3 replies

As near as I can tell, there really isn’t all that much difference yet between S1 and S2. I assume that will change over time with new features added to the S2 app.

There does seem to be a slightly longer delay these days when you first start the controller, as it reaches out on your network to connect to all devices, but that’s more like an extra second than before, and has no impact at all on the ability for speakers to group, or have music come and go. 

But what you’re describing sounds much more like network issues, rather than anything with the apps.

I’d recommend as a starter a simple network refresh. Unplug all your Sonos devices from power. While they’re unplugged, reboot your router. Once the router comes back up, plug back in your Sonos devices.

However, that is not a silver bullet. It will likely resolve 80 to 90% of issues, but not all of them. There still could be a case of ‘simple’ wifi interference , which could be coming from either inside your home, or even from outside your home. 

If your situation continues, I would recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, there are more options available beyond just the diagnostic analysis.

Thank you Bruce for taking the time to help. 
I was so extremely frustrated. Will try this and report back. 
Tnx again

Nope. 
Didn’t work. Tried several times and in different combination of restart order. 
Also of course submitting the diagnostics doesn’t work at this time. 
Tries calling support. But they don’t have support in Sweden. 
So. Let me know if you live in Sweden and want several of useless doorstops. They probably won’t work or they might start occasional fires. 
 

Cheers

Reply