Sonos S1 is connecting to wrong Google Wifi access point instead of the closer AP. how to fix?

  • 16 September 2021
  • 6 replies

As stated in the title, I think the Sonos S1 devices (such as the Connect Amp, the Connect and the Playbar) are all connecting to the one and only Google Wifi router in the other room. I would like them to connect to Google Wifi AP that is in the same room as they are. 

I have everything working except this issue, all the units have a “weak connection” to the Wifi. It would be great if there is a way to make the Sonos units see the local AP.


Best answer by AjTrek1 17 September 2021, 14:25

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 7
Badge +18

Hi @markwigzell 

Thanks for your post!

Simply rebooting the speaker by removing power for a few seconds will result in the speaker connecting to the strongest WiFi signal that it knows the credentials for.

I hope this helps.

Userlevel 7

Great advice by @Corry P 

However, I’d introduce the SonosNet either by wiring a speaker to the main router (if convenient) or connecting a Sonos Boost module ($100 USD).

Thanks for advice guys, however it is the Connect, the Connect Amp and the Playbar that I have the issue with. I have cycled power several times already, they ALWAYS connect to the mesh point I set them up with originally, when following the “Setup Wireless” for them. That mesh point is the actual router. in the Google Wifi set up. They never see the mesh point that is in the same room with them. (I had to move them from the original Wifi router back to their place in the other room). It seems they are retaining the ip address of the mesh point they were set up with. I reasoned I could maybe re-set them up with the secondary AP but they don’t switch to it. 

(Bear in mind, this is a MESH network, and I am using the old S1 units). I have heard the “Move” is able to switch automatically.

@Corry P the only speakers I have are two surround speakers associated with the playbar. I think the issue is with the playbar not connecting to the nearest/strongest wifi. Are you sure a Sonos S1 product will do this? How should I do it?

Btw, I have a Sonos Bridge which I took out of the network before setting up the system on the Google Wifi. I was not able to set the system up at all with the Bridge. If I wire the Bridge to the main router, what do I have to do to get my Connect, Connect Amp and playbar to use it?

Is there any kind of wiring schematic that would shed some light on wired vs wireless setup?


Userlevel 7
Badge +18

Hi @markwigzell 

Sorry - I tend to use “speaker” for all Sonos devices. Replace it with “Sonos unit” in my previous advice.

Do all your access points have the same SSID (broadcasted network name) and password? They should, if they are a mesh, and if they don’t, that would prevent Sonos from connecting. I can’t think why else they wouldn’t connect. You could certainly try rebooting the router and access points, then once they’re online rebooting the Sonos units.

I recommend you follow @AjTrek1‘s advice, however, and permanently connect either your Connect, Connect:AMP or Playbar to the network with ethernet, i.e. not one of your surrounds. The wired unit will transmit a new WiFi just for Sonos that the others will prefer over your existing WiFi automatically, and each will retransmit in a mesh configuration, just like the Google devices. All you need to do is connect via ethernet and wait a minute or two.

This mimics what the Bridge would do, but the Bridge is so out-dated that we recommend you use a speaker/player instead. If you cannot get a Sonos unit close enough to your router, your Bridge will earn you a discount on a Boost, which is the updated equivalent of the Bridge. Just give our sales line a call.

If all goes well, you can remove the WiFi credentials from your Sonos system.

Hi @Cory P thanks for your reply! I do have LAN in the room where the Sonos equipment is. That LAN is part of the wired network that is connected via a switch to my Google Wifi router. So I’m reasoning I can try your suggestion above by wiring my Connect to the wall LAN socket.

Later: YES. That worked. It is kinda funny: I bought the new Google Wifi to fix my Sonos issues, removed my Bridge, then removed my new Wifi network from my Sonos system. And it works better than before. Now I have a new mesh network, but Sonos is not using it. I think perhaps the real problem all along was simply lack of proper coverage by my old wifi extenders (Apple Airports) to my smartphone. They are now also gone. So a win win I think. My original router is also completely gone too. So I installed a Google Wifi and took out 2 Apple airports, a Verizon FIOS router and a Sonos Bridge.

Thanks for helping me understand Sonos a bit better. I was unaware that one could wire the Sonos Connect directly to LAN. I think a few scenario diagrams for how Sonos can be deployed would greatly help people to understand how to set up their system.

Userlevel 7
Badge +22

There are notes specific to Google Mesh setup here: