Answered

Sonos Roam not playing

  • 27 August 2021
  • 5 replies
  • 83 views

Trying to help hubby connect to our Sonos Roam, whilst away from home.  Bluetooth is connected, blue light on the Roam.  His phone is saying it is connected, however he can not play music.  When he tries from the app it is saying that it is looking for a network.  The Roam has been added to our home network.  The hotel Wi-Fi will not have a Sonos network….. tried turning off Wi-Fi all together. 

icon

Best answer by GuitarSuperstar 27 August 2021, 14:28

Use Bluetooth when using the Roam away from home.

Try these steps:

Under the Bluetooth settings on your phone, select “Forget this device”.

Then reboot the Roam following these steps:

  1. Disconnect Roam from charging cables and remove it from wireless chargers.
  2. Hold the button on the back of Roam for at least five seconds until you hear the power-off tone and the light above the Sonos logo turns off.
  3. Wait 10 seconds.
  4. Press the button on the back of Roam to turn it back on.

Then redo the Bluetooth pairing process:

https://support.sonos.com/s/article/4989?language=en_US

View original

5 replies

Userlevel 7
Badge +17

Hi @Mandy And Bryan 

Welcome to the Sonos Community!

Once the Roam is connected to Bluetooth, it is the Bluetooth host device that plays audio to the Roam, and the Sonos app doesn’t have anything to do with determining what that will be. Once connected, your husband should open quite literally any app at all that would normally play out of the device’s own speaker and play from there. The device will feed the audio to the Roam instead of playing it itself, much like with any other Bluetooth speaker. No internet connection is required (unless streaming).

I hope this helps.

Userlevel 7

Use Bluetooth when using the Roam away from home.

Try these steps:

Under the Bluetooth settings on your phone, select “Forget this device”.

Then reboot the Roam following these steps:

  1. Disconnect Roam from charging cables and remove it from wireless chargers.
  2. Hold the button on the back of Roam for at least five seconds until you hear the power-off tone and the light above the Sonos logo turns off.
  3. Wait 10 seconds.
  4. Press the button on the back of Roam to turn it back on.

Then redo the Bluetooth pairing process:

https://support.sonos.com/s/article/4989?language=en_US

Thank you so much, worked a treat 👏

Userlevel 3
Badge +5

Chiming in on this thread rather than creating another identical thread. In essence we have the  same problem, having taken the Roam away on holiday for the first time.

We have no issues pairing the Roam two each of our iPhones, but any time we switch from playing music from  one  device to the other it won't play despite showing as connected in Bluetooth. The only solution seems to be  forgetting the  device each time and starting again.

This is maddening. No other Bluetooth device requires forgetting the device in order to connect to another paired device.  Please tell me this is some bug Sonos intends fixing, and not a (poor) design feature.

Userlevel 3
Badge +5

Hi all

Currently chatting with Sonos on this, and I’ve learned that there is a *slightly* easier way to move the Roam between different streaming devices.  You just have to remember to ‘disconnect’ from the last device from which you were playing.

On iPhone, for example, go to Settings > Bluetooth.  Tap the ‘information’ bubble beside the Roam, and (rather than Forget) choose ‘Disconnect’.

For now, it seems the Roam will retain it’s active connection to the last device from which you were streaming.  The only way to connect to another device is to manually disconnect from the last device used, then connect on the new device.

I’m asking if this can be enhanced in firmware, as with other bluetooth speakers I would assume the most recent device to connect would become the active streaming device.  Will post back when Sonos has confirmed.

Reply