Roam is always turning itself on and the battery is always dead making the roam unusable

  • 25 April 2021
  • 71 replies
  • 7869 views

Userlevel 4
Badge

I hope an update is coming because I’m over going to use my roam and it’s dead. Out of the five times I’ve wanted to use it I have only been able to use it once. I have to leave it on the charger when not in use otherwise it will be dead when I go to use it. When it’s on the charger and it gets to 100% there is no way to turn it off. If I hold the power button for five seconds it turns off but within a few seconds it turns itself back on again. If they don’t say a fix is coming within a week sadly it’s going back.


71 replies

Userlevel 7
Badge +15

It’s best to keep the Roam on its charger when not in use so it will always be charged when you need it. Keeping the Roam on its charger after it is fully charged will not degrade the battery.


Given it's supposed to be a battery powered speaker with a declared life of 10 days or so when not in use, surely you accept the absurdity of that ‘advice’?

Userlevel 4
Badge +9

Hi @caesar327, this is by design, so that the Roam is ready to play when you open the app. I can certainly pass this on as a feature request, however for the time being your best choice to conserve battery when not in use, is to power off the Roam completely.

I’ll be sure to pass on your feedback regarding the Set Up & User Guide @thornen, it does seem that there’s been a bit of avoidable confusion regarding the power button functions on the Roam :)

To clarify, yes, we know the design intent to have the Roam always ready.  But that design doesn’t really work well in more complex Sonos environments (i.e. those users that have a house with Sonos speakers spread throughout).  Since users in that environment will likely use the app periodically throughout the day, but not necessarily wanting to use or activate the Roam each time.   As such, it causes the Roam to wake too often, for no reason, and drain the battery after only a couple of days or so.

While someone might say, well then just power the Roam off -- that’s not the correct answer.  For users with the Roam in a home environment (maybe kept in the bathroom and not near an outlet) - we want the Roam ready to use -- BUT ONLY when we want to use it (to avoid the power drain).   In other words, users should NOT have to physically engage with the Roam to power it on at home, but, at the same time, it shouldn’t turn on every time the app is opened (since then the Roam’s battery drains).

The answer is a software fix/option, whereby the user can decide to Wake up the Roam either:

  1.  Every time the app is used (as it works now);  OR
  2.  Only when the user wants to the Roam to wake (in other words, send the signal to the Roam based on user input specifically (not just every time the app is opened).  This would likely require an extra button click/interaction in the App -- but well worth it.

So how about this option in the App:   Wake Roam on Every App use   vs.  Wake Roam via App Manually

Does that clarify the issue and feature sought?

 

 

Userlevel 4
Badge +9

I’m going to post this everywhere I can. The “auto turn on” feature is SO.DUMB.

Makes this product trash, basically. I’ll probably be returning it. 

Every other bluetooth speaker I’ve used before has auto-turn OFF. That makes 10000% more sense than auto-turn on. It would NOT be a big deal to turn my Roam on right before I want to use it. Who cares about a 2-second delay if your Roam is always dead !? 
 

I suppose it depends how you use it. They probably expect most people will keep it on the charger when they’re on WiFi.

 

That’s a bad assumption. My Roam sits in a bathroom on a shower shelf. No charger or outlet there. Since it’s waterproof, I think this is not an unusual use case.  

The problem is the wake from sleep mode when the app is used (even if using the app for OTHER Sonos speakers).  This was a mistake in design.  The app should allow the choice between always wake Roam vs wake Roam when I specifically want to wake the Roam - and supply a mechanism for doing so.  I assume this is an easy software fix.  Fix it!  

I’m going to post this everywhere I can. The “auto turn on” feature is SO.DUMB.

Makes this product trash, basically. I’ll probably be returning it. 

Every other bluetooth speaker I’ve used before has auto-turn OFF. That makes 10000% more sense than auto-turn on. It would NOT be a big deal to turn my Roam on right before I want to use it. Who cares about a 2-second delay if your Roam is always dead !? 

I hope an update is coming because I’m over going to use my roam and it’s dead. Out of the five times I’ve wanted to use it I have only been able to use it once. I have to leave it on the charger when not in use otherwise it will be dead when I go to use it. When it’s on the charger and it gets to 100% there is no way to turn it off. If I hold the power button for five seconds it turns off but within a few seconds it turns itself back on again. If they don’t say a fix is coming within a week sadly it’s going back.

I’m having the same issue , I got mine a few days ago, I keep thinking I am turning it off but then after a while the white light comes back in . I went to use it this morning after being at 100% yesterday and it was completely drained. It’s now lost 20% over half a day . This is absolutely ridiculous. Sonos reckon on standby it will last around 10 days but I can’t see this happening  we should be able to charge and be ready to pick up and go without charging everyday . I’m very disappointed I the roam for this. I thought maybe I was not turning off properly and came to see if I could find an answer and found this thread.  .. has anyone found a answer to the problem? It is driving me mad keep turning itself back on. I don’t want it on standby permanently, I have other options for getting the weather etc. I just want to charge the roam , turn off and be ready to turn on when I want to take it outside. Surely that’s the point of a portable speaker

Here’s my issue with using a Qi wireless charger. When I put the Roam on the wireless charger, it’ll turn on (if it’s off) and starts charging. The issue is when it’s charged to 100%, the Qi wireless charger stops charging. Once it stops charging, it won’t charge again even as the Roam discharges itself for being turned on. That’s why every time I take it off the wireless charger it’s already dead.

 

I am not sure if that’s my wireless charger issue that it won’t re-charge the Roam as it was draining? Does the Sonos wireless charger behave the same?

I have exactly the same issue. I've only used the Roam for 10 mins since having it delivered, but I've fully charged it 3 or 4 times, and switched it off after charging = put it to sleep. 

My observations is that it keeps waking from sleep without my touching it, draining the battery and next time I look at it I have an orange light and depleted battery. I suspect it something about sitting on my Sonos WiFi network. I may put it in BT mode, put it to sleep and see if it stays asleep. 

Hopefully an update will fix this problem. There is definitely an issue with sleep management and impact on battery life. 

I am so frustrated after living all of my other sonos devices.  I dont want it to sleep, i want it to be off inless i turn it on.  Ive tried to use it twice after fully charging, thinking im switching off and then leaving until I want it. So far its had zero use as has never had charge when ive needed it.  Totally useless given its purpose.  I have a £100 sony speaker tgat works perfectly and just as i expect to use it.  It even keeps a charge !  Hoping sonos come up with an update that actually switches it off.

Userlevel 7

I have exactly the same issue. I've only used the Roam for 10 mins since having it delivered, but I've fully charged it 3 or 4 times, and switched it off after charging = put it to sleep. 

My observations is that it keeps waking from sleep without my touching it, draining the battery and next time I look at it I have an orange light and depleted battery. I suspect it something about sitting on my Sonos WiFi network. I may put it in BT mode, put it to sleep and see if it stays asleep. 

Hopefully an update will fix this problem. There is definitely an issue with sleep management and impact on battery life. 

I am so frustrated after living all of my other sonos devices.  I dont want it to sleep, i want it to be off inless i turn it on.  Ive tried to use it twice after fully charging, thinking im switching off and then leaving until I want it. So far its had zero use as has never had charge when ive needed it.  Totally useless given its purpose.  I have a £100 sony speaker tgat works perfectly and just as i expect to use it.  It even keeps a charge !  Hoping sonos come up with an update that actually switches it off.

If you want to turn it off, hold down the button on the back for five seconds until you hear a chime. I always turn off my Roam when I’m not using it and it keeps the battery charged for anytime I need it.

I hope an update is coming because I’m over going to use my roam and it’s dead. Out of the five times I’ve wanted to use it I have only been able to use it once. I have to leave it on the charger when not in use otherwise it will be dead when I go to use it. When it’s on the charger and it gets to 100% there is no way to turn it off. If I hold the power button for five seconds it turns off but within a few seconds it turns itself back on again. If they don’t say a fix is coming within a week sadly it’s going back.

If you hold the power button for 5 seconds the power light will go off and the Roam will shut off.  Open the Sonos app and click “System” and it should show the Roam as “Offline.”  If the Roam turned back on when you opened the app, you likely did not hold the power button long enough.  I charged my Roam yesterday and powered it off and turned I back on 24 hours later and was still at 100%…..Before I figured this out I was losing 25% of the battery charge per day.

Userlevel 5
Badge +6

Those having issues where it’s draining whilst completely switched off, I would suggest that it wasn’t properly powered off. Because I only use mine occasionally in the bathroom I have to power mine down between uses and can confirm that it only uses about 1% of the battery per day in that state.

What I will say though is that the button is very fiddly and quite awkward to use. A few times I’ve pressed and held it but it’s put itself into Bluetooth mode instead and so I’ve had to repeat the process making sure it does power down completely. I always check the Sonos app to make sure that it says ‘offline’ against that unit.

I’ve seen this mentioned a few times and it’s something I want - please Sonos allow the Roam to be completely powered down from the app. This would make things a lot easier for users and would get rid of the confusion caused when people think that they’ve powered it down.

 

I hope an update is coming because I’m over going to use my roam and it’s dead. Out of the five times I’ve wanted to use it I have only been able to use it once. I have to leave it on the charger when not in use otherwise it will be dead when I go to use it. When it’s on the charger and it gets to 100% there is no way to turn it off. If I hold the power button for five seconds it turns off but within a few seconds it turns itself back on again. If they don’t say a fix is coming within a week sadly it’s going back.

Very unhappy with Same situation.  Poor design. 

Userlevel 4
Badge +9

So I woke up early and walked into my bathroom at 3 AM (everyone in the house had been asleep for HOURS).  Guess what, the Roam little white LED was on!  This means although no one had been using the Sonos App for many hours, the Roam somehow powered on from sleep mode.   Why would it do that?   This may explain why I’m seeing only 2 to 3 days (max) in sleep mode.    

Could it be activity in the app that doesn’t require user interaction (like music library index updating); checking for software updates -- also triggers the Roam to wake from sleep mode?

 

 

So its not just me then? How stupid and annoying is it to create a battery powered mobile device that keeps turning itself on and running out its battery so that it never works when you want to use it. A battery powered mobile device needs turning on manually and should turn itself off if not used for 15 minutes. 

I am constantly turning the damn thing off when i see a light has come on for some reason. It’s a mobile device. It doesn’t need to be constantly connected to my networks or listening. If its off leave it off.

Sonos if you are listening please change the logic so that pushing the rear button once turns the device off completely rather than “sleep and automatically wake up constantly mode”.

Additionally it might make sense for them to engineer a recessed power button that is less likely to get pushed when in a bag. From an industrial design perspective, like everything SONOS builds, it’s beautiful and I see how they matched the power button dimensions to the USB-C port (but doubled the length). A good software solution alternative would be to create a power off “LOCKED” mode. This would require you to depress two (2) buttons power up again i.e. depressing the power button + play/pause button simultaneously for 5 seconds to power up after being “LOCKED”.

Hi @Xander P - Thanks for your help - much appreciated.  It’s a shame that the Set Up & User guide make no mention of this (definitely something that needs to be included to avoid lots of people like me complaining :slight_smile: ).  Anyway, I am pleased that you’ve responded so quickly, and pleased that there is no need for me to return the product.  Thanks again.

I have exactly the same issue. I've only used the Roam for 10 mins since having it delivered, but I've fully charged it 3 or 4 times, and switched it off after charging = put it to sleep. 

My observations is that it keeps waking from sleep without my touching it, draining the battery and next time I look at it I have an orange light and depleted battery. I suspect it something about sitting on my Sonos WiFi network. I may put it in BT mode, put it to sleep and see if it stays asleep. 

Hopefully an update will fix this problem. There is definitely an issue with sleep management and impact on battery life. 

I have the same issue as everyone here regarding power and battery life.  Another annoying ´feature´ is that it seems I have to plug it in to get the system to actually find it, otherwise the system tells me it’s offline.  Great sounding product, but I’m considering returning because of these design flaws.

Userlevel 6
Badge +15

Hi @caesar327, this is by design, so that the Roam is ready to play when you open the app. I can certainly pass this on as a feature request, however for the time being your best choice to conserve battery when not in use, is to power off the Roam completely.

I’ll be sure to pass on your feedback regarding the Set Up & User Guide @thornen, it does seem that there’s been a bit of avoidable confusion regarding the power button functions on the Roam :)

Userlevel 1
Badge +2

@sdtheclub 

That the roam turns on again with fully charged battery if you have turned it off, only happens when it‘s connected to a QI charger. The reasons are how QI charging works and the fact, that roam always turns on if it‘s connected to a power supply. 
If connected to power using the usb c cable roam can be turned off completely even the battery is charged fully. 

Userlevel 4
Badge

Got up this morning and the red light was flashing. The roam was completely dead and it was on the wireless charger since yesterday. The charger is working so for whatever reason the roam will no longer charge from it. I plugged the roam in using the supplied charging cable a few hours ago and I’m now once again waiting for it to charge back up. 

Userlevel 5
Badge +6

Got up this morning and the red light was flashing. The roam was completely dead and it was on the wireless charger since yesterday. The charger is working so for whatever reason the roam will no longer charge from it. I plugged the roam in using the supplied charging cable a few hours ago and I’m now once again waiting for it to charge back up. 

I’ve had similar experience with a qi charger. Personally I’ve taken the qi charger out of the loop for now as the Roam won’t work with it reliably IME.

Ken, 
Thanks for that link. I’ve always been pronouncing that as “Kee”, rather that “Chee”. Good to know I was wrong, and will use the appropriate pronunciation from now on. 

Interesting read, beyond that nugget, too. :)

Userlevel 4
Badge

Got up this morning and the red light was flashing. The roam was completely dead and it was on the wireless charger since yesterday. The charger is working so for whatever reason the roam will no longer charge from it. I plugged the roam in using the supplied charging cable a few hours ago and I’m now once again waiting for it to charge back up. 

Just curious, is it a ‘certified’ Qi charger? 
https://www.howtogeek.com/425885/what-is-a-qi-certified-wireless-charger/

Yes it’s Qi certified. It’s a JW 04087. I own several of these and they work great will all of my other devices

Userlevel 6
Badge +15

Hi @caesar327 and @Plums  - I do understand the feature request and as mentioned I will be happy to pass that on for you :)

Userlevel 1
Badge +2

I’m going to post this everywhere I can. The “auto turn on” feature is SO.DUMB.

Makes this product trash, basically. I’ll probably be returning it. 

Every other bluetooth speaker I’ve used before has auto-turn OFF. That makes 10000% more sense than auto-turn on. It would NOT be a big deal to turn my Roam on right before I want to use it. Who cares about a 2-second delay if your Roam is always dead !? 
 

I suppose it depends how you use it. They probably expect most people will keep it on the charger when they’re on WiFi.

 

Reply