Roam is always turning itself on and the battery is always dead making the roam unusable

  • 25 April 2021
  • 94 replies
  • 10171 views

Userlevel 4
Badge

I hope an update is coming because I’m over going to use my roam and it’s dead. Out of the five times I’ve wanted to use it I have only been able to use it once. I have to leave it on the charger when not in use otherwise it will be dead when I go to use it. When it’s on the charger and it gets to 100% there is no way to turn it off. If I hold the power button for five seconds it turns off but within a few seconds it turns itself back on again. If they don’t say a fix is coming within a week sadly it’s going back.


94 replies

Badge

Same problem for me, turn the Roam off not plugged because was full charge to be used next day, but not surprised battery empty again without even been used all night. Very disappointed I have to use my old Bose mini for my excursion again. 
I’m going to return this speaker, first time that Sonos disappointed me. 

Userlevel 7

@Matt.hutch1966 @Cricho When you press and hold the button on the back for about five seconds to power off the Roam, do you hear a descending chime? This chime is how you know the Roam has been successfully turned off. If it is powered off completely, it should only lose 1%-2% of battery charge per day.

Userlevel 1
Badge +1

Yep did all of that, this is a new issue, had the sonos roam since release, never had this before 

Userlevel 5
Badge +6

If the Roam is still showing in the app then it is not completely powered down. You have to keep doing it until it shows “offline” in the app. You may have to refresh the app for it to display as offline unless you leave the app for a minute or so.

It’s my belief that many people are stil thinking that they’ve powered it down completely but haven’t due to the very fiddly button and the fact that it doesn’t always work properly.

 

Badge

I supposed that this speaker were designed to stay in standby and not consume that amount of battery. Otherwise is only working when turning on, and not very useful to keep in a backpack  if you are longer hours walking or travelling and not having any electric plugs around. The speaker turn useless, and not fitting for porpouse. 

Userlevel 5
Badge +6

I’ve only just realised that when you connect the Roam to a charger, it actually powers it up even if the unit was powered completely down. I suppose it has to  but I still wasn’t aware that this happens.

I noticed because I used the Roam whilst in the bath and powered it down completely so that it showed as offline in the app. I then decided to charge it and noticed that it had powered on and remained powered on after I’d finished the charging process. I suppose it needs to be on to report the percentage battery ?

 

Badge

I have terrible and sad experience with Roam. I guess my unit showed me all possible problems described in this thread. First, I had to update my system to S2, it was not problematic but I had to stop using Connect:Amp I bought a few years ago :frowning2:  Adding Roam to S2 in the app was not straightforward neither was the Bluetooth setup.

Since I managed to include Roam in my app together with 3 other rooms, the real problems started. Terrible battery life, every other time I tried to use Roam, it was out of power. Charging took too long, I could not turn it on and use while charging, it was not responding and I could only see an orange led light. When I left the Roam in the original magnetic charger for some time, the Roam became frozen, I had to restart it to start using it again. Sometimes the BT connection could not be established. I managed to move the sound to another device once or twice, most of the time it was simply not working. When I left fully charged Roam off the charger yesterday night, it was not responding in the morning (/off-line in the app) and I could not wake it up using any method described here. After charging for 30 minutes I could finaly restart it, it suddenly claimed 96% of power. My wife refused to use Roam. 

So I am sending it back to Sonos. 

I have terrible and sad experience with Roam. I guess my unit showed me all possible problems described in this thread. First, I had to update my system to S2, it was not problematic but I had to stop using Connect:Amp I bought a few years ago :frowning2:  Adding Roam to S2 in the app was not straightforward neither was the Bluetooth setup.

Note: You don’t have to stop using the C:A, just simply reset it and set it up using the S1 App - it will continue to work just fine.

Since I managed to include Roam in my app together with 3 other rooms, the real problems started. Terrible battery life, every other time I tried to use Roam, it was out of power. Charging took too long, I could not turn it on and use while charging, it was not responding and I could only see an orange led light. When I left the Roam in the original magnetic charger for some time, the Roam became frozen, I had to restart it to start using it again. Sometimes the BT connection could not be established. I managed to move the sound to another device once or twice, most of the time it was simply not working. When I left fully charged Roam off the charger yesterday night, it was not responding in the morning (/off-line in the app) and I could not wake it up using any method described here. After charging for 30 minutes I could finaly restart it, it suddenly claimed 96% of power. My wife refused to use Roam. 

So I am sending it back to Sonos. 

Thats your prerogative, but it sounds like you maybe using the power button incorrectly for what your perhaps attempting to achieve with the device. Maybe see if these YT videos will assist you (and the Wife) at all…

https://youtu.be/GDf4CUvmLmo
https://youtu.be/29w2rGVs5X4

Badge

Note: You don’t have to stop using the C:A, just simply reset it and set it up using the S1 App - it will continue to work just fine.

@Ken_Griffiths Ken, that’s what I did. But I cannot use it as part of one multiroom system as you certainly know. That’s not “just fine” but very annoying and disappointing. Nevertheless I knew this before obtaining the Roam.

Thats your prerogative, but it sounds like you maybe using the power button incorrectly for what your perhaps attempting to achieve with the device. 

I spent a lot of time finding a solution, that’s not the problem. I did my very last test today. In the morning, I left charched Roam in a living room, near the wifi router. It was turned on in the morning so I guess it was in a stand-by mode during the day, I didn’t push any button, I just stopped the playback. Few hours ago I came back home. Roam was again “frozen”, the white led next to the logo was on but the unit didn’t react to any buttons, it was not visible in the Mac app and it was off-line in the phone app. I had to hold the power button for a long time to resurrect Roam.

I already have the return label so it is time to send the parcel back to Sonos. The positive effect is, I can downgrade back to S1 and control all rooms from one app. The negative effect is, I have to find a good battery powered player for my bathroom.

Note: You don’t have to stop using the C:A, just simply reset it and set it up using the S1 App - it will continue to work just fine.

@Ken_Griffiths Ken, that’s what I did. But I cannot use it as part of one multiroom system as you certainly know. That’s not “just fine” but very annoying and disappointing. Nevertheless I knew this before obtaining the Roam.

Thats your prerogative, but it sounds like you maybe using the power button incorrectly for what your perhaps attempting to achieve with the device. 

I spent a lot of time finding a solution, that’s not the problem. I did my very last test today. In the morning, I left charched Roam in a living room, near the wifi router. It was turned on in the morning so I guess it was in a stand-by mode during the day, I didn’t push any button, I just stopped the playback. Few hours ago I came back home. Roam was again “frozen”, the white led next to the logo was on but the unit didn’t react to any buttons, it was not visible in the Mac app and it was off-line in the phone app. I had to hold the power button for a long time to resurrect Roam.

I already have the return label so it is time to send the parcel back to Sonos. The positive effect is, I can downgrade back to S1 and control all rooms from one app. The negative effect is, I have to find a good battery powered player for my bathroom.

Hi @MH92,

 

I hope this message reaches you before returning the Roam.

 

We were aware of an issue affecting some Roams on a certain version of firmware that could prevent them from waking from sleep, and your post seems to reflect this. This issue has since been fixed via a software update. If you still have your Roam, please turn it on and update it via the Sonos app and let us know if this solves the problem for you.

Badge

Hi @MH92,

We were aware of an issue affecting some Roams on a certain version of firmware that could prevent them from waking from sleep, and your post seems to reflect this. This issue has since been fixed via a software update. If you still have your Roam, please turn it on and update it via the Sonos app and let us know if this solves the problem for you.

Hi @James L. , thank you for your suggestion but I did check for updates a few days ago so I guess I was using the latest available software. After my very bad one month experience with Roam and after reading this discussion forum, I have completely lost confidence in this device. It is also obvious the claimed battery life (up to 10 days in standby mode) has nothing to do with reality. I have already performed a factory reset and have no reason to make further experiments.

Hi @MH92,

We were aware of an issue affecting some Roams on a certain version of firmware that could prevent them from waking from sleep, and your post seems to reflect this. This issue has since been fixed via a software update. If you still have your Roam, please turn it on and update it via the Sonos app and let us know if this solves the problem for you.

Hi @James L. , thank you for your suggestion but I did check for updates a few days ago so I guess I was using the latest available software. After my very bad one month experience with Roam and after reading this discussion forum, I have completely lost confidence in this device. It is also obvious the claimed battery life (up to 10 days in standby mode) has nothing to do with reality. I have already performed a factory reset and have no reason to make further experiments.

Understood. The update I mentioned was released on Monday so there’s a chance you haven’t updated your Roam to that version yet. 

 

We’re here if you change your mind and decide to give it a try.

Userlevel 5
Badge +6

I downloaded the very latest version yesterday and that allows you to set the Roam to power off when not used for 30 minutes and I can confirm that it did indeed power mine down completely.

This suits my usage perfectly as I always turn it off completely between uses and it saves me having to mess around with the very fiddly power button :)

Much appreciated Sonos.

 

I downloaded the very latest version yesterday and that allows you to set the Roam to power off when not used for 30 minutes and I can confirm that it did indeed power mine down completely.

This suits my usage perfectly as I always turn it off completely between uses and it saves me having to mess around with the very fiddly power button :)

Much appreciated Sonos.

 

Glad to see you’re enjoying the new battery saver mode! I’ve passed your feedback on to our dev team :slight_smile:

I downloaded the very latest version yesterday and that allows you to set the Roam to power off when not used for 30 minutes and I can confirm that it did indeed power mine down completely.

This suits my usage perfectly as I always turn it off completely between uses and it saves me having to mess around with the very fiddly power button :)

Much appreciated Sonos.

 

Glad to see you’re enjoying the new battery saver mode! I’ve passed your feedback on to our dev team :slight_smile:

Jame L. it would be much better if I could set my Roam to NOT auto-turn on. Ever. Having the speaker turn on anytime the sonos 2 app is in the foreground is a poor user experience for the use case of having speakers through a house and in use throughout the day.  Really don’t want the Roam waking and draining at all after i’ve manually turned it off.  Thanks for passing it on to the UX and dev teams. :relaxed:

Me too.  I have the latest version of the software and my Roam wakes from sleep mode *even if I have my phone turned off.

I’m so disappointed in what I hoped would be a premium brand experience.

Can we *please* have an option to disable the wake on LAN functionality?  Please?

Me too.  I have the latest version of the software and my Roam wakes from sleep mode *even if I have my phone turned off.

I’m so disappointed in what I hoped would be a premium brand experience.

Can we *please* have an option to disable the wake on LAN functionality?  Please?

 

Did you turn the Battery Saver option on in the settings?  

Me too.  I have the latest version of the software and my Roam wakes from sleep mode *even if I have my phone turned off.

I’m so disappointed in what I hoped would be a premium brand experience.

Can we *please* have an option to disable the wake on LAN functionality?  Please?

 

Did you turn the Battery Saver option on in the settings?  

Thanks for the reply and advice there.  I hadn’t!

I have now - much appreciated.  Let’s see how this goes :)

Me too.  I have the latest version of the software and my Roam wakes from sleep mode *even if I have my phone turned off.

I’m so disappointed in what I hoped would be a premium brand experience.

Can we *please* have an option to disable the wake on LAN functionality?  Please?

 

Did you turn the Battery Saver option on in the settings?  

Thanks for the reply and advice there.  I hadn’t!

I have now - much appreciated.  Let’s see how this goes :)

 

So the battery saver does work.  It’s equivalent to long-pressing the power button to turn it off completely (with a time delay).

I would love to be able to put it into sleep and not have it wake up - except by pressing the on button.  This network wake should be optional imo.

Even if I have my phone and tablet wifi turned off, the Sonos wakes from sleep :(   I can only assume that some other device on my network (TV?  Google Home?  Smart plug/bulbs?) are pinging the Roam on one of it’s open ports that sense for waking (1400, 1401 and couple of others).   So now I guess I’ll try disabling everything the the house and see whether the Roam can be made to stay in sleep … There goes the weekend :/   Or maybe try to use a packet sniffer to find the device.  Any ideas anyone?

 

Reply