Returns Request

  • 26 April 2018
  • 7 replies
  • 337 views

Badge
I recently requested a returns authorisation under the 100 day policy, and so far i have not received anything.

I had an email confirming it had been accepted and i was going to hear from you shortly with a shipping label to return the product which i have not had.

Could someone look into this please.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 7
Badge +19
Hey there, JasonSparrow. Thanks for posting about this. In most cases regarding a specific returns request, I'd recommend giving our Sales team a call to get this sorted. If I remember correctly, the shipping label is an attachment to the confirmation email you received.
Badge
Thanks but everyone keeps telling me to call in etc but this is not possible for me during working hours.

I had no attachment to any emails I have received from you.

I really don’t understand how this is so difficult.
Userlevel 7
Badge +21
Thanks but everyone keeps telling me to call in etc but this is not possible for me during working hours.

I had no attachment to any emails I have received from you.

I really don’t understand how this is so difficult.


It isn't unless you make it difficult.

You reached out for advice and were asked to call in. Whether or not you care to follow your advice is entirely up to you
Badge
Good morning Stuart and thanks for your input.

As I said, I am not able to make calls during office hours, and initially everything was being done via email.

I have had some replies, and was emailed yesterday To be told that I would receive my returns note within the hour.

The reason for the delay was down to my request being stuck in the system.

As of today, I still have not received anything at all.
Userlevel 7
Badge +21
They are generally very good. I've arranged two faultless RMAs, via telephone, Keith N will have checked if there are open cases with the e-mail you used to post here and assuming it's the same as the one your system is registered to than it may be that he has seen something that is causing an issue with the RMA being e-mailed.

I hope you did your e-mail but you might do well to plan to call Sonos.
Badge
Well, as an update,I did as suggested and called and spoke to someone and was promised a returns note within 24 hours.

Surprise, surprise nothing has come through.

Perhaps someone would like to tell me what I have to do to actually get a result?
Userlevel 7
Badge +19
Hi there, JasonSparrow. I reached out to our Product Returns team about your specific case and determined will need the EMEA team to process and resend your shipping label. I will reach out to you with a PM regarding further details. Thanks for your patience.

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings