Answered

Play 5 totally dead

  • 4 September 2017
  • 10 replies
  • 627 views

My Play 5 has completely stopped working. I've tried a different power lead and outlet and no luck. It's first gen but I've not had it that long, since April 2016. How do I go about getting it replaced (hopefully) or fixed? Thanks.
icon

Best answer by Stuart_W 8 September 2017, 13:58

Your best bet is probably to call support as they will want to run through a number of diagnostics and checks with you before they get to any warranty discussion.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Any response from Sonos support on this?
Userlevel 7
Badge +21
Your best bet is probably to call support as they will want to run through a number of diagnostics and checks with you before they get to any warranty discussion.
Thanks. Nearly an hour in the queue though. Ready to give up.

Badge
out of curiosity, do they give you an option to call you back?
No they don't. I gave up after 75 minutes.
Badge
Sorry you had to endure that. I hope you get this worked out. Im curious as to see what steps to try if this should ever happen to me.
Userlevel 6
Badge +3
No they don't. I gave up after 75 minutes.
Hello Afroken, we are experiencing higher than normal volumes of calls today. While you wait, is there anything we can help you with?
I gave up waiting. You could answer my original query though?
Userlevel 6
Badge +3
I gave up waiting. You could answer my original query though?
Sure thing. Can you send me by private message your email address and the serial numbers of the 5 PLAY:5 in question. Also, add your phone number and I'll create a support ticket for you.
Userlevel 7
Badge +26
Thanks for helping out Stuart and Tmoy, we were able to get on the phone with Afroken and hopefully all is well now.

Have a good weekend everyone!