No Sonos Sound


I have two Sonos One speakers.  One in the office and the other in living room.  When I turn on a Sonos station (e.g., Sirius XM) with the Sonos app, I get sound from the living room speaker but not the office speaker.  I then have to tweak the WiFi settings to get a connection where the office speaker has sound.  I have to do this every time I start up the Sonos speakers and it doesn’t matter which station I am trying to connect to through the Sonos app.  It gets a little tiresome!

If I start up a station using the station’s own app such as the Sirius XM app (not the Sonos app), then when I connect the Sonos speakers they both have sound.

Why do I have to keep tweaking the WiFi settings to get sound from the office speaker when using the Sonos app?


12 replies

Userlevel 7
Badge +17

What Wi-Fi setting do you tweak? Are you able to connect one of your speakers directly to your router using an ethernet cable?

I’ve tweaked both 5GHz channels and 2.4GHz Wireless Network.  It usually works on one of the following channels on the 2.4GHz: 1, 6, 11 but not always.  It sometimes works by setting the channel back to Auto.  I’ve even had it work by doing nothing and just click the Save button.  Nothing seems to work “consistently” from one Sonos episode to the next.

Connecting the speaker to the router via ethernet is not an option in my current configuration of the two speakers.  The router is too far away.  I have, however, taken the Office speaker to the router and connected it and it works fine.

Still don’t understand why trying to connect to a Sirius XM station, for example, through the Sonos app the office speaker doesn’t work without tweaking but it does work if I connect directly to the Sirius XM app and then connect the speakers.

  I have, however, taken the Office speaker to the router and connected it and it works fine.

 

Do both speakers in their usual locations work well with this setup? (you’ll need to try this arrangement both ways) If so, consider wiring a BOOST to the router.

‘Auto’ channel selection is almost always a bad idea because the wireless routers almost always pick a channel that is not 1, 6, or 11 and this will create interference for everyone in the area. Even if the router is smart enough to use only 1, 6, or 11, if it is constantly jumping channels, this will frustrate SONOS and prevent everyone from working out a reasonable band sharing arrangement.

Can I just check something basic here …  do you have the speakers grouped in the Sonos app when this happens?  Or are you saying that the office speaker doesn’t work when you try to play to it individually?

It sounds like it may be suffering from a combination of distance from your router and wireless interference.  As an experiment, put it near (a few feet away) the living room speaker and see how it behaves.  If it is fine there, try it back in the office but in a different position - even a small move may have a significant effect.

I admit that the fact that it works from the native app suggests that may not be the issue, but I still think worth trying.

Thanks to all who have responded to help me with this no sound issue.

The Living Room and Office Speakers are set up as a group when I get no sound from the office speaker.  My office is a 12 x 10 room and I have had the speaker on each of the four walls at some time to see if this makes a difference.  It does not.  The 2.4HGz network is almost always set to channels 1, 6, or 11.  I agree that Mixed shouldn’t be used.  But since I am the only one here in this place I’m looking for anything that works.  Should the WiFi settings be tweaked in any other way than just changing channels?

Yesterday I was playing the Sonos on 2.4HGz channel 1.  This morning when I turned the system on with Sonos app to play a Pandora station, no sound came from the office speaker.  As far as I know, nothing was changed from the night before??  And as I indicated previously, when I connected directly to the Pandora app, both speakers play fine through AirPlay.

I have not, as yet, connected a boost (Sonos Boost??) to the router.

Yes, a SONOS BOOST. First explore my test of moving and wiring a remote speaker to the router, then return the first remote speaker to its regular position and bring the other remote speaker to the router. If both of these arrangements work well, then add a BOOST.

You could submit a diagnostic and get SONOS staff comment. Difficult wireless conditions will leave tracks in the diagnostic.

Another avenue to explore is to build your Group in the opposite order. The first member of a Group is the Group’s “Coordinator”. All traffic for the Group passes through this unit. If this unit is struggling with its connection, the Group will suffer. You are attempting to use the best connection for the Coordinator.

When the Group order is Living Room, Office, the LR speaker plays, the office speaker is silent

When the Group order is Office, Living Room, the Office speaker plays, the LR speaker does not

Perplexed

I did submit diagnostics but not yet contacted sonos staff.

 

Likely, you have a very difficult WiFi environment in the vicinity of one or both of the players. The diagnostics will highlight this. Moving a player in its room might change the dynamics.

Note that as indicated in the Diagnostics - How do they work? thread, you’ll need to call Sonos Support directly to discuss it. I suspect there are thousands of submissions, and a significant portion of them in error. They will need the number and likely some knowledge about what they are looking for. 

On Saturday I called Sonos Support but got no phone response.  So I started up a Chat session.  Talked to a machine for a while but was then switched to a real person.  They walked me through a lot of questions and had me try different things to try to get sound from the office speaker (e.g., changing 2.4HGz channel, rebooting router, rebooting speaker, changing speaker location, turned off other devices using router, etc).  We finally generated sound from the office speaker after about an hour and right after rebooting the router.  We closed the chat session.

The next day I turned on the Sonos system and, again, no sound from the office speaker.  I first rebooted the router again but no change.  I then tweaked the 2.4 HGz wifi channels in order to get sound as I have been doing for months.

Maybe I am a special case that just has to bypass the convenience of the Sonos app in order to have sound from both speakers.  As I have written previously, playing a Pandora station, for example, through the Sonos app requires tweaking WiFi channels in order to get sound from both speakers.  Playing the Pandora app directly (without going through the Sonos app) requires no tweaking and sound comes from both speakers.

Still perplexed.

In your router setup do you ‘fix’ or ‘reserve’ IP addresses? If not, I recommend doing this. Endlessly rebooting the router can result in duplicate IP addresses. Reserving IP addresses will minimize this risk. A network scanner, such as FING, will highlight duplicates, but this is not guaranteed. Basically the scanner asks “everyone, tell me your IP address” and flags duplicates. Unfortunately, if a duplicate device is sleeping at the time of the scan, the duplicate device may not be flagged.

is moving and wiring one of the speakers always successful? Have you tried this both ways? Did the support person look at the diagnostic and comment on the WiFi environment?

Reply