Nintendo Switch Controller Connection Issues

  • 16 January 2021
  • 5 replies
  • 60 views

I just got a Sonos Beam soundbar for our living room and there seems to now be a slight delay on my game controllers for the Nintendo Switch. As soon as I disconnect the speaker it starts working like normal. Any ideas on how to fix this or why this is happening?


5 replies

Userlevel 6
Badge +17

Hi @Mattr767.

Welcome to the Sonos community and thanks for reaching out to us. Allow me to help out by sharing some information and asking questions to better get an understanding of the situation.

  1. Do we have the same behavior when listening to music?
  2. How do we get audio from your Nintendo switch to your Sonos?
  3. Do we have thesame situation when we change sources like watch TV, watch movie via in-app movie sources such as Netflix, YouTube, etc.
  4. Can we try to submit a diagnostic after 3-5 minutes after the issue re-occured?
  5. Can we check the TV audio quality and make sure it is set to PCM and check if the issue still persists?
  6. Can we check the TV audio quality through the TV menu and set it to 5.1 surrounds if it is available and observe if the issue persists?
  7. Can we try to unplug all Sonos devices from power and then plug them back into power after 10-15 seconds and observe if the issue persists?
  8. Can we check what is the audio output from your Nintendo switch if this is not possible, please do not hesitate to reach out to the manufacturer?
  9. Can we also try to submit a diagnostic at each try of different video source?

The more information you provide, the more we can better understand what is going on to help you out.

Thanks,

Paul thanks for the response! 

Just to clarify there is not an issue with the audio while playing on the Switch. The delay is coming from the controllers while I play. The controllers are wireless Pro controllers for the Nintendo Switch and I believe it may have something to do with some sort of wireless interference. I know it’s the speakers because as soon as I disconnect the Beam the controllers work like normal.

As far as the set up I have a Beam and 2 One SL in the back for surround sound. The beam is connected to my TV using HDMI ARC and my switch is connected to the TV using HDMI. My router is near the TV but has never caused issues with the controllers before until I bought the beam. I have tried to set up the Beam using WIFI and then also attempted to plug in through the ethernet cord. Currently, I need to disconnect my Beam every time we play and use the TV speakers rather than the surround sound in the room in order to prevent the delay on the controller. If anyone has a solution please let me know!

Userlevel 6
Badge +17

Hi @Mattr767.

Thanks for the update and immediate response.

How does the controller behave when the Beam is connected via ethernet cable? I would suggest unplug all Sonos devices from power, connect the Beam via ethernet cable first to the router (while unplugged from power) and once the Beam is connected via ethernet cable, plug it into power. Once the Sonos Beam has a solid white light, plug into power the 2 Sonos One SLs. Please follow these procedure to make sure that the Beam transition from wireless connectivity to wired connection and check if the issue persists with the delay. If it does, How will the controller behave if we try to keep the surrounds unplug from power and only the beam is powered on. Do we have an improved controller response?

Wireless interference may possibly be the issue and that instead of the controller’s wireless interference disrupt Sonos, its the other way around. Sonos interferes with the controller’s wireless connectivity. 

let me know how it goes and keep me posted.

Thanks,

I already had my beam connected to the router but looking again there is a way to disable the wifi in the device through the app. However, when I disable wifi to the Beam it no longer plays audio to the back speakers. They still show up connected on my app and I can play/pause music on the back speaker with the buttons but no audio will come out of them. Do all of them now need to be wired or can the Beam be wired and the rest wireless?

I already tried removing the surrounds and re-adding them and this was not working.

Userlevel 6
Badge +17

Hi @Mattr767.

Thanks for your immediate response and update.

 However, when I disable wifi to the Beam it no longer plays audio to the back speakers. They still show up connected on my app and I can play/pause music on the back speaker with the buttons but no audio will come out of them. Yes this is normal, If we diable the Wifi capability of the Beam, the Beam cannot communicate to your satellite speakers wirelessly. as the Beam communicates directly to your satellite speaker via it’s 5G network.

 

Do all of them now need to be wired or can the Beam be wired and the rest wireless? We only need to have the Beam wired to the router and the satellite run wirelessly as the beam communicates to them directly. 

 

I already had my beam connected to the router but looking again there is a way to disable the wifi in the device through the app. If we only connect the ethernet cable to the Beam of connect the Beam to the router via ethernet cable without following the steps as indicated above, your Beam will still ahve the chance to run wirelessly even having an ethernet cable connected to the beam. The best way to be sure that the Beam connects via ethernet cable is to connect the ethernet cable first to the Beam (while the Beam is unplugged from power) and then connect the beam to power. 

 

Please let me know if you have further questions and concerns and let me know of the result.

Thanks,

Reply