Question

New LG TV's and 5.1 pass through

  • 23 February 2015
  • 65 replies
  • 88458 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

65 replies

Hey, just signed up to say that there is a website doing this kind of testing on most of the TV's that come out. I will post the link here because I think it would be helpful.

Link: http://www.rtings.com/tv/tests/inputs/5-1-surround-audio-passthrough

Edit: Looks like someone beat me to it. Weird, for some reason my ad blocker wasn't showing the rest of the comments.
I got a new LG OLED 65” TV a few weeks ago, and this has been driving me nuts. I have a Sonos Playbar, with surround speakers and sub, and an 4K Apple TV. The sound would sometimes be fine, and sometimes it would just go mute. It would typically start happening when i tried to play something in 4K HDR 5.1 from Netflix. Once the sound went away, there was nothing i could do would fix it, except to go to one of the LG internal apps, like Netflix and Amazon, and play something. After that I could go back to the Apple TV (on HDMI 2), and things would play fine. For awhile.
When the sound would go away, if I looked on the Sonos app, it would say Unsupported TV Audio. I read everything on these boards, and tried fiddling around with the various Sound preferences in the LG menu. Nothing seemed to make much difference, but I settled on having the sound Sound Out through Optical, with the Sound Out set to Auto. I also set AV Sync Adjustment to Bypass. But again, this didn’t seem to make much difference.
I finally tracked down a way to reproduce the symptoms: If I watched regular TV (actually a TiVo), and then switched to the ATV on HDMI 2, and tried to play a 5.1 video, sound would go mute. After that, I could go back to TV, and it would stay mute, until I did the fix I described above. However, if I went from TiVo to ATV and played a regular video without 5.1, everything would be fine.
Powering off and on the TV made no difference. However, I finally realized that the TV was set to QuickStart+ (in the General menu). When i turned that off, cycling the TV power restored the sound. Oh, and by the way, i now see Dolby 5.1 on the Sonos App.
So that’s what I now do: i keep QuickStart+ off (it takes a couple of extra seconds to turn on the TV), and then everything always works fine, EXCEPT if I switch from TV to ATV and start watching a 5.1 video. If that happens, i just have to power cycle the TV, and i programmed a macro on my Harmony remote to quickly do it.
I think this is an LG/SONOS issue, not Apple. I have the same behavior with a Roku 4K.
Hope this helps.
@Publicpersona2001 I think you should try updating your TV’s software when you get a chance. Here’s the release notes for the latest version:
[04.70.36]
1. To improve OLED model Dolby no audio issue when switching HDMI input

Hope that hopes!
My TV says its software version is 04.70.07, but when I ask it to check for updates it says No Updates Found. I assumed I was on the latest one, since that was one of the first things I checked when I was trouble shooting. Any ideas how to force an update?
OK, so i searched for LG software updates and found the update at http://www.lg.com/us/support/software-firmware-drivers . I downloaded onto a USB stick and updated it manually, and it looks at first glance that it did solve the problem. I'll check it out a bit more later today.

Thank you very much for letting me know. I have no idea why the TV was reporting no new updates. I see the date of this update is 12/12. Maybe they're doing a rolling deployment so as not to overwhelm their servers? In any case, i think this does work.

One tip, for any person trying to do this on a Mac: make sure your USB stick is formatted as an MS-DOS (FAT). You can do it under Disk Utility. I originally had a stick formatted as a Mac disk and the TV didn't recognize it.
Same issue with my setup*, unfortunately the 04.70.36 is not (officially) available yet here in Norway - due to slight model differences (US vs Europe) I’ll check with LG first and ask wether updating will be an issue.

*My setup, with the solution of powering tv on/off for gaining sound:
Lg oled b7 65, fw 04.70.30
Playbar (+sub and 2x one), fw 8.

Devices with sound issues, requiring tv on/off;
Cable box (dekoder) from Canal Digital (t-we)
Apple TV 4k
Amazon Fire TV 4k

After much research and troubleshooting (including the findings mentioned above), I’m quite confident the LG TV optical signal output is failing (lagging, when changing AV-sources with different sound formats).
I had very similar problems - I was complaining more about distortion that starts after a while, but I am having problems where the sound drops out too. I was able to confirm with LG support that the problem with the LG Digital Optical Out.

Here is what I just posted on tomsguide website

2017 LG OLED TV TOSLINK Digital Optical Out distortion

2017 LG OLED65B7P TV TOSLINK Digital Optical Audio Out has KNOWN distortion issues - CONFIRMED with LG Support on January 30, 2018.

My setup:
Directv hdmi -> TV -> Digital Optical Out -> Sonos Playbar
I have the TV sound in Auto mode (not in PCM) so 5.1 surround can work.

When I first turn everything on, the sound is fine.
After 10-30 minutes, strange distortion comes in after sound.
So in a tv show with dialog, every time someone stops talking (sound briefly drops) there is some strange distortion for 1-2 seconds.

Turning the tv and cable box off and back on temporarily fixes the distortion (but is a pain in the ass in the middle of a movie).

I went through support with Sonos and we determined that the problem was not the Playbar.

I went through support with LG and they CONFIRMED that this is a KNOWN problem with the tv digital optical out and that they are working on a fix but they could not say when the fix would be done.
I am posting this here so others can know that this is a confirmed problem with the LG TV software and/or hardware on the OLED65B7P.
I do not know what other LG TVs may have the same problem.

The fastest way to make the distortion go away without having to turn off the TV and video source - Settings/Sound/Audio Out/Digital Sound Out
Change the setting to PCM and then change the setting back to Auto and the distortion immediately stops - though it will come back again after another 10-30 minutes.

This problem would affect ANYTHING connected to the Optical Audio Out
So ANY soundbar or audio system that uses Optical input from the TV will have the same problem.

I think that if you were to leave the sound in PCM mode that the problem would probably go away too, but then you would lose all 5.1 surround sound info and instead get only left and right audio.

I will reply here when/if LG fixes the problem.
If they do not fix the problem soon, I will be returning my tv before the warranty runs out.
I was complaining more about distortion that starts after a while

Same here ?

IThe fastest way to make the distortion go away without having to turn off the TV and video source - Settings/Sound/Audio Out/Digital Sound Out
Change the setting to PCM and then change the setting back to Auto and the distortion immediately stops


Nice ??

If they do not fix the problem soon, I will be returning my tv before the warranty runs out.

I’ve already started researching deals for Sony’s KD-65A1.. ?
Getting the newer LG OLED65C7P, and just got my 5.1 components, play bar and play 1's. Hoping LG took care of these issues!!!!
Badge
I have my eye on the LG 65UJ634V . Anyone know if this would allow 5.1 passthrough?
I have an LG OLED65B7P and a Martin Logan Vision X soundbar connected with optical and get sound dropouts. I used to have a Denon receiver and then a ML Cadence - both with HDMI but I only get sound dropouts with the optical connection.

The LG manual claims the digital output is as follows

Badge +1
Getting the newer LG OLED65C7P, and just got my 5.1 components, play bar and play 1's. Hoping LG took care of these issues!!!!
I have the same TV and it works perfectly with the Playbase, gets stereo or 5.1 depending on the source, have never had any dropouts or sync issues (TV v. 04.70.36, Apple TV 4K as source). You just need to fiddle with the TV's settings a bit. Sound Out > Audio Out (Optical/HDMI ARC), AV Sync Adjustment > Off. DO NOT program an external source's remote (like Apple TV, Roku, etc.) to control the C7 first because if you do, when you put in the Sonos you'll get the "no entry" icon popping up on the screen every time you adjust the tv's volume with the other remote. Program that remote for the Sonos directly if possible.
Badge
Sorry for continuing this thread and I hope that this TV hasn’t been mentioned yet.
Currently I have Sky Q linked to Playbar through HDMI using 2 Play1s as surround sound. The TV ( LG 49UB850V-ZD ) is linked to Sky through 4k HDMI. Been very pleased with quality of sound. Just got Amazon Prime through SMART TV features and, at the moment, I can only play the sound through TV speakers. Will the TV optical output the same quality direct to Playbar? If not, what would be the best way to set-up please?
Thank you in advance,
Tech-numpty.
Take a look at the audio settings for those SMART TV features, it sounds like they're not currently set to Dolby Digital, but something else (DTS as a guess), which is why they'd only be playing through the TV's speakers, and not the Sonos.
Badge
Thanks. Will give that a go.