Line in sporadic audio issues

  • 11 September 2021
  • 3 replies

I have read a few of the questions similar to my issue and tried a number of the recommended fixes, yet I cannot resolve my intermittent audio issues related exclusively to my “Line In” configuration, could use some brain muscle…  I have 10 devices linked to my Sonos system along with multiple audio sources from which to hear the sweet sounds of Sonos in pretty much every room of my home.  However, no matter where I access my “Line-In” source, I cannot solve this intermittent sound hiccup, going silent from a millisecond to a few seconds at most.  Guaranteed to happen on any average 3.5 minute song as an example, and would expect 3-4, maybe more of these quick but painful black outs in this example, but nothing consistent to be clear.  Here is the configuration for this source…  I create hiking/travel trail review videos as a hobby and spend probably too much time on my PC (Windows 10 OS).  I wanted a better audio sound than my PC speakers so I physically installed my Play 3 in the same room as my PC, lets call that speaker product, PC ROOM.  Given everything I could find regarding PC audio to Sonos Product, I then installed a Logitech Bluetooth Audio Receiver near the PC and connected the Bluetooth from my PC to this Receiver.  The Bluetooth Receiver is then physically connected to a Sonos Connect (lets call this product source, COMPUTER, using a Logitech supplied 3.5MM cable from the Bluetooth Receiver, adapting to the Connect in the form of 2 RCA’s, using the Connects RCA Line In ports.  I then use my app controller to connect the PC ROOM (System) with my COMPUTER (Line In via Connect).  That is how I am configured physically and via Bluetooth.  As far as settings go, under Audio Compression for LINE IN settings I am currently back on “Automatic” but have tried Automatic, Compressed and Uncompressed separately to no avail.  I have the Settings on my Connect device (COMPUTER) set to source name “Computer”, Source Level to: Level 8 (Portable Player, PC) and finally, Audio Delay: Low (75ms).  While tinkering with compression settings I did try Level 4 (Airplay) and Level 2 (A/V Component) in the Source Level settings as a solution someone offered in a prior thred.  No dice there…  Sorry for long post but wanted to give the whole picture to answer any initial questions.  12 pack of beer and KC Barbeque to the person who can solve this mystery for me.  Thanks guys and gals..

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

In general, a ’line in’ signal, while being sent to all other speakers, requires a larger amount of bandwidth. It’s more than likely you’re running into a small amount of wifi interference ! Just enough to bother the line in bandwidth usage, but not so much as to bother normal streaming. 

However, beyond reading the linked FAQ and implementing as many of those potential solutions, I would also recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution. Sometimes, a simple verbal explanation can’t match hard data.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

Thanks Bruce..  Now that you mention it, I had recently disabled my old modem/router combo from my ISP and switched to a Mesh Wifi router.  I did this as the carriers modem/router wasn’t capable of handling more than a fixed number of appliances (IP’s), maybe 20 or so before it started to kick appliances off the network (I of course never knew this and had to learn the hard way).  When I added mesh the goal was to increase the # of IP’s the router was capable of handling as I have installed 25+ smart light switches / plugs recently, all connected to the mesh routers 2.4GHZ signal, which happens to be the same signal used by Sonos.  Prior to installing those smart light switches/plugs I had already converted to Mesh and all was good on Sonos at that time, so now here I am again with the potential for over crowding or interference, ufff..  Who knows, it could be something completely different but I think your sense of the issue would appear to in line with recent events on the network.  I will submit a diagnostic and place a call, thanks for the advice!  Matt

Note that depending on what mesh you’re using, there could be various issues, from auto channel hopping, to split subnets, etc. I tend to recommend that if you use a mesh network, you’re better off using SonosNet (wired mode) for Sonos, but there are always individual circumstance, and one ‘easy’ answer doesn’t cover all situations. Which is why I often recommend the route of a diagnostic and calling in, since there is likely to be hard information that might normally take days or weeks of back and forth in these forums to uncover, much less understand. I wish you luck!