Issue streaming audio from Beam to Move

Hi there,


I have a Sonos Beam connected to my TV and a Move. When streaming music via the sonos app or via Spotify, all works fine. I can pair the two speakers and play music with great quality.


However I have an issue when the Beam streams audio from the TV input (HDMI) to the Move. So if I am playing music on my TV (i.e. YouTube), and then group the Move and Beam together, the audio is perfect on the Beam, but it breaks up regularly (every 2-3 seconds) on the Move.


I have tried resetting both but still get the issue. And it happens across the various sources on the TV.


Any ideas?


Thanks for your help. 


Best answer by buzz 25 July 2021, 11:11

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Refrain from Factory Reset without further consult.

How is BEAM connected to your network?

Connected by WIFI.

Are you watching a streaming service on TV and the stream is wireless to the TV or a ‘box’? Likely there is an issue with your WiFi. Submit a diagnostic and post the confirmation number here or call support. WiFi problems are highlighted in the diagnostics. Also, keep track of time of day because WiFi interference could peak at certain times because of activity nearby.

Hi there, to continue this topic, I tried an Ethernet connection and suffered the same issue.

I have submitted diagnostic number 229006209.

Hi there, to continue this topic, I tried an Ethernet connection and suffered the same issue.

I have submitted diagnostic number 229006209.

Have you considered changing the grouped-room audio delay buffer size to cater for network difficulties and perhaps also changing the WiFi band in use by the Move?

To get you started…If you goto "Settings/System/[Beam Room Name]” scroll down to ‘Group Audio Delay’ and change its setting to ‘medium 113ms’ to begin with and see if that resolves the dropout issue, if not then increase the buffer with one of the other settings available - if it does then work it’s likely a network issue, so you could then go onto perhaps consider switching the Move onto your ‘other’ network band (5Ghz or 2.4ghz depending on which one it is using at the moment) and see if that then works any better for you.

Thanks Ken. I have tried the audio delay however the only one that gets stable audio to the Move is the Max Delay - 2000ms which makes it unusable when trying to group the audio together (they are in the same room). 


How do I get the Sonos Move to only use the 5GHz frequency? It currently is on the 2.4GHz frequency.

All good, I managed to resolve this issue. Massive shoutout to those that helped. 


The steps I followed were:

  • Connect Beam to router via Ethernet
  • Disable Wifi on Beam
  • This now allowed my Move to join my 5Ghz network
  • Now audio is synced up with minimal delay selected.

Note: Turning off the wifi on the Beam will disconnect any surround speakers, and Sub that are connected to the Beam.

Probably easier to rename the 5Ghz channel to something like “MySSID5” instead of “MySSID” and then put that into the controller for the Move to connect to. 

Yea, I thought as much. 

I do have a separate 5Ghz channel however, following the steps I took above, I can no longer add my Beam to the 2GHz network. When I try to add the Beam to the 2GHz Wifi, the App crashes.

Might be time to call Sonos. The app shouldn’t crash when adding a speaker, but then again, you can’t have two SSIDs in the network section of the controller, either. I thought you were connecting the Beam with an Ethernet cable?