Question

Harmony Ultimate: no group volume control

  • 2 January 2017
  • 7 replies
  • 1730 views

I just want to ask here first if everybody else has the same problem, before posting a bug to Logitech... Perhaps it's me doing something wrong...

I've got three PLAY:5 (gen 2) in a group, one of them is connected to the network by wire and others two are added to this one as a group. So, as it is described everywhere - in this case the first one must act as a controller for a group.
When I create the Harmony activity (using MyHarmony software on a Mac) it does not let me add more than one Sonos device, showing me the message that I only need to choose a group controller device for the Sonos activity and in this case the whole group volume will be controlled when Harmony changes the volume of that controller device.
BUT. It's not true. After I create this activity with the PLAY:5 controller chosen in this activity, only this device's volume is changed when I adjust the volume using Harmony remote... The other two PLAY:5 devices' volume remains unchanged...

Actually this looks like a bug in a Harmony Ultimate. But perhaps it's me doing something wrong? Does somebody else here have the Harmony Ultimate controlling the volume of a whole group from its Sonos activity?..

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

OK, I've just filed the bug report to Logitech... Will see how adequately they will react on this...

There are actually TWO bugs here (I've reported them both to them): the one I've described here with volume control, and in addition the "Line-In" command of Harmony's "Sonos Activity" does nothing with controlled PLAY:5 device: no matter how many times you invoke "Line-In" command, the controlled device never switches to Line-In mode... But as soon as I invoke the same from Android Sonos app - the device immediately switches to Line-In mode.

So far the Harmony Ultimate is useless for Sonos with these bugs..:( Not sure about other Sonos devices, but for my group of PLAY:5 (gen. 2) - definitely useless.
Did you get a response from Logitech on this? I have the same issue with the group volume, it seems they've covered this by adding a statement to their website that states you can start and pause music for the group but volume will only be adjusted on the master speaker. This seems silly to me if the buttons on the speaker and the Sonos App can do it why can't the Harmony Hub do this!?!?!
All I've got - I had a mail conversation with a really stupid Logitech support guy, trying to explain him why is it a Logitech firmware problem, like teaching "logic for idiots". He constantly tried to shift the conversation into "you are using Logitech remote wrong". But after I've proven it to him in long detailed step-by-step explanation (like doing it for a baby) - he was forced to agree that these two are a Logitech remote bugs and promised me that he is going to forward this report to Logitech programmers.

I did not hear anything from them after that. But according to their glitchy MyHarmony application written in MS Silverlight and such a glitchy firmware (it has a lot of problems with other devices, e.g. with AppleTV) - I'm sure their programmers are the same stupid as this support person. It was simpler for them to add this statement onto their site than to fix at least one of these simple bugs.

So, I don't use Logitech remote for Sonos. Just using it for TV and movies (using it together with AppleTV native IR remote 'cause Harmony is glitchy with AppleTV too). I'm forced to every time reach my smartphone when I want to listen music on Sonos..:(
If somebody knows some other universal remote that works OK with Sonos - I would be happy to throw away this Logitech crap and be using something that works...
Userlevel 7
Badge +21
It's not a bug. Harmony is only capable of controlling one device. When that device is in a group, Logitech will continue to address the one device directly, not the group. Logitech doesn't know that the device is in a group, and likely doesn't care since it's designed to adjust one device only. The logic behind this is that it's more likely that different devices in a group are in different locations, but your remote is only in one location. Why adjust the volume of speakers in other rooms where you can't tell how loud they are? Obviously your use case of having three speakers in one room grouped together wasn't considered.

Now, if you had two of your Play:5 speakers in a stereo pair - meaning that the two speakers are bonded together to function as one device (one as left, one as right) - then Harmony would adjust the volume of the two speakers together... but you'd still be left with your third speaker not being adjusted.

As to the "Line In" command, I've never tried that through Harmony since I don't have anything connected to the Line In on my first-gen Play:5 or my Connect. Many have been pushing Sonos to allow adding line in connections to the Sonos Favorites, so you can select a specific Line In connection (in case you have multiple devices with them) to listen to, and could add that Sonos Favorite to the end of your Harmony activity.
So this thread still seems relevant. "Line-In" command still is not working for me, and you can't add Line-In as a favorites.

However the volume of a group may be resolved. I was able to make a sequence of commands for the Harmony Remote volume up/down buttons that controlls volumes for everything that's grouped together. So I think that part of your question is closed. It's just that pesky Line-In! 🙂

Has anyone had any luck with this? ("Line-In" command or adding to favorites?

you can customize the volume buttons from with the activity itself as seen here.

and then choose "Sequence" instead of just a single sonos speaker "Command".
A few weeks ago I've got an e-mail from Logitech asking me to check if this is resolved. And immediately after that the OTA update came to my Harmony remote.

So, I've checked, and YES, one bug has been fixed, now Harmony can see the Sonos GROUP and control the volume of this group instead of just of one speaker. So, you don't need to use the command sequences with a new firmware version anymore.

Yes, this was a BUG, because for previous firmware versions Logitech stated that Sonos groups are RECOGNIZED, and to control the volume of the group THE MASTER DEVICE of the group must be chosen in the activity as the volume control device (which exactly was done by me and which did not work as stated by Logitech). So, this was a firmware bug by definition. And I was finally able to reach the stage when this bug was filed by the first-level support, got a bug-tracker ID, and was forwarded to developers. It took 7 months for these geniuses to fix this...
So now in the fixed version the Harmony shows you the GROUP when setting up the Activity, and allows you to set this GROUP as volume control device (instead of picking "master device" as in previous firmware versions which didn't work anyway).

But other than this annoying bug - nothing else has been fixed (Line-In is among of not fixed too), and even got WORSE. Because the Sonos' volume control in new Harmony firmware version became eeexxxtreeeeeeemly sloooow... Now I need to push the volume-up/down buttons like forever (30-50 times or so) to make it noticeably louder/quieter... And once (already with a new version) this buggy remote broke my Sonos group, so I was forced to set it back from the smartphone... Sometimes it lives by its own - sometimes it decides to suddenly un-mute two muted speakers of the group when I'm watching TV (using one speaker sitting next to it) and press mute button (which is programmed to send the "mute" command to this one speaker only)... But sometimes mute/unmute works as expected... Sometimes it suddenly stops sending commands to AppleTV (so when a phone rings sometimes I'm forced to quickly grab AppleTV's own remote to pause the movie because Harmony decided to sleep a little), but the same suddenly it starts working again...
Very unpredictable buggy firmware.

For Line-In - there is still the only way: to set it to "Auto Line-In" in Sonos, which is an ugly hack. Because in this case you are always screwed up when e.g. you are listening music and just decided to silently switch-on a TV (e.g. to see a game without a TV volume, continuing to listen a music). But in this case the TV will immediately switch Sonos to Line-In mode and break your music. And Harmony will still think it's playing the music, when the TV is already playing through the system switched to Line-In by TV (not by Harmony). This is because Sonos' "Auto Line-In" is a thing EXTERNAL to Harmony remote, Harmony doesn't control it, like it must be when using Harmony's explicit "Line-In" command sent by Harmony to Sonos WHEN NEEDED as part of TV activity. In this case the TV audio would be enabled only when the TV Activity is switched on by Harmony explicitly, and will not be touched when you just switch on the TV separately.

After I've seen that nothing is fixed (except the volume bug), I've ignored to answer to their letter, because I'm just tired to do the long detailed explanations to lazy idiots on the other side (as I remember it took me a couple of days and a couple of long detailed letters 7 months ago to just get the "first-line" idiot finally forward it to developers)...
But few days later they sent me the same question again. So, I finally answered to them with all this info (in very polite manner, although it was hard for me:)). They didn't even bother to answer back and say thanks or something... So, I give up. Will continue be using a couple of separate native remotes and a smartphone for Sonos, 'cause it's the only reliable way to control all my different devices without sudden surprises, AppleTV control sleeping, and depressing volume button forever when wanting to change the Sonos volume. Looks like humanity have lost the ability to produce properly working firmware for consumer-grade devices.
Just got a reply from Logitech in response to my report mentioned in my previous post (1.5 or 2 months later, speedy workers huh?). So, I decided to come back and post it here for those who is still interested (it's not interesting for me anymore 'cause I stopped using Logitech remote, and now thinking about ditching Sonos too)...

With this last reply, looks like regarding "Line In" remote control command - both are sucks: Sonos who as it appeared just ditched the "Line In" command from their API (!), and Logitech who's not capable to figure this out in time and either discuss it with their Sonos contacts asking them do things properly for remote controls, or at least remove this useless "Line In" item from their useless remote if it is not working anyway, to not mislead Harmony customers...
So, I ditched using this buggy Logitech remote some time ago. Now started to be thinking about switching Sonos to some other, old-school active speakers... I love the sound of Sonos, but the usability of this 3-speakers-in-one-room setup with all my different configurations is just ridiculous nonsense. Too many moves from remotes+smartphone to correct all the volume/mute/unmute/line-in glitches after switch to different audio-source... My wife can't remember all this and just constantly asks me to fix things up every time it glitches again after some source switch and she can't get proper music or TV audio...
Looks like Sonos guys only think about sound, and completely ditching user experience part and proper remotes-API support...

So, here is the Logitech answer:

Dear Jim,

Thank you for your patience. Since, Sonos have removed the LINE IN
command in their new API, the command which is available in our
database is not working. Unfortunately, we cannot do anything
to make it work as we leverage the API to command the device.

Once the Sonos have enabled the Line In command in their API, it
will start working again. However, this is completely depend on the
Sonos Manufacturer and we cannot provide any time frame for this to
be done.

Hope this helps.
Best Regards,
(Here was the name of the guy)

Harmony Team - Logitech