Answered

Drop out issues

  • 16 December 2018
  • 5 replies
  • 412 views

Hi, I recently setup a system in my condo of five Sonos Play-Ones and two Sonos Ones. My condo is 940 square feet and I was having some drop outs with the modem/router that my service provider supplied me with once I went from five speakers to seven as I added the two Ones to replace Echo Dots I had in the rooms. I've always been told that the routers supplied by cable companies are not the best in terms of signal strength and I've had drop outs on my PC which in my office the furthest away from the router.

So I bought a new D-link router that was supposed to have better signal coverage, but the performance of my system was worse. The cable router has two networks one for 2.4 and the other for 5G, and my new D-link router just has the one network but is dual band. I don't know if that is an issues as I've read that Sonos products run on 2.4 as it usually has a stronger signal then 5G. After this I looked into the Sonos Boost thinking maybe its an interference issue with the other devices on my network and a dedicated network my be the fix. But unfortunately the Boost produced the worst performance with individual speakers constantly dropping out. And streaming music from my IPhone completely stop after at best a couple minutes.

So I went back to the drawing board and put the Sonos speakers all on my cable router along with my PC which I use the Sonos app to stream a imported copy of my ITunes library so it needs to be on the same next work. And all other devices are on the D-link router which is feed off the Ethernet ports on the Cable modem/router. And the boost is not hooked up as it was like I was using dial up.

This setup has produced the best results, and if I don't group the two speakers in my bedroom it very rarely drops out on the remaining five speakers. And if it matters the music files that I am playing from the Sonos app on my PC are ALAC which are losses files which is probably pushing the Sonos speakers to there limit along with competing with other Wi-Fi network interference in my building. And I also have a my condo converted to a smart home, with light switches, plugs, thermostat, cameras, and powered blinds but those are all on the D-link router.

Anyone have some suggestions on how I can improve my setup? As I eventually plan on converting my TV surround sound to Sonos from my wired setup as I already have to Sonos speakers in my living room. And would like to get my current system to be highly reliable before I spend the $2000 CAD on the play bar and subwoofer.

Thanks
icon

Best answer by Ken_Griffiths 16 December 2018, 13:02

I don’t understand why the Sonos 'Boost Mode' is not the best option for you here, as the signal hops between the Sonos devices and would often be a far stronger 'exclusive' signal than a central-based WiFi signal. See the diagrams and explanation of the difference between 'Standard Mode' and 'Boost Mode' here:

Choosing between a Standard and BOOST Setup

My thoughts here, are that you may not have configured 'Boost Mode' correctly when you initially tried it, for example once 'Boost Mode' is activated you should almost always remove your WiFi credentials in the 'Advancec Settings/Wireless Setup' of the Sonos App. It’s not clear, if you did that, or not?

You should also try to configure the main routers 2.4ghz channel, so that it is the least used non-overlapping channel in and around your premises and then go onto set your SonosNet channel at least 5 channels apart from your router channel and also select the next least-used SonosNet channel for this purpose.

To add further stability to your system, I would also recommend adding the Sonos IP addresses to your man routers DHCP Reservation Table.

I think setting up your system with 'Boost Mode' in this way, would provide you with a much better/stable signal than you will achieve with a central router WiFi signal, plus SonosNet is 'exclusive' to Sonos products, so there will be no other devices on that signal to interrupt the flow of data.

The one other thing to briefly mention is a that the faster 5ghz signal is not generally used by Sonos, other than for bonded Home Theatre systems and whilst it is quicker, the signal does not often reach the distances that can be achieved by a 2.4ghz signal. A 2.4ghz signal is plenty fast enough for the Sonos Audio data and that’s why I believe it is still currently preferred.

Hope the above helps to resolve your wireless signal issues.?
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Just thought I'd update on this, I ended up having to upgrade my router again the Dlink one I'd bought previous was still having issues having a good signal at the furthest spots in my condo from the router. I ended up going with an Ubiquiti Amplifi HD mesh wifi setup and disabling the wifi singnals from my cable router/modem. I tried every combination of channels with both routers and the Sonos Boost, which was still the worst of the three for drop outs. I now run every thing on the Ubiquiti router and have had good preformance out of my Sonos speakers, still cuts out a bit on odd speakers on first song or when I switch songs but usually after about 5-10 seconds all speakers are playing and stable. Is this normal? I run from the Sonos app on my PC, which is a copy of my Itunes library in Losses format. For me it is not a big deal as I listen to play lists or full albums usually.
Thanks for the input Ken, when I get back home I'll give it a shot.
I would maybe download a WiFi scanner, like wifiinfoview for example and see what is the least used 2.4ghz WiFi channel in your locality and set the router to that channel. Then set SonosNet to the next least-used channel, but ensure it is at least 5 channels away from your router channel.

Then get things switched over to run on SonosNet.

Remove any WiFi credentials stored in the Advanced Settings as mentioned earlier and then finally add the Sonos IP addresses to the routers DHCP Reservation Table and my guess is your device dropouts will likely disappear for good.
When I got the boost I set it up as a new account with all the speakers factory reset and added to the account with setting up the boost first. The shame is when this system works it’s what I’ve been looking for, for over a year. Allows me to control all 4000 albums on my desktop from my phone/tablet and pay it wirelessly throughout my who place including my patio which my PCs Bluetooth would not reach. Then there’s the other side the drop outs...
I don’t understand why the Sonos 'Boost Mode' is not the best option for you here, as the signal hops between the Sonos devices and would often be a far stronger 'exclusive' signal than a central-based WiFi signal. See the diagrams and explanation of the difference between 'Standard Mode' and 'Boost Mode' here:

Choosing between a Standard and BOOST Setup

My thoughts here, are that you may not have configured 'Boost Mode' correctly when you initially tried it, for example once 'Boost Mode' is activated you should almost always remove your WiFi credentials in the 'Advancec Settings/Wireless Setup' of the Sonos App. It’s not clear, if you did that, or not?

You should also try to configure the main routers 2.4ghz channel, so that it is the least used non-overlapping channel in and around your premises and then go onto set your SonosNet channel at least 5 channels apart from your router channel and also select the next least-used SonosNet channel for this purpose.

To add further stability to your system, I would also recommend adding the Sonos IP addresses to your man routers DHCP Reservation Table.

I think setting up your system with 'Boost Mode' in this way, would provide you with a much better/stable signal than you will achieve with a central router WiFi signal, plus SonosNet is 'exclusive' to Sonos products, so there will be no other devices on that signal to interrupt the flow of data.

The one other thing to briefly mention is a that the faster 5ghz signal is not generally used by Sonos, other than for bonded Home Theatre systems and whilst it is quicker, the signal does not often reach the distances that can be achieved by a 2.4ghz signal. A 2.4ghz signal is plenty fast enough for the Sonos Audio data and that’s why I believe it is still currently preferred.

Hope the above helps to resolve your wireless signal issues.?