Answered

Cannot connect to speaker via wifi

  • 26 September 2016
  • 6 replies
  • 954 views

Since I changed some settings on my router, the Sonos speakers will not connect via wifi (they work fine when wired via ethernet). I have tried the troubleshooting steps suggested, such as restarting router and speakers, changing the channel etc.
When I follow the 'set up wifi' in advanced settings, it accepts the network name and password with no problem, but the wifi speaker does not appear in the controller. If I try and connect via the usual 'Add a Player' menu, then it never gets to the stage of the flashing green light, so it cannot be set up through that route.

I submitted a diagnostic report about 10 minutes ago.
icon

Best answer by Tom B 28 September 2016, 12:02

Hi dommiz, welcome to the community! You have a bit of a tricky set up there. Sonos does not work well with powerline device, as detailed in our system requirements. Having these in place will make the setup and operation less smooth, but it may be possible anyway.

If your router and extenders are not in the same room as each other and you want to achieve a seamless network around the house, it is advisable to set them all to the same channel.

Your Mac is currently joining the 5GHz wifi from the BT Hub; let's get this on the 2.4GHz band instead while we're setting up the system, as this seems to be the same network name (SSID) as your extenders are using.

If the wireless setup fails again, get all the Players in the same room with a at least one wired to the main router and try it like that.
View original

6 replies

Userlevel 7
Badge +21
Since I changed some settings on my router, the Sonos speakers will not connect via wifi (they work fine when wired via ethernet). I have tried the troubleshooting steps suggested, such as restarting router and speakers, changing the channel etc.
When I follow the 'set up wifi' in advanced settings, it accepts the network name and password with no problem, but the wifi speaker does not appear in the controller. If I try and connect via the usual 'Add a Player' menu, then it never gets to the stage of the flashing green light, so it cannot be set up through that route.

I submitted a diagnostic report about 10 minutes ago.


You'll need to put the diagnostic number here else Sonos won't know which one to look at.
@Stuart_W - Many thanks for the tip! I have re-submitted the report and the number is: 6582977.
Might be a help to let us know which settings you changed as well...
I changed the LAN network name when I added an Apple Time Capsule wifi router (as and extender) to the set up. It seemed the Apple device did not like the former network name as it had spaces. We have an old house with thick stone walls, so we have three TP Link powerline devices to distribute the network. One of these devices has a Sonos player plugged into it (which is working fine), another one has the Apple Time Capsule as a wifi extender (in a room some distance from either Sonos speaker, and the third is just for the PVR and TV. A further wifi extender is not wired, but picks up the wifi signal from the main router and extends it into another room.
It is possible there is a conflict with the wifi channels, as there are 3 wifi devices broadcasting (the main router, the Apple device and the standalone extender). I assume these devices are set up to select a channel automatically, so later I will change that to a fixed channel. We have no neighbouring wifi networks here on the farm, so no problem with local channel conflicts.
Userlevel 4
Badge +3
Hi dommiz, welcome to the community! You have a bit of a tricky set up there. Sonos does not work well with powerline device, as detailed in our system requirements. Having these in place will make the setup and operation less smooth, but it may be possible anyway.

If your router and extenders are not in the same room as each other and you want to achieve a seamless network around the house, it is advisable to set them all to the same channel.

Your Mac is currently joining the 5GHz wifi from the BT Hub; let's get this on the 2.4GHz band instead while we're setting up the system, as this seems to be the same network name (SSID) as your extenders are using.

If the wireless setup fails again, get all the Players in the same room with a at least one wired to the main router and try it like that.
@ Tom B - many thanks for the advice. Yes, you are right that my Macbook was connected to the 5GHz network instead of the 2.4 network I set up for the rest of the house. This is a legacy of when the Macbook didn't like the 2.4 network, yet certain iPads could not cope with the 5 Ghz network. The days of Apple products 'just working' are long gone...

So, I connected my Macbook to the 2.4 Ghz network, ran through the wireless set up again (Prefs -> Advanced) while the Sonos player was still connected direct to BT router via ethernet. Then I disconnected the player's cable from the router, and used the app to see if I could play a track from Spotify, via wifi. Lo and behold, the wifi connection now works. Clearly, it was the dual 5/2.4 Ghz network that was the issue. Nothing to do with channels, or even with the TP powerline units, as one Sonos player operates quite happily while connected to one of the powerlines.

Many thanks for the solution.

Reply