Access Denied to Music on Synology Drive


Userlevel 1

Hi 

I had this problem with my Music Library on my Synology NAS server. Eventually the Sonos Tech Team came up with an answer that worked for me. The problem was I only had one user account for the NAS server and all my Sonos Speakers and iMac and PC etc used this account. It appears the NAS drive thought this was a security risk and stopped my two One SLs for accessing the drive. The other speakers worked OK. The solution was to create another user account specifically for Sonos. As soon as this was created and the library rebuilt with the new account all the speakers worked correctly and I can play music from the library from any speaker. Hope this helps with some of these access problems.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

50 replies

Let me add something here which might help others having difficulty with Sonos and Synology.  I recently updated my NAS with DSM 7.0, which immediately broke Sonos access to the shared Music drive on the Sonos.  The solution for me, as suggested by others in similar posts, is to go to the SMB settings under File Services, then Advanced, and then other.  There is a setting called enable NTLMv1 authentication.  Once you do, you will get a nasty warning message about potential vulnerabilities with this aging standard.  This fixed the problem for me.

The key takeaway is that Sonos needs to update its SMB protocols to a higher standard, in the interest of greater security.  While the future is streaming, many of us still have lots of audio files on servers that we want to use with our systems.

There’s already user community/Staff awareness about support for the later SMB encrypted transfer of music files mentioned in this rather long thread…

It at least shows Sonos are aware of the issue.

I really thought of buying some more sonos devices for my whole family. But now I have to accept  security issues in the future. Seems that I have to switch to another vendor if there is no update from sonos ! 

 

Thanks @BillFair.   You are a legend! 

Hi, maybe recent updates have solved the issue. At present no problem at all for me after some adjustments. Sonos Connect. Synology 218 play. Windows 10 PC, on a wired connection and 2 Macs running OS 12 Monterey and Sonos app wireless. 
 

SMB and AFP enabled so that the NAS software DSM can talk to the PC and Sonos and to the Macs.

At first Synology and Sonos collided on the wifi. Synology was discovered by my iPhone but not Sonos. Wired connection solved that problem. 
Now everything seems to work. I haven’t fiddled with different settings of SMB or NTLMv1. 
I have a WDMyCloud and a QNAP NAS as well building up the library on Sonos. 

Thanks BillFair - this solved my problem as well.

I’ve given up on Synology as my NAS solution for my ripped music. Way too involved to get it to work the way I need it to (yes I have too much stored music) and the WD MyClouds work perfectly with shares and specifying actual folders and even specific subfolders when necessary. Thanks for all the insite.

Let me add something here which might help others having difficulty with Sonos and Synology.  I recently updated my NAS with DSM 7.0, which immediately broke Sonos access to the shared Music drive on the Sonos.  The solution for me, as suggested by others in similar posts, is to go to the SMB settings under File Services, then Advanced, and then other.  There is a setting called enable NTLMv1 authentication.  Once you do, you will get a nasty warning message about potential vulnerabilities with this aging standard.  This fixed the problem for me.

The key takeaway is that Sonos needs to update its SMB protocols to a higher standard, in the interest of greater security.  While the future is streaming, many of us still have lots of audio files on servers that we want to use with our systems.

 

 

Holy cr@p I searched long and hard, uninstalled and reinstalled the SONOS apps, before finally finding this...and it worked for me too.  I must admit I am using the SONOS S1 clients with an old Play5...don’t know if that’s an issue or not, but THANK YOU!  Sheesh...

Unfortunately, I’m unable to help. I’m a WD MyCloud user, and have no working knowledge of the Synology system. Not to mention why it should be any different in use than the WD setup…

I’d try calling the folks at Sonos, I’d imagine they have some sort of script for this. 

Would be interested in what you find out, though. The fans on my WD are failing, and expect a Synology is in my near future. 

I am mildly concerned about your use of S1 still, though. Makes me wonder if there’s some setting in the Synology, either SMB v1, or NTML v1, that’s not set properly. I’ve seen quite a few posts that suggest that OS updates to NAS devices frequently change these settings without explicit declaration. Have certainly experienced that before with WD. And Vizio, on my TV’s audio settings. Didn’t figure that out for several days, when I noticed that surround data wasn’t being played. 
 

Help me with this, Bruce, if you can… Previously:

 

\\MyBookLiveDuo\Jazz was the share. Easy enough to do on the WD. I created a folder called Music, and under that folder was Jazz, and I shared it. I can’t get it set up the same way on the Synology. I don’t want to create just a \\Jazz share… I’d like all shares to be under a music folder. Any idea or link on how to set this up? It is defying all my IT experience. Thanks for any help.

The same as before. No change. 

Assuming you have a firewall set up, still relatively low, as long as you keep it updated, IMHO. 

Yeah, but how at risk am I now?

There’s been no ability to make any changes to S1, there’s apparently not enough memory available to update the kernel to allow other versions of SMB. So from your perspective, nothing has changed. 

Hey, man. Good to see ya. S1. A few pieces are too old for S2.

Depends on if you’re using S1 or S2. S2 now can use up to SMB v3.

Thanks for this fix. My WD MyBookLiveDuo is dying a slow death. I’m moving everything over to my eight disk Synology… how insecure is this now? Can’t seem to find an answer out there.

Huge thanks to you, BillFair. I think it’s a damn miracle that I found your post. After wondering why my path was no longer good, and searching for solution for an hour and half, I stumped upon your post. Many, many thanks!

Badge

Thanks @kiddude 

I am on DSM 6.2.4 so don’t have the NTLMv1, but still needed to adjust the minimum setting to SMB1 via File Services>SMB Advanced settings

Very helpful!

 

One other item if you get to the end of this thread. 

In the File Services » SMB » Advanced Settings, make sure you set the minimum setting to SMB1 as I had missed it and by default it is probably SMB2 if you took the defaults.

 

enjoy

 

Enabling an insecure protocol isn’t a solution. Sonos needs to implement smbv2.

They’re doing that by all accounts, according to the information provided in this thread …

 

Enabling an insecure protocol isn’t a solution. Sonos needs to implement smbv2.

 

This is a good trick if you cannot wait for the SMB2/3 update and if you don’t want to drop your security settings for your Synology NAS as a whole.

I am not sure as customers that we should have to do all this to ‘stick a plaster’ on the problem for Sonos, they should resolve it and not expose their customers into having insecure settings within their network - this is not acceptable but even more so given the price tag of Sonos equipment.

Agree 100%.  Just offering someone’s ready-right-now solution.

I have already sent the CEO the request to fix SMB2/3 and also to filter out incompatible files or at least downsample high resolution audio that’s on a music library.

I am not sure as customers that we should have to do all this to ‘stick a plaster’ on the problem for Sonos, they should resolve it and not expose their customers into having insecure settings within their network - this is not acceptable but even more so given the price tag of Sonos equipment.

Well it appears the update is coming from Sonos, based on the information seen in the link below, but I guess these things do take time and have to be fully tested before they can be made available to all. We just have to be patient and wait for any announcement, but in my view probably more security risks come from poorly configured SMB NAS shares and local network security implementation, than they do from the wannacry or petya exploits .. Anyhow see this link:

https://en.community.sonos.com/advanced-setups-229000/smb1-security-issue-lack-of-response-from-sonos-6860761?postid=16551779#post16551779

 

This is a good trick if you cannot wait for the SMB2/3 update and if you don’t want to drop your security settings for your Synology NAS as a whole.

I am not sure as customers that we should have to do all this to ‘stick a plaster’ on the problem for Sonos, they should resolve it and not expose their customers into having insecure settings within their network - this is not acceptable but even more so given the price tag of Sonos equipment.

 

This is a good trick if you cannot wait for the SMB2/3 update and if you don’t want to drop your security settings for your Synology NAS as a whole.

The SMB support issues have been discussed by many for quite a while now in various posts. Reading this message, it looks like there is light at the end of the tunnel. :yum:

 

Sonos, please update asap. I also took a lot  of time to figure out what was going on.  I can’t believe Sonos actually wants to force it clients to run any security risks.

Userlevel 2

Sonos, please update.   I just spent half the weekend trying to figure this out.  We need an update that is compatible with Synology Diskstation!