Access Denied to Music on Synology Drive

  • 6 June 2021
  • 4 replies
  • 166 views

Hi 

I had this problem with my Music Library on my Synology NAS server. Eventually the Sonos Tech Team came up with an answer that worked for me. The problem was I only had one user account for the NAS server and all my Sonos Speakers and iMac and PC etc used this account. It appears the NAS drive thought this was a security risk and stopped my two One SLs for accessing the drive. The other speakers worked OK. The solution was to create another user account specifically for Sonos. As soon as this was created and the library rebuilt with the new account all the speakers worked correctly and I can play music from the library from any speaker. Hope this helps with some of these access problems.


4 replies

Userlevel 5
Badge +15

Hi @49ermuse, thanks for sharing this with the Sonos Community! I’m sure this information will be able to help others who may be having trouble with Synology NAS drives :)

Let me add something here which might help others having difficulty with Sonos and Synology.  I recently updated my NAS with DSM 7.0, which immediately broke Sonos access to the shared Music drive on the Sonos.  The solution for me, as suggested by others in similar posts, is to go to the SMB settings under File Services, then Advanced, and then other.  There is a setting called enable NTLMv1 authentication.  Once you do, you will get a nasty warning message about potential vulnerabilities with this aging standard.  This fixed the problem for me.

The key takeaway is that Sonos needs to update its SMB protocols to a higher standard, in the interest of greater security.  While the future is streaming, many of us still have lots of audio files on servers that we want to use with our systems.

 

 

Let me add something here which might help others having difficulty with Sonos and Synology.  I recently updated my NAS with DSM 7.0, which immediately broke Sonos access to the shared Music drive on the Sonos.  The solution for me, as suggested by others in similar posts, is to go to the SMB settings under File Services, then Advanced, and then other.  There is a setting called enable NTLMv1 authentication.  Once you do, you will get a nasty warning message about potential vulnerabilities with this aging standard.  This fixed the problem for me.

The key takeaway is that Sonos needs to update its SMB protocols to a higher standard, in the interest of greater security.  While the future is streaming, many of us still have lots of audio files on servers that we want to use with our systems.

There’s already user community/Staff awareness about support for the later SMB encrypted transfer of music files mentioned in this rather long thread…

It at least shows Sonos are aware of the issue.

@BillFair thanks I had the same issue.  I upgraded to DSM 7.0, Sonos could see my music library but I kept getting access denied when trying to play a song from my Synology.  I was about to enable NTLMv1 but got scared with the warning messages.  I was still stumped and only solved it when I saw this post and enabled it and it all worked. 

 

So thanks for sharing.  I was going nuts because the Music folder on my NAS was accessible from Windows 10 via file explorer

\\IP_address_of_NAS\Music_Folder_Name_on_NAS

 

in Sonos it is accesses via

//IP_address_of_NAS/Music_Folder_Name_on_NAS

Reply