Access Denied to Music on Synology Drive


Userlevel 1

Hi 

I had this problem with my Music Library on my Synology NAS server. Eventually the Sonos Tech Team came up with an answer that worked for me. The problem was I only had one user account for the NAS server and all my Sonos Speakers and iMac and PC etc used this account. It appears the NAS drive thought this was a security risk and stopped my two One SLs for accessing the drive. The other speakers worked OK. The solution was to create another user account specifically for Sonos. As soon as this was created and the library rebuilt with the new account all the speakers worked correctly and I can play music from the library from any speaker. Hope this helps with some of these access problems.


45 replies

Userlevel 6
Badge +15

Hi @49ermuse, thanks for sharing this with the Sonos Community! I’m sure this information will be able to help others who may be having trouble with Synology NAS drives :)

Userlevel 3

Let me add something here which might help others having difficulty with Sonos and Synology.  I recently updated my NAS with DSM 7.0, which immediately broke Sonos access to the shared Music drive on the Sonos.  The solution for me, as suggested by others in similar posts, is to go to the SMB settings under File Services, then Advanced, and then other.  There is a setting called enable NTLMv1 authentication.  Once you do, you will get a nasty warning message about potential vulnerabilities with this aging standard.  This fixed the problem for me.

The key takeaway is that Sonos needs to update its SMB protocols to a higher standard, in the interest of greater security.  While the future is streaming, many of us still have lots of audio files on servers that we want to use with our systems.

 

 

Let me add something here which might help others having difficulty with Sonos and Synology.  I recently updated my NAS with DSM 7.0, which immediately broke Sonos access to the shared Music drive on the Sonos.  The solution for me, as suggested by others in similar posts, is to go to the SMB settings under File Services, then Advanced, and then other.  There is a setting called enable NTLMv1 authentication.  Once you do, you will get a nasty warning message about potential vulnerabilities with this aging standard.  This fixed the problem for me.

The key takeaway is that Sonos needs to update its SMB protocols to a higher standard, in the interest of greater security.  While the future is streaming, many of us still have lots of audio files on servers that we want to use with our systems.

There’s already user community/Staff awareness about support for the later SMB encrypted transfer of music files mentioned in this rather long thread…

It at least shows Sonos are aware of the issue.

@BillFair thanks I had the same issue.  I upgraded to DSM 7.0, Sonos could see my music library but I kept getting access denied when trying to play a song from my Synology.  I was about to enable NTLMv1 but got scared with the warning messages.  I was still stumped and only solved it when I saw this post and enabled it and it all worked. 

 

So thanks for sharing.  I was going nuts because the Music folder on my NAS was accessible from Windows 10 via file explorer

\\IP_address_of_NAS\Music_Folder_Name_on_NAS

 

in Sonos it is accesses via

//IP_address_of_NAS/Music_Folder_Name_on_NAS

Let me add something here which might help others having difficulty with Sonos and Synology.  I recently updated my NAS with DSM 7.0, which immediately broke Sonos access to the shared Music drive on the Sonos.  The solution for me, as suggested by others in similar posts, is to go to the SMB settings under File Services, then Advanced, and then other.  There is a setting called enable NTLMv1 authentication.  Once you do, you will get a nasty warning message about potential vulnerabilities with this aging standard.  This fixed the problem for me.

The key takeaway is that Sonos needs to update its SMB protocols to a higher standard, in the interest of greater security.  While the future is streaming, many of us still have lots of audio files on servers that we want to use with our systems.

 

 

Thank you very much, fixed my issue for me!

Thanks @BillFair.  Solution worked for me as well. 

Thanks BillFair! “ enable NTLMv1 authentication “ worked for me too.


Sonos needs to update its SMB protocols to a higher standard, in the interest of greater security.
But it doesn’t.

When you charge premium prices you should do better Sonos

Thank you BillFair - “ enable NTLMv1 authentication “ worked for me too with synology DSM ver. 7.  Sonos should have a setup guide for the synology, and other, nas devices.

+1.  “enable NTLMv1 authentication” worked for me on 7.0.  Thanks for sharing.

Thank you so much Bill.  Many hours of aggro and scratching my head and swearing...a lot!!  

 

FFS Sonos, keep up with latest security and be more on-the-ball with the likes of the hugely popular and brilliant Synology drives.  We should have to figure this stuff out for ourselves and rely on clever and kind people like Bill!

Let me add something here which might help others having difficulty with Sonos and Synology.  I recently updated my NAS with DSM 7.0, which immediately broke Sonos access to the shared Music drive on the Sonos.  The solution for me, as suggested by others in similar posts, is to go to the SMB settings under File Services, then Advanced, and then other.  There is a setting called enable NTLMv1 authentication.  Once you do, you will get a nasty warning message about potential vulnerabilities with this aging standard.  This fixed the problem for me.

The key takeaway is that Sonos needs to update its SMB protocols to a higher standard, in the interest of greater security.  While the future is streaming, many of us still have lots of audio files on servers that we want to use with our systems.

 

 

Many thanks for sharing your knowledge!! It works now. Best.

Userlevel 2

I had already a sonos dedicated user account before updating to 7.0, and suffered the same denied access. BillFare solution worked at once. Thanks!!!

Reading this comments here solved my problem finally before I go nuts….Enabling the NTLMv1 worked for me - thanks!

Badge

Let me add something here which might help others having difficulty with Sonos and Synology.  I recently updated my NAS with DSM 7.0, which immediately broke Sonos access to the shared Music drive on the Sonos.  The solution for me, as suggested by others in similar posts, is to go to the SMB settings under File Services, then Advanced, and then other.  There is a setting called enable NTLMv1 authentication.  Once you do, you will get a nasty warning message about potential vulnerabilities with this aging standard.  This fixed the problem for me.

The key takeaway is that Sonos needs to update its SMB protocols to a higher standard, in the interest of greater security.  While the future is streaming, many of us still have lots of audio files on servers that we want to use with our systems.

 

 

Can’t thank you enough for this. Never would have figured it out without this!!!

Many thanks 49ermuse it is very decent of you to share this work-around.

SONOS need to fix this.

Badge

I had just the same problem: once updated Synology NAS to DSM7, with NTLMv1 disabled by default, SONOS cannot connect anymore.

I solve by enabling NTLM1 on Synology, but this represents a security issues.

I kindly ask SONOS to considering implementing support to NTLMv2 as soon as possible.

I have just discovered that I have the same problem with my Synology NAS running DSM7.0 in that my Sonos system will not connect to my Music Library source.

It is a security risk to enable NTMLv1, as others have pointed out when this is enabled on the Synology Device [DSM Control Panel > File Services > SMB > Advanced Settings > Others and check Enable NTLMv1 authentication] the following warning is displayed.

Enable NTMLv1 authentication: Enabling this option allows clients to be authenticated through NTMLv1, which is not secure and can be vulnerable to published attacks for obtaining user credentials. We strongly recommend updating your network authentication settings.

Come on Sonos, you need to fix this and change the protocol used rather than putting users at risk by forcing them to enable an outdated protocol that has a definite, adverse effect on network security which may then be compromised.

I will not be enabling NTMLv1 on any if my Synology devices and will find an alternative way for music to be played via my Sonos system.

Thanx for the information. This did it for me too! 

Let me add something here which might help others having difficulty with Sonos and Synology.  I recently updated my NAS with DSM 7.0, which immediately broke Sonos access to the shared Music drive on the Sonos.  The solution for me, as suggested by others in similar posts, is to go to the SMB settings under File Services, then Advanced, and then other.  There is a setting called enable NTLMv1 authentication.  Once you do, you will get a nasty warning message about potential vulnerabilities with this aging standard.  This fixed the problem for me.

The key takeaway is that Sonos needs to update its SMB protocols to a higher standard, in the interest of greater security.  While the future is streaming, many of us still have lots of audio files on servers that we want to use with our systems.

 

 

Thank you for posting this solution.  And Sonos -- please, please get your act together on this topic.

Userlevel 7
Badge +20

I’m sure such motivational words will have Sonos employees positively skipping to work ;)

Great to hear that the NTLMv1 solution from Bill Fair worked so well for numerous people. Well done Bill! Accordingly, I implemented that fix (after updating to DSM 7.0) but, alas, it didn’t work for me. Does anyone have any other suggestions? I’m a computer luddite, so need a reasonably complete explanation (and have found the ones in this thread comprehensible).

My Sonos One Controller (running on Win 10 box) has been working well with the music library on my new Synology DS220+ for ~ 2 months.

Suddenly, a couple of days ago, when I tried to play a song, the Sonos app said “Unable to play [song] - Access to the [shared folder] is denied.” Originally, all the Songs, Artists & Albums were listed in the Sonos library but the imported playlists did not appear. Now, it’s the reverse – the imported playlists appear but not the individual Songs, Artists & Albums. When I try to play a playlist song, the above error message appears.

Troubleshooting steps taken:

  1. Re-enter login credentials
  2. Verify that smb1 is enabled on the NAS (it was, or it wouldn’t have worked previously).
  3. Remove the NAS music library from the Sonos app and start over
  4. Adjust Norton 360 firewall settings per the Sonos help document
  5. Re-start Sonos
  6. Re-start NAS
  7. Create new user account on NAS for Sonos use only
  8. Try logging in via Sonos app on another device: iPhone SE2020 running iOS 14.8. Same result with iPad.
  9. Enabled NTLMv1 authentication (In DSM 7, go to Control Panel > File Services > Advanced Settings under SMB > Others and enable NTLMv1 authentication)

I’m still able to access the music library on the NAS via Synology’s mobile apps (DS Audio, DS File) using the same login credentials which previously worked with the Sonos system.

 

Please help. Thanks

Looks a comprehensive list to me, User721894. Actually, @Airgetlam solved the problem for me when I guessed that “check username and password” meant removing the NAS music from the Sonos list and reinstating it (with updated password). That appeared to be implied in your Step 3, so I don’t think I can help. Good luck!

Let me add something here which might help others having difficulty with Sonos and Synology.  I recently updated my NAS with DSM 7.0, which immediately broke Sonos access to the shared Music drive on the Sonos.  The solution for me, as suggested by others in similar posts, is to go to the SMB settings under File Services, then Advanced, and then other.  There is a setting called enable NTLMv1 authentication.  Once you do, you will get a nasty warning message about potential vulnerabilities with this aging standard.  This fixed the problem for me.

The key takeaway is that Sonos needs to update its SMB protocols to a higher standard, in the interest of greater security.  While the future is streaming, many of us still have lots of audio files on servers that we want to use with our systems.

 

 

Hello Bill,

    Thank you. Its works well for me also in France. Super.

Gerard.

I really thought of buying some more sonos devices for my whole family. But now I have to accept  security issues in the future. Seems that I have to switch to another vendor if there is no update from sonos ! 

 

Reply