Question

2 Separate Play 1 speakers - no longer able to group


Badge
I have just been on with customer support as I am now unable to play music simultaneously in two separate rooms (only since downloading the recent update!) Prior to this update they have worked fine in both rooms since purchase of the second Player1 in November. Apparently, as I have a wifi booster near one speaker, it is now reading it as a separate 'network' and I cannot play music simultaneously in two rooms. Before I go out and purchase the suggested Sonos Booster, I would like to check if anyone else has had this problem. I am not a technical wizard but this doesn't really make sense to me as they worked perfectly before and nothing has changed in my environment.

9 replies

The update of the software causes the speaker to get a new IP address from the network. If it found the wifi booster this time, rather than your original wifi signal, depending on the way it's set up, it could "break" the system. What I'd actually recommend is that you connect one of your speakers to the router (not a booster) and let SonosNet be the wifi that the speakers connect to. Once you've connected that speaker/BOOST/BRIDGE to the router, wait about 3 or 4 minutes for the system to figure everything out, and then go in and remove the wifi network information from the Sonos app.
Badge
Thank you. I actually do not have a booster - getting a booster to fix this problem was what was suggested by Sonos customer service. I will try what you have suggested. The thing is everything worked until the software update... nothing in my environment changed, all my other devices requiring wifi work fine everywhere. If I can fix this, I hope I don't have to go through all of this each time there is an upgrade.

Thank you very much for your suggestion and I will try this.

Christine
The problem with wifi environments is that they are not always under our control. While you may not have changed anything, it's possible that a neighbor did, or that an electric motor in your home started 'leaking' interference, etc. But I think you're on the right path, and hopefully your issues will be gone soon.
Badge
Thank you. I have just tried again but no luck. I am stuck with two 1 play speakers in two rooms and I get either one or the other which sort of defeats the purpose of the thing. Appreciate your counsel however.
Userlevel 6
Badge +3
Christine,

Did you try plugging in one of your speakers into your router with the supplied Ethernet cable ... then did you also wait till things switched over to SonosNet and then remove the WiFi credentials from the Sonos App in 'Advance Settings/Wireless Setup' as Bruce has suggested, as that should work ... you can tell if the speakers have switched over to SonosNet as they will both show WM: 0 in the “About my Sonos” box... which is in the 'Settings' part of the App
Badge
Maybe I didn't 'wait till things switched over to SonosNet and so on... I will try this again. How will I know that things are switched over to SonosNet.
Thanks
Chris
Userlevel 6
Badge +3
Turn off both speakers and cable one to your router... then turn it back on and wait until the speaker has finished booting... it takes about 30 to 60 seconds to do that.

Open your Sonos controller and go to Settings/About my Sonos ... where you will see your speaker with a variety of information including its assigned IP address. Near the bottom of that entry you should see this ... WM: 0 ... that means the speaker is using SonosNet to communicate with other Sonos speakers.

Close your controller and then switch on the other speaker. Once again it will take 30 to 60 seconds to boot. The speaker should connect automatically via SonosNet and once again you will see WM: 0 in Settings/About my Sonos area of the Sonos App.

If that is the case, you can then remove/reset your WiFi credentials from the Sonos system by going to Settings/Advanced Settings/Wireless Setup... things then should work fine.

Only remove the WiFi credentials if both speakers show WM: 0 in the About My Sonos area of the App.

Hope that helps...
Hi all,
I am having similar problems to this. I have tried all the above advice but still no success.

Connected speaker 1 to router via ethernet and it has the WM:0 listed. I then removed the wifi by resetting it. I then disconnected the speaker and as expected it failed to connect wirelessly. So i linked it back up with the router and entered the wifi details/password. It connected and again it had WM:0 listed. I disconnected it from the router and it re-connected wirelessly. All sounds good. But then i checked 'About my Sonos' again and its listed as WM:1......why has it done this?

I repeated the same process for speaker 2 and it did exactly the same thing. So i have two wireless speakers both on WM:1 and they do not appear together.

The only way i get them to appear is if 1x speaker is connected to the router, whilst the other is wireless. They will both appear and I can group them then. But this is ridiculous. My router is in the hallway and I am not going to have a 15ft cable going through my house.

What am i doing wrong?

Craig
Userlevel 6
Badge +3
Craig in effect you are setting the two speakers up entirely separately. The advice given to Christine was a different issue. Let’s try to get you sorted.

Just to let you know that you first of all need to decide if you want to run in boost mode ... this is (mostly) where a single Sonos device is cabled directly to your router and broadcasts its own WiFi signal connection called SonosNet to the other Sonos devices and the signal 'hops' or 'spans' like a mesh between the Sonos products to often improve communication between them. It saves troubling your own home WiFi signal with the streaming traffic, but obviously it needs one device (at least) cabled to the router to provide access to/from the internet and local LAN. It stays wired to the router after setup, but only the one device is often needed to run all the other speakers on the SonosNet signal.

Any device using SonosNet will show in the 'about box' with WM: 0

The other option is to not run the devices on SonosNet ... by using the standard setup and not cabling any Sonos devices to your router, but instead using your own home routers WiFi signal ... the 'about box' shows these Sonos devices with WM: 1 next to their entry in the list.

If you choose the standard setup then you will need your WiFi credentials set in the “Advanced Settings/Wireless Setup” area of the Sonos Controller App... but if running on SonosNet, it’s advisable to remove the credentials to prevent the possibility of some speakers switching back and forth between the SonosNet signal and your routers WiFi signal.

Firstly it would be helpful to let me know which type of setup you wish to now do (Standard (WiFi) ...or... Boost (SonosNet)) and I will then do my best to sort out your issues.

Reply

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)