Question

2.4 Ghz Band Saturated

  • 20 April 2017
  • 8 replies
  • 1600 views

I have recently noticed that the WiFi in my house has been slow. I managed to isolate the problem to equipment that use the 2.4 GHz (802.11n) bandwidth. Using an RF Explorer, I realized that the 2.4 Ghz is completely saturated (any channel) from devices at our neighbors. As a result, a 50 Gbit speed is reduced to 1 Gbit when the 2.4 GHz channel is used. To be safe, I replaced the WiFi WAP with a new one that supports both 2.4 GHz and 5 GHz. The problem remains, but not on the 5 GHz band. Any equipment on the 2.4 GHz band crawls, any on the 5 GHz band flies.

I have been having problems with connectivity of my SONOS speakers, when I realized that they also use the 2.4GHz band. I have had the speakers for some time now. Both are wireless via a SONOS Bridge, so not my WiFi WAP. Am I to assume that I am doomed, since SONOS uses the same band?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

The only time that I'm aware that the Sonos devices use the 5Ghz band is when they are bonded with the Playbar. Other than that, they all use the 2.4Ghz band. And I'm not aware of any way to change that.

I assume it's for backwards compatibility with older devices that don't include a 5Ghz wifi card, like the Connect: Amp.
Userlevel 5
Badge +10
An additional reason that the 2.4Ghz band is utilized is that a 5Ghz signal attenuates very quickly. (It decays to a weak signal over distance, and particularly quickly when having to go through walls, etc. ) This is one of the reasons that you don't see as much "noise" on those bands at your location... the signals are not strong at distance. So, for most people, a 2.4Ghz signal would provide better coverage and performance.

The use of 5Ghz for faster speed with sonos' 5.1 setups is because it is understood that a 5.1 setup doesn't require he signal to go far and won't have to go through walls, etc. (5.1 will all be in the same room.)

However, that doesn't help you much Telly. Any chance you can use your tools to I'd which networks are with which neighbors and get some alignment in channel usage?? Just a thought.
Telly,

As you have one Sonos device cabled to your, router then your network is running on SonosNet using the 2.4ghz band... you can set one of three channels for SonosNet in the controller Advanced Settings.. either Ch1, Ch6 or Ch11.. I would start with Ch6.

Next go to your router and if necessary change your router's 2.4ghz channel ... you will most probably have a choice of at least 11 different channels, or more. Select one that is furthest away from channel 6 and is least-used by your neighbours, or other devices in your home.

Leave things settle for a while and see see how things go.

If you then still have problems, switch your SonosNet to channel 1 and again move your router channel to one that is furthest away from Ch1 and least-used by your neighbours etc. Then see how that goes.

If that also fails, then repeat the procedure one further time, but with SonosNet now set to Ch 11.

If all the three SonosNet channels are tried and still fail (hopefully they won't), then you might be best to 'daisy chain' your speakers together, using an Ethernet connection, but that really needs to be a 'last resort' option.

If one particular speaker (only) keeps failing, then look at where that speaker is placed in your premises and see if there are things nearby that maybe interfering with its signal.. such as a wifi printer or a wireless telephone, or power-line adapter etc. Consider moving it a few feet away from such devices and try to avoid too many walls/floors between the speaker and your main router.

One final thing.. as your speakers are running on SonosNet, then it's important to note that there is no need to have your router wifi credentials stored in the Sonos Controller 'Settings/Advanced Settings/Wireless Setup' ... if any details are shown there then I would reset/remove them, as they will not be needed by your selected SonosNet setup.
SHARKB8T, I have several neighbors and it seems that the problem extends beyond my immediate ones. I spoke to my immediate neighbors (I have a separating wall only on one side of the building) and they have similar WiFi problems. They purchased a nanny cam recently, which I had them completely unplug to see if this would help, but it didn't. No luck.
Ken,
I will try your suggestions and see what comes out. The house is two floors, so I am struggling where to put the SONOS bridge. If I bring it upstairs, the upstairs speakers work, but when I bring the speaker out in the backyard during a BBQ, the connection is frequently lost. Find a network plug where you would want the speaker, however, is not easy.

BTW, Sonos is perfect for (wireless) temporary outdoor use (when it works).
Telly,

In a SonosNet (boost) setup the signal works different than when using your router wifi (standard) setup, in that SonosNet allows the connection to hop/step and be boosted between the Sonos speakers.

So in standard (uncabled) mode, if you say have a long straight corridor with a router at one end, together with speaker-1 nearby, then have speaker-2 halfway along the corridor and speaker-3 at the very far end. The router will transmit the music over its wifi signal direct to all three speakers itself ... meaning that it may have to 'really stretch' along the corridor to reach all the way to speaker-3 .. you might only need to put something like a 'closed door' in the way and the signal to speaker-3 could be lost altogether, depending on how far away it is to begin with.

But in SonosNet mode, the music signal is much better because it goes from speaker-1 ... to speaker-2, which in-turn passes it along to speaker-3 ... so the distance between the receiver speaker and the start of the signal is much shorter and therefore a lot stronger.

So having a Sonos device (like a bridge or boost or another Sonos speaker) between things, can greatly improve the situation... so in your case something between your upstairs bridge and a speaker a long way off in the garden will dramatically improve the signal to the one in the garden..

Remember the Sonos boost works slightly better than a bridge, but you can also have more than one bridge/boost on any SonosNet network, just to act as a further signal 'hopping device' if that suits instead of an interim (middle) Sonos speaker, but the first important thing is to try an reduce any other wifi signal interference (from neighbours etc.) to begin with, by trying the things I mentioned in my earlier post in this thread.

Hope that helps
Ken,
I took a bit to reply to make sure that whatever I tried had enough time to settle, so that I could provide accurate feedback. I played with the various channels, but it does not seem that there is anything I can do there. Probably all routers around me are set to AUTO, so they constantly switch channels. If only all neighbors could agree to stick to one channel each...

I did move the Bridge closer to the problematic speaker and now it works great. I haven't had any problems since I moved it to the top floor. The speaker on the lower floor also works flawlessly. I haven't tried the backyard speaker yet, but it is located outside of the 2nd speaker, so maybe by buying an additional speaker for the backyard it will use the intermediate speaker to bridge the signal.

Thank you very much for your suggestions and your help.
You are welcome Telly and I'm glad things now appear sorted. I also agree the neighbour's having their router channel set to auto does not help in these situations, especially when they regularly switch their routers off overnight etc.

Anyhow, thanks for the update.