Question

Won't connect after getting a new router (SONOS PLAY:1)


After getting a new router in my home I can't connect to my sonos speaker. I've checked my wifi settings and it looks fine - but still no connection.
Right after it tries to connect with my wifi I get the message "there's a problem connecting to your wifi". I really don't understand this.
I have tried to reset my sonos speaker a couple of times now, no help.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

22 replies

Userlevel 7
Badge +20
After getting a new router in my home I can't connect to my sonos speaker. I've checked my wifi settings and it looks fine - but still no connection.
Right after it tries to connect with my wifi I get the message "there's a problem connecting to your wifi". I really don't understand this.
I have tried to reset my sonos speaker a couple of times now, no help.


HI Milad Barid,

It might help to check your router's wireless encryption to see if it's using a type the PLAY:1 can connect to. Here's a quick guide to the supported encryption types.

It might also help to temporarily connect your PLAY:1 to your router with an ethernet cable. Then when you're setting up the Sonos app you can choose the BOOST or BRIDGE setup. You won't need to have a BOOST or BRIDGE if your PLAY:1 is wired to your router. Once the app is connected and set up you can go to the settings menu and head to advanced settings to find wireless setup. Wireless setup will guide you through setting your wireless network's password and should help get the PLAY:1 working wirelessly.
There nothing wrong with my routers encryption, i have checked it a couple of times now.
I tried with ethernet cable, and it says that I should press the button and release on my SONOS boost, which i don't have. I have also pressed on the Bridge button, but I get a message that it can't connect.
Userlevel 7
Badge +20
There nothing wrong with my routers encryption, i have checked it a couple of times now.
I tried with ethernet cable, and it says that I should press the button and release on my SONOS boost, which i don't have. I have also pressed on the Bridge button, but I get a message that it can't connect.


Hi Milad,

It would be best to work with our phone team to get your system working again. Here's a support ticket: 160616-001019. Please give us a call and reference that number. You can find our phone number here.

I have tried to reset my sonos speaker a couple of times now, no help.


Connection problems which appear suddenly are often caused by network problems. The typical cause is duplicate IP addresses. These often show up after a router change because the new router, having no idea of previous IP assignments, issues a new IP that is in use by another device. Resetting just your speakers isn't going to do it, in fact it may exacerbate the issue because they can easily get an IP that is in use by any other device that has not been rebooted yet. To cure this, do the following:

Reboot/power cycle your devices in the following order:

Modem
Router
Switches or hubs
Wired Sonos units
Wireless Sonos units
Computers/printers
Wireless devices - phones/tablets etc.

Allow each device to come back up before proceeding to the next. Note that you can permanently prevent duplicate IP addresses by assigning an IP to each device's MAC address in the router setup. See your router manual for details
I had problems setting up my Sonos speakers and I realised that they can only connect to wifi networks on 2.4 GHz and Channels 1-11 i.e. Channel 12-13 are out.

(This wasn't immediately obvious and I spent some time trying to figure out what was the issue.)
Yeah it's a total joke it is this difficult to connect these goofy speakers to a network like this! I have talked to multiple Sonos techs and even Apple Wireless senior advisors and still not working. If they can't sort this how the heck do they expect the average person to! Not happy.:@
Yeah it's a total joke it is this difficult to connect these goofy speakers to a network like this!
It isn't. It's trivially simple and there's even a nice how-to video.

As for the possibility of screwed up network addressing, this affects any device following a router change. In such a scenario all network devices need a reboot/reconnect.
Userlevel 6
Badge +3
Also a "Factory reset" is almost never the answer. Several folks on here have never once reset their speakers including me for years. Try the above first and then post back.
Then not sure why multiple Sonos techs I talked to left me without knowing what was going on NOT resolving my speakers connecting wirelessly.
Badge
After getting a new modem/wifi router, I had the same problem - my Sonos system was unable to connect via wifi. I went through the suggested fix, cabling one off my Play:1 speakers directly into my router (good, it instantly made my Sonos network/speakers appear again), but ... no matter what I did, I couldn't get the Sonos wireless setup to connect. It kept rejecting my wifi password. Given one of the comments on this thread, I logged into my router and changed the channel for my 2.4GHz network from 11 (which it should support) to 1, and it all instantly resolved. Honestly, issues like this should be eliminated by Sonos because the average user will *never* be able to understand how to make this kind of fix. Engineers should be focused on usability issues as the #1 important goal of the company. It should just work, with no tweaking required. Can you imagine if a mobile phone or tablet required this level of complexity to be operable?
I just had the same problem, except i just bought a new Play1 and could not connect to my WiFi network. Chapps comment about changing channel on my router did the trick for me. It was set in auto mode, and i just chose a specific channel.
Badge
I wanted to stuff my router in a blender, but it didn't fit.
Sad how simple the solution is, yet how long it took to resolve and how much pain I went through.

Just in case you are still having the issue:

Disable airtime fairness
Enable IGPM snooping
Disable WMM (unless you use airplay)
Disable Roaming Assistance
Turn off Explicit and Universal beam forming
Change the 2.4ghz channel to 11

Try to set up the speaker again. It should work instantly.

Go back and enable:
both beam forming options
airtime fairness

Google those features to see why you may need them.

Good luck!
After a frustrating 24 hours of trying to setup my three Play 1's with my new ASUS AC-RT3100 router (retiring the Airport Extreme), I finally have everything working. I tried everything, shutting down all devices in the house, rebooting, wiring to Ethernet, etc. What finally made Sonos work with this particular router was: Under Wireless --> 2.4GHz, turn on ENABLE SMART CONNECT. Once I did that, I was able to setup the first speaker right away. The 2nd speaker took a couple of tries. The third speaker eventually had to use the Alternative Setup method but once that was done, I unplugged it from Ethernet and now everything is working as expected.
Interesting, and somewhat counter-intuitive. ASUS 'smart connect' is evidently band steering. And on some routers band steering is known to cause confusion for a Sonos unit trying to connect to the 2.4GHz WiFi.
Agreed, seems strange to me as well. But nothing I did could get the speakers to work with this particular router until I made that change. At this point, I'm just going to leave well enough alone 🙂
Standard advice to avoid these kind of gremlins is to wire a Sonos unit to the network and put the system into SonosNet/BOOST mode. But with just 3 players I can understand why you'd favour WiFi/Standard setup.
Badge
I wanted to stuff my router in a blender, but it didn't fit.
Sad how simple the solution is, yet how long it took to resolve and how much pain I went through.

Just in case you are still having the issue:

Disable airtime fairness
Enable IGPM snooping
Disable WMM (unless you use airplay)
Disable Roaming Assistance
Turn off Explicit and Universal beam forming
Change the 2.4ghz channel to 11

Try to set up the speaker again. It should work instantly.

Go back and enable:
both beam forming options
airtime fairness

Google those features to see why you may need them.

Good luck!
UNLESS ITS TUESDAY, in which case reverse the order? This is not consumer friendly advice, unless of course you were making a joke 😉
Badge
After getting a new modem/wifi router, I had the same problem - my Sonos system was unable to connect via wifi. I went through the suggested fix, cabling one off my Play:1 speakers directly into my router (good, it instantly made my Sonos network/speakers appear again), but ... no matter what I did, I couldn't get the Sonos wireless setup to connect. It kept rejecting my wifi password. Given one of the comments on this thread, I logged into my router and changed the channel for my 2.4GHz network from 11 (which it should support) to 1, and it all instantly resolved. Honestly, issues like this should be eliminated by Sonos because the average user will *never* be able to understand how to make this kind of fix. Engineers should be focused on usability issues as the #1 important goal of the company. It should just work, with no tweaking required. Can you imagine if a mobile phone or tablet required this level of complexity to be operable? THIS IS EXACTLY my issue, though I am on channel 6. I have the option of channel 1 or 11. Not sure I should mess with this, absolutely not confident about messing with this level of setting. Seems really difficult, if I knew I would have these sorts of issues I would not have purchased this system - really I was expecting a plug and play experience which is how this was sold to me. Has my 2012/2013 Play 1 become obsolete? Could that be it?
Badge
Yeah it's a total joke it is this difficult to connect these goofy speakers to a network like this!
It isn't. It's trivially simple and there's even a nice how-to video.

As for the possibility of screwed up network addressing, this affects any device following a router change. In such a scenario all network devices need a reboot/reconnect.
THIS SOUNDS REASONABLE, yet all my other devices are working except for the sonos which doesn't like my new network password. It will only work when cabled to my router - so its not wireless anymore. Is this some strategy by the product team to sell BOOSTS? 😉
Badge
After getting a new router in my home I can't connect to my sonos speaker. I've checked my wifi settings and it looks fine - but still no connection.
Right after it tries to connect with my wifi I get the message "there's a problem connecting to your wifi". I really don't understand this.
I have tried to reset my sonos speaker a couple of times now, no help.
Badge
Just updated on android app and after update nothing worked. Went step by step connecting playbar so tv sound works but sub, and play 3 and two small play 1s do not connect? System worked fine, now nothing works but tv playbar. Thing i loved aboit sonos was its simplicity and it just worked but lately each update is a major headache and system just does not work. Very dissapointed in Sonos
Badge
I wanted to stuff my router in a blender, but it didn't fit.
Sad how simple the solution is, yet how long it took to resolve and how much pain I went through.

Just in case you are still having the issue:

Disable airtime fairness
Enable IGPM snooping
Disable WMM (unless you use airplay)
Disable Roaming Assistance
Turn off Explicit and Universal beam forming
Change the 2.4ghz channel to 11

Try to set up the speaker again. It should work instantly.

Go back and enable:
both beam forming options
airtime fairness

Google those features to see why you may need them.

Good luck!