With 9.3 controller unalble to update SONOS speakers error 1013


Badge +1
Updated the app this morning, opening the app on the iPhone, the iPad, Windows 10PC on Wi-Fi and also Windows 10 PC on Wired network, all items are unable update the SONOS sound devices ( we have about 8 on our wired network) it starts the update, says finishing off (after 2mins) but then says error 1013 everything was working fine before the App Update. What can I try ? or is the problem SONOS end ? I presume the Device that is running the update downloads the update from SONOS and then sends it to each SONOS device on the network ?

26 replies

Badge +1
Here is what happens





Badge +1
I have tried the update on WiFi and wired PCs, iPhones and Android devices all do exactly the same with error 1013, i am now unable to play music on any of the devices. :@
Badge
Hi, sadly I have just experienced the same problem. Just unpacked by first ever sonos products (Beam and 2xPlay:1s) and no end of unresolved issues just trying to install the beam, let alone the Play:1s. Pair the beam with the new system created no problem, but I can't even set started until it does a (firmware?) update, then I get exactly the same as you above. Beyond disappointing having forked out decent money for this product and my first experience of it is not what I would expect. Wasted 2 hours so far....nothing installed....stuck on the stage you have in screenshots above. No consistency either as sometimes it gets to finalising, sometime not even that, and then my most annoying issue I thought I had resolved and back to 1101 errors to even start the process (can;t wait to unplug all my routers all over again....)
Badge +1
I am now looking at the Ports on the Router, (this is a business so we have network people)
I have emailed our IT man to see if port 4444 is open on the router/firewall
It seems that (by my own research) that the update needs these ports open, to access the internet:Below are the ports that Sonos uses:

TCP/IP:

80 (Internet Radio, updates and registration)
443 (Rhapsody, Napster, and SiriusXM)
445 (CIFS)
3400 (incoming UPnP events - Sonos Controller App for Mac or PC)
3401 (Sonos Controller App for iOS)
3445 (OS X / Windows File Sharing)
3500 (Sonos Controller App for Android)
4070 (Spotify incoming events)
4444 (Sonos update process)
UDP:

136-139 (NetBIOS)
1900 (UPnP events and device detection)
1901 (UPnP responses)
2869, 10243, 10280-10284 (Windows Media Player NSS)
5353 (Spotify Control)
6969 (Initial configuration)
Note: When configuring a software firewall, the above ports will require inbound access.
Userlevel 5
Badge +17
Oh dear, the recent 9.3 update was supposed to make setting the beam up via mobile phone easier.
Try removing all sonos apps and installing the apps again.
You could try an Ethernet cable from the router to the beam.
I think there maybe other sonos problems, but you might have to wait till Monday to get an answer from them.

All I can say is that after the initial sonos setup frustration (mine was with pc firewalls), they will sound fantastic.
Badge +1
You can check which ports are open with this site, i have found that port 4444 is not open. :@
http://www.canyouseeme.org/
I have had my Sonos system in 7 rooms for over 10 years now and the only (few, thankfully) problems I have ever had is when Sonos updated the system controllers. After many problem free months, this latest update to 9.3 is another such event. I have the same issues as outlined above and I think the update is going to succeed only for it to fail at the last hurdle. Using the 9.2 controller on my PC (windows 10) I can access half of the rooms although any music source is now intermittent. My iPads and phones cannot use the controller at all.... I wish Sonos would spend longer on Beta trials of their updates before their users face many hours of frustration trying to resolve issues which they have caused. It is a tremendous system when it works properly! It seems we will have to wait for the Sonos tech staff to receive enough negative reports for them to believe the issues and fix it...….
Userlevel 1
Same issue here. This really pisses me off.
Badge
Thank you all for the support! really nice to feel the love from the community and get me to keep the faith! It seems you can;t set up speakers anymore from the desktop controller v9.3 (it says in the release notes) so I might try to find v9.2 and see if that helps. Brian, did you have any success in opening up port 4444?
Badge
All, just an update, after 1 more hour of pure stubbornness and belligerence or retrying, the update has eventually applied and finalised, then took another 4 retries to get the beam to finalise the beam set up process. Now unbelievably it is saying I don't have the speaker registered, even though it is when i log into my sonos account...... and I can't use the beam until the app recognises this, but again, error after error trying to register the beam.......sigh.........even when it then gives you a tick for the process completing (1 in 10 times at best), it still doesn't recognise the registration.... wow this app is broken and making a the speakers totally uninstallable.
I just bought a BOOST unit to add to my Sub, Play 1 pair, Play 3 pair & Play 5 units. I am now still-uck as many of you without any operating SONOS system. I can't get the updates to load and thus none of my SONOS units work. I have wasted 2 hours following each of the recommended fixes by SONOS. Really this is appalling. I don't see that when these updates arrive we (the users) benefit. This is not the first time for all of us to suffer. I don't believe this is the way to run a business.
Userlevel 4
Badge +7
I had the same error and tried the update several times over the course of several hours before it finally succeeded. But, it did eventually work.
Badge +1
I have Emailed IT support , but they are back monday,
I pinged Port 4444 to my router from external ip, and it closed, so i can only presume this is the problem i have, i have been trying updates all afternoon, they all get to `Finishing up` and then i get the error 1013 which is a pain.


rafishani wrote:

Thank you all for the support! really nice to feel the love from the community and get me to keep the faith! It seems you can;t set up speakers anymore from the desktop controller v9.3 (it says in the release notes) so I might try to find v9.2 and see if that helps. Brian, did you have any success in opening up port 4444?

Userlevel 6
Badge +16
brianthesnail wrote:

I pinged Port 4444 to my router from external ip, and it closed,


There's no reason for any port to be open for incoming traffic originating externally, for Sonos purposes. However, you may need to check that outgoing ports are not blocked. Such blocking would be atypical for a normal domestic router/network, but might exist in corporate or other more complex scenarios.
Userlevel 7
Badge +20
I'll add this here too: Updates used to be hell for me until I followed a suggestion here to set static/reserved IP addresses for all my Sonos devices. The pain was greatly reduced! This update went into my 10 Sonos system with no issues.

----
I have no tweaks to my firewall or routing setup to accommodate Sonos gear and all is updating and working with no problems.
After years of error free updating 9.3 has ended our system so far. Same scenario as brianthesnail. Have tried several switch off/disconnect/restart of router and bridge, and also uninstall/reinstall of software, but on opening and choosing connect to existing it simply cannot find the system at all
Userlevel 7
Badge +20
Try disconnecting power from the Bridge and running Ethernet to another Sonos device. The Bridge is a common source of problems. Power cycle the device you hooked to Ethernet and give things a few minutes to settle in.

If that works you have several options, keep one or more Sonos devices connected to Ether net (best) purchase a Boost (not bad but $$$) or replace the Bridge power supply (cheap) and hope that was the problem.
Thanks Stanley. Been that long since setup and no problems since then that I'd forgotten you could connect speaker to ethernet direct! Job done and back playing music. Many thanks
Badge
good morning all. I am not sure what happened (I suspect all nighters by the Sonos team to resolve our issues) but I can happily report everything actually started installing this morning with zero errors and super quick work. All done in 3 mins.....sigh..... happy, yet still frustrated with the debacle yesterday. I hope you all find the same success.
Badge +1
I have unplugged all of my play 5s and ones leaving just the living room tv system play bar, 2x5s and a sub, still same error 1013 im not a happy owner
Badge +1
Update. Still same problem, each device flashes blue/Red when the app says getting started. They flash for about 30 seconds, then they stay blue, then after 10 seconds the App says Update Problem , with the 1013 error. Can Technical please confirm that port 4444 needs to be open for this to work ? or is the App itself applying the update to each SONOS device. ?
Badge +1
Update: I Factory Reset one of the Ones. Plugged it into the Network with ethernet cable. Reset the App controller and set up new System. Speaker updated no problems, so i have one updated, but on a new System :( do i spend the rest of the day doing the same to all other speakers ( about 10 of them ) adding them to the new system i have just completed - bearing in mind all my saved stations and playlists will be gone :( grrr ?
Badge +1
SORTED !! ....
OK this is how i did it, Unplugged all 11 SONOS devices, Reset the Controller app on iPhone, Moved each SONOS device into my office, wired it into the network and factory reset each device and set up a new System, One by one, the update worked flawlessly. Now the problem i found is the Wired network in my House, which is the same wired network in my office which is situated next to my house, All running off the one router, 2 managed switches, one in house and one in offices. When SONOS is plugged into house Switch, items refuse to update with error 1013. Plug into the network switch in my office, they update ! Goodness knows why ? Same Network, Same Domain, everything is connected, all from the DNS Server. Yes it took me a total of 8 hours to get to this point where i am now, but at least i can wake up to Christmas Music in the morning ! lol ! :cool:
Userlevel 5
Badge +17
Well Done Brian!!
Hopefully a sonos rep will be along to advise you on why you had such problems.
Badge +1
I wont hold my Breath :( To everyone who is locked out due to the update, my advice to get you going is to take your SONOS devices to another location and try it on a friends network, once updated you can then plug them back into your own network and configure. There were no problems with my ports either, all working as requested by SONOS.

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings