Answered

Wiring As Many Speakers As Possible And Disabling Wifi

  • 24 June 2022
  • 5 replies
  • 86 views

Userlevel 4
Badge +7

Hey Everyone,

I know the general way of thinking here is to only wire one speaker to Sonos, however I have a tonne of wifi devices at home and my house tends to be a difficult wifi environment even when using SonosNet.

I have 20 Sonos speakers scattered around, and the Symfonisk Lamps in particular seem to have really poor wireless connectivity and frequently drop out regardless of the SonosNet wifi channel.

My ethernet network consists of a main TP Link Deco Router linked to a 16 Port Unmanaged Switch in my office which then feeds into 3 different locations in the house each with their own unmanaged switch on each end and Deco Access Point. I have found that wiring in as many Sonos speakers as possible to ethernet solves a huge amount of the issues I have with SonosNet. I’ve managed to wire in 11 Sonos speakers and leave 9 to SonosNet and the experience is vastly better.

The issue is, if I have anymore than one of the ethernet wired speakers with Wifi enabled everything works really well until anytime I need to reboot all my Deco Units. Something then seems to happen causing certain speakers to keep appearing and disappearing. I can’t easily turn some of the Sonos speakers doing this off and back on either as my electrician hard wired 4 of the hard to reach mounted Sonos Ones directly into power for some reason meaning I end up having to turn the entire house electricity off and on to reboot the whole system when this happens.

I have found that by simply only having one of the ethernet wired Sonos Units set to wifi enabled the whole problem goes away. Something in the Deco’s is clearly interfering with Sonos STP implementation when they are restarted and Sonos is still running at the time.

In my situation is there anything really wrong with only having one ethernet connected speaker (A Sonos Beam Gen 2) broadcasting it’s wifi? It seems to reach all the wireless speakers it needs to and makes the whole system rock solid.

Appreciate any advice.

icon

Best answer by billiejoe87 24 June 2022, 12:32

View original

5 replies

Hi. In general, unless you are having STP issues, it is better to leave the wireless radios switched on on all the wired speakers. Otherwise you are half crippling SonosNet. 

Userlevel 4
Badge +7

Hi. In general, unless you are having STP issues, it is better to leave the wireless radios switched on on all the wired speakers. Otherwise you are half crippling SonosNet. 

I understand what you are saying, however it sounds like my system is having STP issues based on the above.

Don’t know if Sonos can manage STP properly when daisy chaining unmanaged switches, but it seems to have trouble with the TP-Link SG116 in my office (Which is connected directly to my router) feeding another TP-Link SG116 in my sunroom, TP-Link SG108 in my Lounge Room and TP-Link SG-105 in my bedroom.

EDIT: Actually noticed that in my sunroom and master bedroom I had the ethernet connection from the main office Switch feeding into the Deco Access Point in each room and from there into the unmanaged switch in each room, maybe this was causing an issue as the Deco Access Points were assigning their own DHCP or something whenever the network restarted.

As John B mentioned, the usual recommendation is that you keep the radio’s ON, however, if your system is more stable with most radio’s OFF, declare victory and move on. There are situations where turning OFF most of the ratios is productive, For example, if you have a pile of AMP’s in a closet, all connected to a switch, there is no need for all of the radios. If you move units between locations, keep track of that good location and make sure that a radio enabled unit is in that location. Another general rule is that the more recent designs have better radios.

Given what you say about your setup, I think it would be worth checking in your Sonos app that all devices have WM=0, i.e connected to SonosNet or by Ethernet.  (Except that any Moves or Roams would have WM-1)

Userlevel 4
Badge +7

Given what you say about your setup, I think it would be worth checking in your Sonos app that all devices have WM=0, i.e connected to SonosNet or by Ethernet.  (Except that any Moves or Roams would have WM-1)

Yeah they do all have WM=0.

I actually think I have resolved the issue by daisy chaining the unmanaged switches directly to each other instead of placing the Deco Access Points in front of the unmanaged switch in each room. The access points shouldn’t have been assigning their own DHCP, but it seems like Deco’s have a habit of strange behaviour if they ever lose connection to a main router and can try assigning their own addresses.

I’ve activated Wifi on all my ethernet connected Sonos and restarted my whole network a few times and everything has worked properly.

Thanks for all the advice.

Reply