Answered

Windows 10 Music Library

  • 6 August 2015
  • 7 replies
  • 3748 views

Badge
Since upgrading to Windows 10 I have lost the ability to play any music in My Library. I receive an error message every time. I have tried deleting the folder and adding again, but same result. Any ideas???
icon

Best answer by ElesoteriC 6 August 2015, 00:22

Hey Hudders,



Make sure to share the error message you are getting.



Windows 10 updates reclassifies your network connection, normally onto public which restricts it's local network communication.



Top Google result has a real handy video which originally helped me find the place to change it.



https://tinkertry.com/how-to-change-windows-10-network-type-from-public-to-private



Make sure to check your various security programs too, sonos lists the changes you need to make for the most popular ones on their FAQ



https://sonos.custhelp.com/app/answers/detail/a_id/692/~/firewall-and-internet-security-software
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 7
Badge +22
Do you have any anti-virus software running.

It lets you add the folder but nothing scans?

Are you adding the folder from the Sonos app on the windows computer?
Userlevel 3
Badge +2
Hey Hudders,

Make sure to share the error message you are getting.

Windows 10 updates reclassifies your network connection, normally onto public which restricts it's local network communication.

Top Google result has a real handy video which originally helped me find the place to change it.

https://tinkertry.com/how-to-change-windows-10-network-type-from-public-to-private

Make sure to check your various security programs too, sonos lists the changes you need to make for the most popular ones on their FAQ

https://sonos.custhelp.com/app/answers/detail/a_id/692/~/firewall-and-internet-security-software
Badge
It was the Network resetting to Public following upgrade! Once I reconfigured Firewall settings - able to add Library again!!!! RESULT! Thanks for assistance!!!;)
Userlevel 7
Badge +22
Great news Hudders!
Recent Windows update 1709 automatically turns off smbv1 file sharing, that is needed by Sonos. Control Panel/Programs and Features/Turn windows features on or off/SMB 1.0/CIFS File Sharing Support/: uncheck smb v 1.0/cifs automatic removal and check the other two. reboot.
Thanks tenholde - turning on smbv1/SMB 1.0/CIFS - solved my issue
Recent Windows update 1709 automatically turns off smbv1 file sharing, that is needed by Sonos. Control Panel/Programs and Features/Turn windows features on or off/SMB 1.0/CIFS File Sharing Support/: uncheck smb v 1.0/cifs automatic removal and check the other two. reboot.
^ live saver. [Enter Bromance]