Answered

Wifi Power Cycle, must hardwire now

  • 22 November 2018
  • 10 replies
  • 398 views

Appreciate some insight on how to correct an issue that’s come up.

Power cycled on my wireless router by accident. Once that happened and launched the Sonos App it can’t find any of my speakers even after power cycling the speakers. My phone connects fine on the same SSID and password.

If I hard wire a speaker to the router and then power cycle that speaker it can be found by the Sonos app. Next if I power cycle each of the other speakers they are also found. Great, back to normal except one of my speakers is hard wired now.

My problem comes in when I try to disconnect the first speaker I hard wired. When I do that the app can’t find any of the speakers anymore. How do get all the speakers to connect wirelessly without one of them having to be hardwired (my original setup before the WiFi was power cycled)?

Hoping I don’t have to reset everything and start from scratch. I have 8 speakers and they aren’t all easy to get to.

I submitted a diagnostics report with one speaker hard wired and one connected wirelessly:

My confirmation number is: 1739272776.
icon

Best answer by John B 22 November 2018, 22:40

One other thing. Make sure your router is not set to use wireless 'n' only. Look for a setting of b/g/n
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Sounds like somehow the wifi details have been lost from Sonos. Or, possibly, just that your phone is connecting to your router's 5GHz band. Get your phone onto 2.4GHz band and see if the speakers reappear.

If not then get back to where you have one device wired and everything is visible. Then Advanced Settings, Wireless Setup and follow the prompts. Again, make sure your phone connects to your router's 2.4GHz band if it is dual band, not 5GHz.

Do not reset your speakers!!
By way of explanation of my suggestions...

Sonos only connects to your network at the 2.4GHz band. Therefore IF the controller connects to 5GHz and IF your router does not allow data to pass between the two bands, then the controller cannot see the speakers. However, if you have one device wired, the connection can be made along the wire, so being on different bands does not matter.

Another possibility is that the wifi details have been lost in your Sonos system. But that doesn't matter with a wired component as other speakers can connect to the wired one.

I assume your router's SSID (network name) and password have not changed?
Thanks for the advice John. The SSID and password have not changed. Will try your suggestions and let you know how it goes.
One other thing. Make sure your router is not set to use wireless 'n' only. Look for a setting of b/g/n
So got access to my ATT router and can see b/g/n is enabled. Can also all the devices connect including my Sonos Devices. It shows they are connected on the 2.4 GHz band; I don’t think the router even supports the 5 GHz band. I tried hard wiring a different speaker with the same results.

Also tried resetting wireless settings but it gives an error because it can’t connect to all my devices to clear wireless settings.

Any other ideas?
Also tried setting up wireless and get this when it fails. Should I try resetting my SSID and password

Tried a factory reset on a speaker, no dice.

Buying a boost, didn’t need it before but I seem to be out of options!
Badge
Same issue since update last week
https://en.community.sonos.com/search/activity/topics?userid=8020153
Badge
My issue solved (ATM)
Was advised to set the wifi channel to 12 but the Playbar still would not connect to the WiFi.
Tried channel 10 which connected, then moved up to channel 12. This didn't work so settled on channel 11.
My router was originally set to a much lower channel but I noticed interference with neighbours so set it to furthest channel from any of them (13) which doesn't appear to be compatible with the Sonos Playbar (or 12).

So far working fine on channel 11