Answered

WiFi password incorrect

  • 14 October 2019
  • 34 replies
  • 4911 views

I've spent 3 days trying to get my playbar, sub, and 2 play-3 speakers set up and it keeps saying the WiFi password is incorrect even when I copy-paste from the router settings.
It accepts the range extender network password, which is the same as the other one, but then tells me I can't use the speakers without the Boost.
So now I'm stuck with thousands of dollars of speakers that don't work.
I've tried changing the network password, deleting and reinstalling the app, resetting the speakers. I've tried plugging a speaker into the router but then the app doesn't even find it when searching for speakers to set up.
Can anyone suggest something else to try?
icon

Best answer by nik9669a 14 October 2019, 12:13

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

34 replies

Got the same problem.

Ok, but how do I disable the 5G on the router? 

Userlevel 5
Badge +14

Hi @Gustav_l.

Welcome, thank you for reaching out to Sonos Community, I totally understand where you're coming from and I’m here to help.

I suggest not to turn off the 5Ghz the reason behind that is this can be used for Sonos home theater speakers.

Also, other electronic devices like tablets, phones, laptops can also use 5ghz. 

But if you really insist I suggest contacting your cable provider or the manufacturer of the router.

If you need help with any other information, please be sure to let us know.

But how do I solve the problem? My sonos 5 gen 2 keep insisting it's incorrect password when it's not.

What do I do?

 

Diagnostic report 438006721

 

Tried

Disable 5g - no success

Change passwords - no success

Still saying its wrong password when it's not

New diagnostic report 681472499

Userlevel 7
Badge +22

Make sure the router supports 802.11b/g - if it is set to 802.11 N-only then Sonos won’t connect with a password error.

By the way disabling 5GHz will not affect surround sound Sonos devices, they use their own network, not your router’s.

The WiFi was set to 802.11b/g/n tried to put it as b/g

Reset sonos 5

New password 

New name on wifi

Still same problem. The sonos 5 claim its the wrong password, it's not. 

Trying also to re do the whole setup. The app can't find the speaker (green lamp) 

Btw, it did work before, this happened the other day and now I can't make it wire less. Any other suggestions? 

Even I had the same issue. And after I did the following changes, it resolved my issue.

Ensure that wifi is 2.4 GHz b/g/n

I contacted sonos customer care & the following changes done resolved the issue for me:

  1. Change the wifi channel mode from auto to manual, the sonos uses channel 6, so its best to select channel 1 or 11 as these channels have the least overlap with channel 6.
  2. The second setting is is turn on UPNP.

Hope it works for you.

 

Userlevel 7
Badge +22

Please don’t turn on UPNP on your router, it opens a wide security hole. It is not necessary for Sonos unless you have an old, crappy router. If you actually find it necessary, please share the router model # so others can learn from it.

I had the same problem with me Play 3. Tried many things.

 

I called my internet provider and ask them if the could reset my WiFi router. I also told them to use lower case and no spaces between letters for the name of the network.

 

I use the 2.4 Ghz band.

 

it worked.