Answered

Wasted weekend!

  • 6 November 2016
  • 6 replies
  • 458 views

Ok this is doing my head in now! :)

I've had a sonos system for years and it's always worked and been easy to set up. For some reason last week it stopped working and I've tried all sorts to get it running again.

Yesterday I gave up in the standard setting and got a boost that came today. Plugged this in thinking all would be good - well it isn't!

Boost is plugged in and connected and I've got a 2 play 5's, sound bar (with 2 play 1's and a sub connected up). Even these were temperamental to set up, kept getting messages saying wifi may be out of range etc, but eventually after clicking retry what seemed like hundreds of times!

I still have a play 3 and 2 play 1's to connect in upstairs rooms and it seems I now can't add anything else to the system. I've put them next to the boost and they still won't connect! I've factory reset them all and green lights are flashing, when I go to add new component, they show up but when I push the 2 bottons and get the chime I get the attached error message each time!

If anyone can help it will make my weekend and probably prevent a divorce! 🙂
icon

Best answer by ratty 6 November 2016, 15:02

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

The first thing I suggest you do is turn off absolutely every network device in the house, Sonos or not. Restart the router and wait for it to finish its boot up. Start the BOOST and wait for it to stop flashing its LED. Then start one of the PLAY:5s. Meanwhile start a device you use as Sonos controller. Now try adding the missing PLAY units.

By the way the recommended spacing between router and wired Sonos component is at least 2 feet. You should also check which SonosNet channel has been selected, in Advanced Settings, and compare that with your router's 2.4GHz WiFi. They need to be at least 5 channels apart, and the router shouldn't use a 40MHz width channel since it tends to monopolise the available spectrum. Out of the box some routers can be greedy. What router do you have?
Userlevel 7
Badge +22
Pretty comprehensive from ratty. If you follow each of his steps you should find everything back to working better than before. Once up and running well I like to go into router and reserve the ip addresses for each Sonos unit
Hey Ratty/Chris

I think I've read hundreds of your replies on here this weekend!

Finally everything now working - thanks for your help :)

....not really sure how, but I think it was a combination of changing channel on the router on 2.4GHZ and changing the authentication on the router to https rather http. It was also set to using 20/40Mhz which I changed to 20 as not sure how it determined which to use. It's a Asus RT-AC530 by the way.

I didn't do the turning off all devices bit as with 3 teenage boys this would be the end of the world! ....and we had 32 connected devices to the router!

Now it works, its way quicker using the boost, so maybe a weekend not wasted!

One question now - how do I reserve the IP addresses?
You can reserve IP addresses in most routers' DHCP server configuration. Usually you can select the Sonos devices that it already knows about, rather than having to type in the MAC addresses by hand.

By the way using HTTPS for the router is irrelevant. That has absolutely nothing to do with authentication onto the WiFi via its SSID/key.
Thanks Ratty - think I've done that!

Is this it?
Userlevel 7
Badge +22
yep looks like you have it