Question

Volume control


  • JRT
  • Novice
  • 1 reply
Occasionally when I go to adjust volume, the controls on my SONOS controller take on a mind of their own and spaz out super loud, then super quiet in a jerky way. What's this about?!

9 replies

Hi JRT

Welcome to the Community!

Do you use Spotify? and Do you play direct to Sonos from the Spotify application?

If so it is probably worth turning off the lock screen controls on one of the applications as they could be conflicting with each other.

On the mobile devices go into the Sonos application and then to "settings" -> "app settings" and make sure "hardware volume controls" and "lock screen controls" are turned off.

If you aren't using Spotify, could you submit a Diagnostic and reply with the number shortly after it happens.

Many thanks
Matt R - does this mean that this is expected behavior with lock screen controls on? Or is this going to be fixed? I am experiencing a similar issue and it's very frustrating.
Thank you Matt R, that seems to have worked. I see no difference with those functions on or off at the moment.
Hi - I'm having the same problem, when streaming from Spotify with a 1 and 5 grouped, from an iPhone 6 (Sonos app is not running on any other devices)

Turning off "lock screen controls" didn't help me

Turning off "hardware volume controls" seems to fix it.

There is a comment here from Sonos that they are working on it with Spotify:

https://en.community.sonos.com/troubleshooting-228999/sonos-play1-group-volume-issues-iphone-6767988
If you turn off Hardware Volume Control, then we lose the ability to control individual volume settings for each speaker. That is WHY I want to use it! Sometimes I am in my office and want the living room a little louder so I get more sound from other sources....when Im in my living room - I want some trickle sound from my office :) right now the Iphone app just goes nuts when you try to mess with the volume.
I notice this as well. However just quiting spotify seems to help. I need often use the hardware buttons to adjust volumes. So i don't want to turn them off.
Same here and it's annoying. Seems to be directly related to Spotify. I'm not turning off lock screen control and I use them. This needs to be fixed!
Userlevel 5
Badge +3
mdixson wrote:

Same here and it's annoying. Seems to be directly related to Spotify. I'm not turning off lock screen control and I use them. This needs to be fixed!



Currently one of the fixes is to turn off lock screen control just for Sonos. You're only disabling the controls for Sonos and as you say they aren't controlling the volume properly I don't understand the problem. Doubtless Sonos are working on the "proper" solution. In the meantime don't come on here and petulantly demand an instant fix.
Hello All,

We've been looking into this with Spotify to find a resolution. Turning off the hardware and lockscreen volume controls is the recommended workaround at this point. As soon as we hear any updated information, we'll be sure to let you know.

Reply

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)