Virgin Media Super Hub 3.0 now working with Sonos 2 fix

  • 28 September 2021
  • 4 replies
  • 88 views

If anyone is having problems updating their Sonos 2 app after the update then here is what happened to me.

After updating the app my system stopped working completely. The Virgin hub blocks certain sites including the Sonos servers from accessing it properly therefore creating problems with the app update and consequently drives us all insane trying to figure out what is going on. After many hours of investigation and trial and error I was told by Virgin that the DNS settings need to be changed but they cannot be changed by logging into the settings from your computer, they have to be done by Virgin - but if you’re using a MAC then you can change them as follows:

Go to:

’Settings’

Network’ 

Select ‘Wifi’ 

Select ‘Advanced’

Select ‘DNS’ in the tab above

Click on '+’ 

add 8.8.4.4 within the empty field,   (perhaps the other settings will work on other computers but this worked for me)

Click on ‘Ok' and ‘Apply’ 

Delete and re-install the Sonos 2 app from the phone or device and it will work immediately. 

I reset all my devices and followed the instructions on the app. 

Below is a copy of the DNS server instructions from Sonos, mine worked with the Google Secondary: 8.8.4.4

 

I hope this helps others before you start pulling your hair out :)

 

The issue seems to be rooted from the router so I highly recommend contacting the ISP for them to change the DNS server on their end since you are unable to change it yourself. 
The DNS I would recommend would be open DNS or google's DNS.
Open DNS would be:
Primary: 208.67.222.222
Secondary: 208.67.220.220

Google's DNS:
Primary: 8.8.8.8
Secondary: 8.8.4.4

Once the DNS is changed please reboot the router and all the speakers and try to update again.


4 replies

Userlevel 7
Badge +15

What do you mean when you say you reset all your devices?  Could that have been what really resolved the issue?

I don't understand quite what issue may have appeared to be resolved by them somehow changing your DNS that can only be done on a MAC.

Many people do use Google DNS servers, more for reliability and update speeds I'd say.  If VM really were blocking Sonos updates I'm sure we'd be aware of it much more vocally.

You can quite easily change your DNS server on your PC too if you want/need to.

After I updated the Sonos app last week I could no longer access my system. According to Virgin media there has been a problem with accessing the Sonos update through the Virgin media super hub 3.0. the DNS needs to be changed to allow the servers to be accessed and the update to complete correctly. 

 

I went through all the troubleshooting guides several times, including resetting the devices and removing and re-installing the Sonos 2 app. This was with Sonos technical support. They were the ones who informed me of the Virgin media problem, therefore I have posted this to help others with a similar problem so as not to have to go through the hours of troubleshooting which I had to go through. 

Not everyone knows about DNS servers and so on, most people don’t want to get involved with all the technical issues. 

I hope this helps some people if they have a similar issue.

 

 

It still begs the question why VM’s DNS servers were evidently borked and unable to resolve the Sonos update server’s address.

Userlevel 7
Badge +15

In a cmd prompt, if you do an

ipconfig /all

what does it say for the DNS Servers?  Or are you on a Mac and so changed them yourself?  I’m interested to see if VM changed them for you at ‘their end’.

Was the problem updating the App or the Devices - or both?  For example, did you try updating the App just using the 4G connection - thus avoiding the VM network completely?

Reply