Very disappointed with Sonos system for TV through my condo

  • 9 November 2018
  • 42 replies
  • 506 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

42 replies

By the way, it doesn't look like interference is an issue.
Badge +1
You could have mentioned Google wifi mesh!

Ah Ha! We may be getting somewhere now 😉 Way to go John B!


How so? Does Sonos not support this modem? If so, they should say so in a compatibility list.
We are trying to help. Yes it is supported. It just helps to have crucial bits of information. Jeez
I wonder why I bother sometimes
Badge +1
DELETED
Badge +1
I wonder why I bother sometimes

John I appreciate your help here, but even their support says it's not supported when I spoke to them on the phone this morning. That's all I'm trying to do here. We all know the frustration of doing Google searches to fix stuff, and people don't post the resolution, or say it's solved but don't say how it's solved. I want to stop the next person from having these same frustrations, and perhaps take the product back during the period where that's permitted.

Again, I'm a big Sonos fan for music. I refer it to other people. It just doesn't work with TV audio on a lot of speakers. To be clear, Sonos does NOT support more than the playbar plus sub plus stereo pair in the TV group, and you can ONLY play TV audio if the playbar is part of the group.
The Playbar plus Sub plus surrounds is not a group it is a room. That room can be grouped with other rooms for all forms of audio. Correct that Playbar has to be part of that group, which seems natural and unproblematic to me.

What you are doing is supported. The problem is that it is not working reliably for you
I suspect that Support told you that you cannot add more speakers to the Playbar room, which is true but irrelevant
Userlevel 7
Badge +22
[quote=Harry Fine]
Here are my questions (not that they will lead to a resolution):

1. Are TV broadcasts via cable or OTA - Cable, fibre to the condo, high speed

2. Have there been any changes internally to your electronic environment (router, modem, switches, microwave oven, refrigerator, electric range, cameras, baby monitors or any electrical gadget - [b]Google wifi is about a year old, it's hard to remember back, but it may have started with that, but I'm not sure.


You mentioned that you have Cable and fiber and that you are using a Google Mesh. Might you also have another router in your setup (i.e. yours or ISP provided)? If so you need to do one of the following below:

1. Remove it ...if not possible
2. Turn off the Wi-Fi...if not possible
3. Place the Google Mesh in Bridge mode

I've got to sign off. However, you are in very capable hands with John B. I've learned a lot from his posts.

Cheers!
Google mesh doesn't have a bridge mode
Userlevel 7
Badge +22
Google mesh doesn't have a bridge mode

See what I mean 🆒
Badge +1
OK. I'm back home, was out for a few hours. Did everything you said John, I removed the Boost, removed ethernet from the Living Room Play:1. Turned off all Sonos devices. Turned off all Google Wifi pucks. Turned off cable modem. Plugged Playbar directly into second ethernet port in the Google wifi puck, so the switch is out of the equation.

Turned on cable modem (which by the way was in bridge mode. Your buddy AJTrek1 was confused about bridging.) Let the cable modem get a lock. Turned on Google Wifi pucks. Let them connect. Turned on Playbar. Let it boot. It played. Turned on each of the other 6 Play:1's one at a time, until they were recognized. Added them to the grouping. All 7 now playing.

All device show WM:0. Boost still not connected. Sat and waited. Didn't take 5 minutes before the Play:1s started to cut out.

So I've done it all. I've isolated the switch. I've re-booted everything in order. I've called support who says there is no interference. I checked my TV sound settings with support. I've replaced the optical cable twice. I've got my wifi channels set apart. And the problem is just as bad as when I started.

Whats more, support says this configuration is not supported, that I can't add all my speakers to the group that the TV room (or pair) is in and have it work reliably. So unless you have any other ideas, I would suggest that Sonos is not meant for this type of application, OR the Google Wifi is an issue. I don't really believe that's the problem, but who knows.

So...Sonos does not work driving multiple speakers (more than a few) with TV as the input.
I feel your pain. The complex “solutions” users have to come up with to get it to do simple things like this is ridiculous. If a viable competitor to Sonos emerges I will quickly join the bandwagon. Sonos is great if you are a casual listener who wants basically a speaker or two to play music - anything beyond that (including a record player or TV, both of which are headaches for me constantly) they are gonna find frustration using Sonos. That’s just the sad reality.
Sorry it did not work. If your ISP device is a pure modem then it won't have a bridge mode. If it is a modem router it should not be in bridge mode but should have wifi off and only Google puck wired. But I think you have suffered enough
I was going to suggest rewiring Living Room and wiring Boost to another puck. But it looks like the bandwidth requirements will defeat all attempts
Userlevel 7
Badge +22
@Harry Fine

I'm not confused about Bridge Mode. I don't use it because I'm able to turn off the wifi in the modem/router provided by my ISP. Incidentally my ISP is Google Fiber. I'm paying for 1GB pushed to an AC5300 router. I also use a dedicated Boost module in a 3 level home. I've been running TV audio to 3 complete Sonos HT setups, Play 5 x 2 in stereo pair and Sonos One x 2 in stereo pair for over an hour with no dropouts..

IMO don't blame Sonos as there has to be something going on with your wireless environment. As my question in a previous post finally uncovered the fact that you are running a Google Mesh...might there be other things you haven't communicated?
In 99.9999% of the posts regarding questions like yours it always comes back to the network (or just a lack of understanding of Sonos).

I hope you get your issues resolved. You might take your Sonos back to the way it was on day one before you introduced Google Mesh to see if that resolves the issue. As there has to be a configuration problem in the mix. Also, try using static IP Addresses.

Good Luck...Cheers!
Badge +1
Sorry it did not work. If your ISP device is a pure modem then it won't have a bridge mode. If it is a modem router it should not be in bridge mode but should have wifi off and only Google puck wired. But I think you have suffered enough

ISP (Rogers) has a Hiltron modem which is in bridge mode, so Roger is ONLY providing the WAN IP, that's it. The Google wifi pucks are in charge of the internal network, LAN IPs, connectivity etc.

John, you guys have been very helpful, but it's becoming a case of fan boys who are blaming the user, and you are losing some objectivity. It doesn't work. Sonos even says it doesn't support this. Even if you are right, even if there was some way to make this work, it shouldn't require jumping through hoops, getting rid of my Google wifi mesh system, etc.

I could never recommend Sonos to anyone until they get their reliability and simplicity worked out.