Answered

valid wifi password rejected when trying to add Play 5's back to system


Sometime in the last couple of months my 2 Play 5’s stopped working.

I can work through the “Find Missing Product”, and find the product, setup the SONOS wifi and then try to connect to my wifi network.  All good until i get to the password for my wifi at which point the Sonos App advises that (VALID) the password is invalid.

 

I’ve reset all other speakers, and the router (as suggested on the only other post i can find with similar issues).  No joy.

 

Please assist !

icon

Best answer by davesimau 29 April 2020, 01:24

Problem solved finally. 

i believe it started after a password change on my router. 
 

resolved (I think !) by :

connect speaker via ethernet

change network password

run wireless setup in Sonos/Settings/System/Network

allow time for everything to be applied across speakers 

still didn’t work, 

repeated above, changing back to the “new” (recent over last few months) router password 

all food for me after that  

 

View original

17 replies

I thought I’d resolved the problem.

 

I’ve just connected speaker to ethernet, it’s updated software and appeared in my system.  I then removed from ethernet and it worked fine on wifi - until i switched off, and back on.  My Playbase stopped playing when i switched it off ? 

My Play 5 is no longer connected (without Ethernet) and the “Find missing product
 process leads to the same outcome.

Userlevel 3
Badge +10

Hello @davesimau 

Thanks for reaching out. The best option to identify the issue with your Play:5 would be to submit a diagnostic and reply back with the confirmation number while it’s wired into the router. 

Thanks.  I’ve just submitted a diagnostic report - number 669892826

Userlevel 3
Badge +10

Hey @davesimau, thank you for the diagnostic report. I see that there are 2 Play:5 on your system and the one labeled as Pool. Is that the one that is having the connection issue? If so, I think it might be best that you get in touch with our support team via telephone. They will need to know your full network topology because we are seeing miscommunication between the network and Sonos.

 

I have the same problem with both. I’ve just been trying to get one working to start. 
 

I’ll reach out to telephone support, thanks 

Problem solved finally. 

i believe it started after a password change on my router. 
 

resolved (I think !) by :

connect speaker via ethernet

change network password

run wireless setup in Sonos/Settings/System/Network

allow time for everything to be applied across speakers 

still didn’t work, 

repeated above, changing back to the “new” (recent over last few months) router password 

all food for me after that  

 

My problem is similar but does not involve a changed password, it involves a changed network. I moved house and have a new internet provider. New modem. New wifi network. New password for that network wifi (for a 2.4Ghz connection as with the previous house/network/wifi).

I have succeeded to connect my Play:1 device to the internet via Ethernet cable. When I follow the ‘change to wifi’ process it finds my correct network, asks for the password, and when I enter the correct password (used to connect every other non-SONOS device I own, I get the “Invalid Password” message. No matter how many times I try entering it (correctly).

The solutions I see above appear to involve changing my network password, then changing it back. I would rather not impact all of my other devices currently accessing the wifi if I don’t have to. But if that is the only solution, that would work in my situation, then I’m willing to do it.

TIA

Userlevel 6
Badge +14

@Dan the Fan Is your new network 2.4Ghz b/g/n and not “n only”?

By the way, if you have not bought a lot of new stuff since moving all your old gear should still remember the old SSID and paswoord…....

I’m not sure about b/g/n or “n only” but from what I’ve seen in the ‘advanced specs’ for the network I’m only seeing ‘n’ (e.g. 802.11n). I have no idea what that means other than what Google tells me about bandwidth. I hope the other info below helps.

A couple more bits of info about how I got to where I am now:

  1. Trying to set up wifi initially I got stuck at the step where there was supposed to be a SONOS wifi network to sign onto - no such network appeared in my available networks list (it had worked previously at my old home, but no sign of it where I am now.
  2. As I was working my way through various options, SONOS did update both my device and my smart phone app to the latest versions (e.g. SONOS 2 on my phone). But after all that, where I was able to get was ‘wired’ connection (via Ethernet cable) and the invalid password problem when trying to switch from wired to wifi.

Cheers and TIA for any help you can offer.

 

Channel:                       Auto Current: 13 (interference: acceptable)
Auto Channel Timer(min) 0
802.11n/EWC:                       Auto
Bandwidth:                                                   20 MHz                                 Current: 20MHz
Control Sideband:                          Lower Current: N/A
802.11n Rate:                       Auto
802.11n Protection:                             Auto
Support 802.11n Client Only:                             OffOn
RIFS Advertisement:                            Off
OBSS Co-Existance:                             Enable
RX Chain Power Save:                          Disable Power Save status: Full Power
RX Chain Power Save Quiet Time: 10
RX Chain Power Save PPS: 10
54g Rate:                       1 Mbps
Multicast Rate:                       Auto
Basic Rate:                       Default
Fragmentation Threshold: 2346
RTS Threshold: 2347
DTIM Interval: 1
Beacon Interval: 100
Global Max Clients: 16
XPress Technology:                          Enable
Transmit Power:                                                        100%                         
WMM(Wi-Fi Multimedia):                  Enabled                                      
WMM No Acknowledgement:            Disabled           Enabled           
WMM APSD:            Disabled                   
Beamforming Transmission (BFR):                       Disabled                 
Beamforming Reception (BFE):                       Disabled                 
Band Steering:                       Disabled                                                
Enable Traffic Scheduler:                       Disabled                                        
Airtime Fairness:                       Disabled                                         

 

 

Userlevel 1

@Dan the Fan: If you can keep one of your Sonos wired, I recommend that. You then remove the wifi credintials (network name and password) from Sonos app and run your system om SonosNet (Wired Setup). However, do not diable wifi in the app, as wifi in this context relates to SonosNet between Sonos units.

When you have set up as SonosNet, ensure that all your Sonos units show as “WM0” in Settings→System→About my system. 

At this point in time I only have one Sonos product, so keeping that one wired does not solve my problem of wanting to use that speaker over wifi. I was able to follow the original instructions for setting up wifi from scratch (rather than to switch from wired to wifi), but eventually that process wanted my network password as well, and had the same problem with the message about the password being invalid when I was giving it the correct password.

I even tried changing the network password, as recommended above. That password, entered correctly, was not accepted (using either the change from wired process or the set up wifi from scratch process).

So I am still without instructions I’m able to follow to get my speaker working via wifi. I have yet to hear back from @106rallye based on the additional details I provided.

I live in hope.

Cheers

Userlevel 6
Badge +14

What choices do you get from this setting:

802.11n/EWC:                       Auto

@106rallye 

The choices I get when 802.11n/EWC are listed in my post above (following your previous post). I tried the other option for this value - “Disabled” which changed a few of the parameters as listed below. While this was disabled I tried connecting to my wifi from scratch (i.e. no wired connection up and running. It took me through the usual steps of connecting to a SONOS wifi connection, but when I selected my 2.4Gh network I got the same password invalid result as I have been. Given it failed, my network is currently back on the “Auto” value for that parameter.

Here are the values for that network with it set to “Disabled”:

Channel:                       Auto

Current: 13 (interference: acceptable)

Auto Channel Timer(min) 0
802.11n/EWC:                     Disabled
54g Rate:                       Auto
Multicast Rate:                       Auto
Basic Rate:                       Default
Fragmentation Threshold: 2346
RTS Threshold: 2347
DTIM Interval: 1
Beacon Interval: 100
Global Max Clients: 16
XPress Technology:                          Enable
54g Mode:                             54g Auto
54g Protection:                               Auto                         
Afterburner Technology:                                                                   Disabled        (Disable WMM for Selection)
Preamble Type:                                                         long         
Transmit Power:                                                  100%                         
WMM(Wi-Fi Multimedia):                      Enabled                                      
WMM No Acknowledgement:            Disabled                  
WMM APSD:                Enabled           
Beamforming Transmission (BFR):                       Disabled            
Beamforming Reception (BFE):                       Disabled      
Band Steering:                       Disabled                                  
Enable Traffic Scheduler:                       Disabled                           
Airtime Fairness:                       Disabled                           
Userlevel 6
Badge +14

Not a network expert, but I also see a button labelled “Support 802.11n Client Only:”, that can be turned on or off. Since “n only” could be a problem: have you tried this setting?

I've not seen you mention make and product number for your router. Tha could give other people guidance helping you.

@106rallye - I just changed the setting. Still no luck connecting to wifi. Either via direct route (Sonos couldn’t even find my device (Play:1) on my system) or via connected ethernet cable (found my device and connected to it, but attempt to go to wifi from there had the same password invalid issue.

:-(

Userlevel 6
Badge +14

Seems strange. Again, please mention make and model of your router. Maybe that will help people helping you.

@106rallye My router is a Netcomm model NF18-ACV05

Reply