Update to 7.3 Spotify repeating every song. Driving me mental! HELP!


Since updating the controller to 7.3 and updating my iPhone iOS (not sure this has any impact) my spotify is repeating every second song. I start a play list, the first song starts and finishes in full, the second song starts and finishes and restarts. The it repeats every song on my playlists and streaming other lists. The UI shows the album art and name of the next song on as if its playing now but its replaying the previous song. This happens on both sonos and spotify connect. This is driving me mad!

I am running:

Sonos 7.3
Play 5 gen 2
2x play 3
Iphone 6 with iOS 10.3.2

Things I have tried:

Unchecked repeat in both Sonos and spotify

Uninstalled sonos and spotify apps on laptop, iPhone, Ipad
Uninstalled the connection with spotify in sonos app
Connected to a different spotify account

Switched off all wireless devices in the house
Switched off all sonos at the power
Switched off the router, waited then switched back on and turned on only the Sonos. Connects but doesn't help

Changed from boost to standard and vice versa

Changed the channel the router is using to 6.

Nothing has worked!

Please help!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

57 replies

Same issue: 7967731
Userlevel 7
Badge +20
Hi , frankbot and ricrac,

Your systems are now flagged for a patch which should help. Please run updates and test things out.
Userlevel 7
Badge +20
I'm having the same problem. How do I get the patch you are discussing? Seems like people are posting a diagnostics no. but not sure where I can get one. Can anyone help?

Hi skodlod,

I used your community account email to find your system so you shouldn't need to submit a diagnostic report. Please check for updates on your Sonos system, run any that it finds, then test out Spotify and let me know how it goes.
I continue to have same issue with my iTunes music-- my confirmation number is: 7983596
Hi Sonos, yes I do have the same problem.

Diagnostics no 8051109

Please help
Thanks
Martin
Why can't you just add this patch to a general update? The problem isn't solved for over two months! Same problem in Germany, diagnostic number is 7894283. Please add the patch.
Thanks!


I had this problem for weeks, then I discovered this community entry, applied for the patch, got it and everything seemed to be fine. But since the last update I have the same issue again. It’s frustrating. New diagnostic code 8067339

Please help me!
Can I also be added to the patch?