Update problems 8.2 and 8.2.2

  • 13 December 2017
  • 37 replies
  • 5531 views

This latest update is ridiculous - my app and system continually want to update, no way to turn off the request. It won’t successfully update, and I always get an Error 30 upon resolution. The recommended path forward is for me to disconnect all my equipment, update, then connect one puece and update again. This is crazy - I have over a dozen units, all tuned and working fine before this update. Forcing me to spend an hour or more updating your software is unreasonable.

Very unhappy with this update. Is there any other means of updating?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

37 replies

I would certainly echo jgatie's recommendation. In fact, in my considered and humble opinion, the more Sonos devices you have, the more important this step is. But, knowing what I do now, I'd even do it if I had only one Sonos speaker.
You should not have to run around rebooting Sonos every time. Sounds like your router gets its allocation tables wiped, causing it to hand out duplicate IP addresses when all the Sonos devices reboot during an update. You can prevent these duplicate IP addresses by assigning an IP to each device's MAC address in the router setup. See your router manual for details. I did it a while ago, and though I only had a few problems with updates previously, I have had absolute zero problems since.
Userlevel 2
I'm not sure why Sonos has so much trouble with their update process being so unreliable. It has pretty much been the same for several years, including the latest update to 8.3.

I have 14 units, which include Play 1s, 3s, 5s, Playbars, a Sub, a Connect:Amp, and a bridge. In all aspects except updating, everything is pretty flawless, although they do occasionally like to do a complete redesign of their controller apps which requires a bit of relearning. The old muscle memory to get to Favorites has to be forgotten.

Usually, we end up with a situation where one of the mobile apps (my wife's (she'll never see this, so I'm just going to put it out there)) has "Check for Updates" turned on. This will invariably put the controller into an unusable state until the update is performed.

I've learned that a desktop controller on a computer usually has better luck actually getting the update to the device, so once my wife is a frustrated prickly bear, I'll go into the office, open the desktop controller and attempt to update. It will fail.

Then I go around the house, manually unplugging each Sonos device for about 10 seconds, and plug them back in.

Once I've done that, I just have to run through the update process 14 times. Even though all the devices are online, the controller only seems to update 1 at a time. It's basically clicking "Try Again" a bunch of times. C'est la vie. After 14 iterations, everything is updated and all the apps start working again. Yay.

I'm not sure Sonos expected people to have this many devices.

While the update process is quite painful, I'm more than happy to put up with it periodically for the enjoyment I (we (my wife especially)) get out of it on a daily basis.

I had to reboot all my devices - http://:1400/reboot

Then check the software version release date of each device after the reboots - http://:1400/support/review


Thanks @Gregwlson.... I hadn't thought of rebooting devices remotely. That will be a big help. 🙂
I didn’t say unplug every unit. Just one unit hooked to router.

No you will not see the advanced menu because your software is updated and not your hardware. You will see it after you update the hardware.

Plug one Sonos unit into your router. Give system 5 minutes to adjust then try update of hardware.


This worked for me. Unplug all speakers and plug the one new speaker that needs the firmware update onto the booster.
I was getting the error message and was unable to access the system from my laptop. I went to the SONOS website, and downloaded the file for my Mac OS. it asked if I wanted to replace the old file. I said yes. Reinstalled app popped up and downloaded the 8.2.2 update. Problem solved! I didn't have to unplug any of my units, but I'm only running 2.
Badge
Just managed to finally FIX mine!
I have 14 speakers with every possible speaker and setup (except a Playbase or new One Alexa).
I have been trying to update using everything suggest over the last week.
My fix;
Checked “about my Sonos system” to see which units had update to 8.2.2 and which were stuck in 8.2.
I then unplugged all units stuck in 8.2 except the bridge (which was in 8.2). I then ran the update and the bridge updated to 8.2.2
Next I Plugged in each room- one at a time- and ran the update after connecting each room. Checking “about Sonos” each time to make sure the speakers have updated.
Took me 30 mins to update 7 speakers out of my 14 that were stuck in 8.2.
To complete this fix I did not have to reboot my router, switch, or any of the units that had the 8.2.2 update.
Very long winded (I had previously spent about 2 hours trying all the suggested fixes beforehand).
I had submitted a support request as I usually get a quick reply. I guess they must be very busy and understand, so decided to try and figure it out myself.
Hope this helps anyone else who is ‘stuck’

Merry Christmas!!!!
Badge
further update....definitely the connect is the issue. play 1 updated fine. unable to group zone with connect probably because its not updated. it is playing none the less. sent diagnostics to sonos. will see how it goes.
Badge
i have tried every suggestion listed. i discovered that although the app says its already on 8.2.2, its still asking to update to 8.2.2. ughhhh. i also noticed the reinstalled app on ipad was working fine with my play 1 for almost 30mins and did not ask for an update untill i plugged back in my connect. weird? I'm now back to unsuccessfull updates despite what i try. someone above asked why are the speakers wired to the ethernet in the home? I have been forced to do that because of all the buggy issues with connecting and disconnecting recently. ive already regretted making this investment as im yet to experience continuous smooth operation of the system. the sonos tech team's input on these topics are also deafeningly silent and helpless. this brand so far has not lived up to its name as advertised for me. 😞 extremely disappointed and highly annoyed.
This is the first time I had any problems with an upgrae. I had the same problem with my upgrade to 8.2.2 and had to reboot the Boost by pushing the reset button and when the light went from flashing red to white, I went to each Play:1 speaker and pushed the top button and when the light went from green to white the speaker came one....total time, about 5 mins. Hope this helps someone.
Userlevel 4
Badge +1
This latest update is ridiculous - my app and system continually want to update, no way to turn off the request. It won’t successfully update, and I always get an Error 30 upon resolution. The recommended path forward is for me to disconnect all my equipment, update, then connect one puece and update again. This is crazy - I have over a dozen units, all tuned and working fine before this update. Forcing me to spend an hour or more updating your software is unreasonable.

Very unhappy with this update. Is there any other means of updating?


Not sure if this helps but I find if I update through a PC it almost never works the first few times... however using the APP almost always updates the first time...
In any event, I have 18 Sonos devices in my house... I have never seen the system be so unstable as I do now... It seems that the new Management has really hurt the company's image... Although the Alexa integrated is cool... it really doesn't add that much value to the product..which should be "Sound Quality First, then Easy Access to Music" In my option, Sound Quality is still good... but easy access to music has taken a major turn for the worse... The New App is absolutely HORRIBLE... for me, it's not just the look of it, it's the EASE of use... In short, the Sonos needs to hire a company that can provide Human factors, User interface and experience for their software development.
Userlevel 7
Badge +26
That sounds really frustrating, meuha. With any update, there's a chance the network has some trouble based on all of the players rebooting and pinging for IPs. I've seen that sort of thing come up regularly each time. What you're describing sounds like a broadcast storm, where the Sonos traffic builds up on the network because BPDUs aren't being allowed to pass properly and another device is trying to manage STP and not approving of Sonos communication. If you bring Sonos down to just one player wired to the network, does this prevent any issues?

If you're still having trouble, I'd suggest that you give us a call on our support line.
Userlevel 7
Hello,

This update is a disaster.I f have just sent support the following report.

Quote After physically removing all the SONOS devices from the network (they are all connected by wired ethernet) the network recovered. Unquote


This new 8.2.2 update obviously affects Sonos users in different ways depending upon devices being up-to-date and/or network configurations. Sometimes these things happen because it's impossible to recreate every possible environment in a test facility. However, if a enough users submit their diagnostic reports I'm sure Sonos engineers will find a common thread that is causing the update frustrations and correct it in a future update.

Unless you misstated your Sonos environment; I'm curious as to why you have every Sonos component wired by Ethernet?

Also, having every component wired by Ethernet defeats the purpose of having a wireless system. Furthermore (granted I don't know the layout of your home or how many Sonos components are in play) you are either running a lot of Ethernet with long runs or you are employing "switches" which for best results should be unmanaged as they are transparent to STP traffic.

Just a few thoughts. Hope you get your issues resolved.
Userlevel 7
Badge +17
8.2.2 update worked fine for me, from prevous 8.2 where I had to remove & re-install the app. My iphone is not upto date as I ignored that request first.
Hello,

This update is a disaster.I f have just sent support the following report.

Quote
After being prompted by the app I started an update of the controller to version 8.2.2. The update did not finish and stopped in the middle of "finishing up" where its timed out. It was almost impossible to connect to the system, but once in a while I succeeded for very short periods. The system reported an error code 1101. I tried to reinstall as suggested, but that failed miserably. From the failed update I ran in to severe network issues. As it turned out after several hours of searching the SONOS system was flooding the network to an extend that other network traffic was not possible anymore. The network just broke down under the generated traffic. After physically removing all the SONOS devices from the network (they are all connected by wired ethernet) the network recovered. I have attached two screen prints where it is visible that when the devices are connected to the network the network goes to the brim of capacity. The file SONOS_Lan shows the load on the 2.4 GHz Band (almost 90%) and the Sonos-Lan-2 shows the traffic in the 5 GHz band. Unfortunately I am not able to provide you with the diagnostic information as it simply is impossible to establish a connection between the app and the controller.
Unquote

I hope the will fix this.
I wasn't able to edit my previous response, let's try it again:

I had multiple errors with the latest update and finally got everything on 8.2.2 after the third try.
No need to physically unplug anything.

I initially rebooted all my devices - http://(sonos IP address):1400/reboot

Then checked the software version release date of each device after the reboots - http://(any sonos IP address):1400/support/review

This generates a list of all Sonos devices, expand the headings to see all IP addresses and software versions.

Then reboot any device that isn't on the latest (December) version before attempting the update again via the app.

I've only had Sonos for a couple of years but this is the first update that's given me any trouble.
Userlevel 7
Badge +26
This latest update is ridiculous -
The most rediculous with this update is that it doesn't contain any improvement at all regarding the layout and colors.... why not listen to the costumers and do some real improvements???

While our design team is looking into app improvements right now, this update had an extremely important security update that we felt needed to be out as soon as possible. It patches the KRACK vulnerabilities in the wireless of our products (see https://www.krackattacks.com for more information on these vulnerabilities). While updates might not have something specific you're looking for, we try to make sure to only put them out when it's something important.
This update was likely already in process even before the original 8.0 was released. I suppose they could have held on to the update that fixes a vulnerability in their software in order to include layout improvements.....
Userlevel 2
Badge
This latest update is ridiculous -
The most rediculous with this update is that it doesn't contain any improvement at all regarding the layout and colors.... why not listen to the costumers and do some real improvements???
Yes, in the past Ive been extremely happy with sonos - regular beta program tester for them, no issues for years. That is part of why this one is so frustrating to me.

I submitted a diagnostic and help ticket last night. I unfortunately work/commute during the hours they publish as being available via phone, so email is my most effective method for communicating directly with them.

Chris : Nothing I have tried has been successful in updating my system. I havent unplugged every sonos device in the house yet, that will require a substantial amount of time since many of my units are mounted high up and Ill need to carry a ladder around my house to every room. I did unplug everything form my router, then plugged my boost (only) in, and when that failed, tried plugging a play 5 (only) in to the router directly, and that also did not work.

AjTrek1: Yes, all phones and tablets are running the most up to date software version available for the OS, and the app itself updates and downloads without an issue. Its the system update that fails. I have tried deleting and reinstalling the app on both an android phone and an iphone and then running the update - still fails.
RE: My boost. My network is set up with my router connected directly and only to a network switch. All other devices have been on the network switch (including the Sonos Boost) for more than a few years, and I havent had any issues with the sonos system set up that way in the past. I have changed nothing about my network set up in many many months, so if there is an IP conflict it was caused by this update. What I did last night was remove the network switch, and connect the boost directly to the router (which shouldnt have an impact from a networking perspective, but I tried it anyway). That update failed, so I removed the boost, and connected a Play 5 directly to the router, and that update failed too. I both RESET my boost, and changed ethernet cable connection point as options - neither worked. And yes, I did these after checking for OS updates and Sonos app updates.


Thanks for the advice everyone - hopefully the Sonos team can help me directly.
This latest update is ridiculous - my app and system continually want to update, no way to turn off the request. It won’t successfully update, and I always get an Error 30 upon resolution. The recommended path forward is for me to disconnect all my equipment, update, then connect one puece and update again. This is crazy - I have over a dozen units, all tuned and working fine before this update. Forcing me to spend an hour or more updating your software is unreasonable.

Very unhappy with this update. Is there any other means of updating?


I finally got everything on 8.2.2 on the third try.

I had to reboot all my devices - http://:1400/reboot

Then check the software version release date of each device after the reboots - http://:1400/support/review

Then reboot any device that isn't on the latest (December) version before attempting the update again via the app.

I've only had Sonos for a couple of years but this is the first update that's given me any trouble.
Userlevel 7
I am also in the loop where Sonos tells me that I need to update, opens the App Store to update, but the only choice is to open Soonos, which puts me back into the loop.

It sometimes caches, so you need to refresh the page by pulling down, or just install it from the app store directly .


I have exact same problem. When I go directly to the app store it allows me to open currently installed app, but not update it. Something is wrong with that update.


You need to delete the App. Then go to App store and download the new version. Worked for me with a few caveats. See my first post from 10 hrs ago.
Userlevel 7
I’ve tried updating via android and iPhone, I’ve uninstalled and reinstalled the app on both, no success.

I’ve plugged my boost directly into the router and tried updating, fails.
I’ve tried plugging the play 5 that is close enough directly into the router and updating again, fails.


Two things....

Regarding your phones..are they up-to-date with the latest software? Outdated software on any device can cause problems with an App.

Regarding your Boost...What did you mean when you said..."I've plugged my boost directly into the router" . Your Boost should have already been plugged into your router. Were you by chance indicating that you reset your Boost? If so, doing so only requires that you disconnect power for about 30 secs to reset. No need to remove the Ethernet cable.

Also, I suggest you follow these steps after you are sure the software on your phones are up-to-date.

Unplug every device that uses Wi-Fi or Ethernet. Reset your router. Plug in every device (starting with your Boost then Sonos speakers) one by one. This process should eliminate any internal IP conflicts. Just a suggestion. If no joy then submit a diagnostic as suggested by Chris.

Good luck and Cheers!
I am also in the loop where Sonos tells me that I need to update, opens the App Store to update, but the only choice is to open Soonos, which puts me back into the loop.

It sometimes caches, so you need to refresh the page by pulling down, or just install it from the app store directly .


I have exact same problem. When I go directly to the app store it allows me to open currently installed app, but not update it. Something is wrong with that update.
Userlevel 7
Badge +22
Sounds like your issue is unique. I would call Sonos on phone.

In meantime out of curiosity. If you unplug all your Sonos units as you did. Have the single Sonos unit on that is hard wired to the router. Will it update.
I’ve also reset my controller and reconnected. Still all fails.