Update problems 8.2 and 8.2.2

  • 13 December 2017
  • 37 replies
  • 5581 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

37 replies

I’ve tried updating via android and iPhone, I’ve uninstalled and reinstalled the app on both, no success.

I’ve plugged my boost directly into the router and tried updating, fails.
I’ve tried plugging the play 5 that is close enough directly into the router and updating again, fails.
I just did my 5 zone set system; faultless as always and done in 5 minutes. So it isn't as if there is an all pervasive bug. I know the last time I had to delete the Sonos app on the iPhone and reinstall it; the update route was hanging and I suspect that was an Apple issue.

The occasional glitch like this usually hits early adopters with agencies other than Sonos involved in the process, and usually also have a simple workaround.
Chris - I mention unplugging all units because that’s what the sonos troubleshooting guide says to do.

I have a play 5 plugged in to my network switch which is plugged directly into my router. I’ll try changing it to be plugged directly in to the router and try the update again.

I still think that it is poor testing for sonos to release an update that requires this sort of behavior to update.
Userlevel 7
Had the same or similar issue on my iPhone X. I first reset my router...no Joy. My next step was to delete the Sonos app and when prompted Connect to an existing Sonos system. At first I thought everything was fine as the update seemed to take. However, I discovered I could not connect to my Sonos account. So I reset my router once again and since I use a Boost I reset it also. Eureka!!! Everything is back to normal and running Sonos 8.2.2. Resetting my Boost would be the same as if I were using a Sonos speaker in Boost Mode which I suspect is along the same thought process as RVA Chris suggested.

However, If you're listening Sonos Development this update is a bit buggy at first. I'd never experienced any diffuculty updatinng before. Guess there's a first time for everything. Cheers!
Userlevel 7
Badge +22
I didn’t say unplug every unit. Just one unit hooked to router.

No you will not see the advanced menu because your software is updated and not your hardware. You will see it after you update the hardware.

Plug one Sonos unit into your router. Give system 5 minutes to adjust then try update of hardware.
There is no “advanced settings” option under the settings menu on my app. It’s not just the constant update request (although that is annoying). It’s that their software update has caused a major issue with my system that will take a user lots of time and effort to fix. Most of my hardware is mounted with concealed cords in innocuous locations. Having to unplug every unit in my house to update software on a system that was functioning perfectly before is not reasonable.

I do have one unit plugged directly into my network hub/switch.
Update first using a desktop app. When the update is complete, delete the iPhone app, and re-download it from the App Store. Worked for me.
I am also in the loop where Sonos tells me that I need to update, opens the App Store to update, but the only choice is to open Soonos, which puts me back into the loop.

It sometimes caches, so you need to refresh the page by pulling down, or just install it from the app store directly .
I am also in the loop where Sonos tells me that I need to update, opens the App Store to update, but the only choice is to open Soonos, which puts me back into the loop.
I have no advance setting choice under settings.
Userlevel 7
Badge +22
Under settings...advanced settings. There is a checkbox to turn off automatically check for updates.
Userlevel 7
Badge +22
There have been more updates recently. Historically Sonos has only had a few updates a year.

When I have had trouble with hardware updating (I assume your app updated fine) .... just try taking one unit and hooking a single unit to your router. Give it a couple minutes to adjust to being sonosnet. Then try updating hardware.