Unifi and Wireless Sonos

  • 18 August 2021
  • 8 replies
  • 289 views

I have a very simple home system consisting of of a standard modem/router (ZTE H268A) and 2 Unifi lite APs. I have 6 Sonos devices (2 x Play5s, 2 x Play1s, Arc Soundbar, Sub). 

Before changing to the Unifi setup all Sonos products worked fine and were accessible via the Sonos or Windows app.  However, they are no longer accessible.

So I reset the app (Android) and tried to start afresh. I reset one of the Play1s (wireless) and tried to add to the app - but the app cannot find the speaker. So I temporarily connected the speaker to my router via an ethernet cable and I can find it in the app and add. But if I remove the cable the speaker is no longer visible in the Sonos app.

I would like to have all Sonos devices connected wirelessly.

I have tried various configuration changes as mentioned in multiple topic queries both in this Sonos Community blog and also in the Ubiquity Community Forums without success.

Anyone got Sonos working purely on WiFi with Unifi APs?  


8 replies

Userlevel 7
Badge +17

It would be good to know what you have tried already. That way people would not propose possible solutions you’ve already tried and that have not worked…..

Things tried that I have gleaned from other posts here:

  1. Settings --> Network --> IGMP Snooping: Set to Enabled
  2. Settings -->Wireless Networks --> Block LAN to WLAN Multicast and Broadcast Data: Enabled
  3. Settings -->Wireless Networks → Multicast Enhancement (IGMPv3): Enabled
  4. Settings -->Site --> Auto-Optimize Network: Disabled
  5. Settings -->Wireless Networks --> Guest Policy: Disabled
  6. Settings → Controller --> Make controller discoverable on L2 Network: Enabled
  7. Set AP channels to manual (1 & 9) & (40 & 149)

I can connect one device i.e. Play1 via ethernet cable to the router and set it up and then also connect another device via wifi) i.e. another Play1), but as soon as I disconnect the ethernet cable, the 2nd wifi device disconnects from the sonos app.

Badge +18

Try something along the lines of mutli-cast channel isolation

Things tried that I have gleaned from other posts here:

  1. Settings -->Wireless Networks --> Block LAN to WLAN Multicast and Broadcast Data: Enabled

This is incorrect. You do not want to block multicasts or broadcasts.

 

  1. Settings -->Wireless Networks → Multicast Enhancement (IGMPv3): Enabled

Some have found this causes problems.

 

  1. Set AP channels to manual (1 & 9) & (40 & 149)

Channel 9 is a poor choice. The standard non-overlapping channels at 2.4GHz are 1, 6 and 11.

Userlevel 7
Badge +21

Shouldn’t both APs be on the same channels for Sonos use?

I looked at the changes I’d need to make to my Ubiquity setup to support Sonos and decided it wasn’t something I wanted to do.

My first step was (dumb) to buy a Boost and by connecting it all my Ubiquity issues went away. A smarter first step would have been to wire any Sonos device to Ethernet and set the SonosNet channel to one my AP(s) weren’t using.

If SonosNet won’t work due to your Sonos being too far apart you can wire one of the remote ones that won’t connect or add a Boost in the remote location.

OK I think it is just too difficult to get Sonos working on WiFi with Unifi - it really should not be this hard!

I ended up buying a second hand Unifi Boost and just waiting for it to arrive to install.  Hopefully that fixes the issue.  It is obvious Unifi has some issues with some devices - I have a similar problem trying to get my LG TV’s LGthinQ to work.

Badge +2

I don’t have a solution, but wanted to say that I’ve have a unifi/ubiquiti network with sonos running on it for a few years now. I have a combination of wired + wireless sonos players.

I have spent entirely too much time battling between Sonos and my UDM Pro.  I had two AP’s, 1 wired 1 working as a wifi extender/mesh, one SSID, one network, etc… all very simple.  My issues revolved around speakers dropping out from the app, showing up intermittently, and generally the more speakers I added the less likely anything was to work up until zero speakers would show up.

I am not 100% what specifically ‘fixed’ my issue, but sharing in any case.

  • Removed the wifi extender AP to simplify what I have
  • Settings → WiFi → Disabled “Optimize IoT WiFi Connectivity” Not entirely sure what this does, but as part of simplifying this was on the disable list.
  • Enabled Multicast Enhancement
  • Set 2.4 Ghz to channel 6

Reply