Unable to update Play5 speaker- lost connection to Amazon Music

  • 7 October 2017
  • 1 reply

My Play5 Gen 1 speaker will not complete the update. I get constant error 30 messages. I have tried all the remedies and spent hours on the phone with tech support. Tried direct Ethernet cable to router, eliminated my bridge, rebooted everything countless times, double and tripled checked my router settings. After I updated the control software on my iPhone, iPad and Mac I lost Amazon Music. I am running an Asus RT-N66U router, 100+ Mbs download. I had no issues prior to the latest update. Any ideas out there in the community?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 7
Badge +19
Hey there, rcuomo. Thanks for reaching out to the Community. I am happy to take a closer look at what is going on. Would you mind sending us a diagnostic report and replying with the confirmation number it gives at the end? I didn't happen to see any tickets on file for your email address in the Community. Do you happen to have a reference number for the call you've had with our technicians or the ticket created? Much appreciated.