Unable to update, error code 11 - Unable to send diagnostics

  • 2 April 2017
  • 2 replies
  • 1537 views

I bought used ZP100 and Connect units which both ask for update prior to operate. I've tried every possible network trick but nothing works, error code 11 every time. I've tried with IOS/Mac, (hard)reset, re-install, DMZ and i have 100Mbps fiber link routed thru VDSL2 (Zyxel WMG-1312 B10D) with no trouble to access Internet with any other device and there are a lot of them. Even disabling every other device won't make a difference. For some unimaginable reason none of the control apps aren't able to send diagnostics out either nor it doesn't allow IOS to submit it via cellular either (just to try a different routing) but only WiFi.

I'm also new to SONOS.

Searched this Community and Google for answers but wasn't able to quite find the right one.. Similars had connection and router, etc issues which i think i don't, or at least none of the other devices doesn't?

Submitting diagnostics doesn't create any logs, so not much about that.

Here's the diagnostics from Mac Console (probably the only way to submit those?)

2017/04/03 00:11:20:567 updatemgr(1): possible system update: manifest=
2017/04/03 00:11:20:568 updatemgr(1): baseline version 35.3-39010, baseline url=http://update-firmware.sonos.com/firmware/Gold/35.3-39190-v7.2-jkqqah-GA-1/^35.3-39010
2017/04/03 00:11:20:569 updatemgr(1): there are 1 ZPs in the household
2017/04/03 00:11:20:569 updatemgr(1): controller self-update prevented (to=35.3-39010, azp=7.6-41043)
2017/04/03 00:11:20:569 updatemgr(1): updates needed: 1 ZPs, controller=false
2017/04/03 00:11:23:205 updatemgr(1): updating system: manifest url=n/a
2017/04/03 00:11:23:206 updatemgr(1): baseline version 35.3-39010, baseline url=http://update-firmware.sonos.com/firmware/Gold/35.3-39190-v7.2-jkqqah-GA-1/^35.3-39010
2017/04/03 00:11:23:246 updatemgr(1): Pausing household for ZP update(s)
2017/04/03 00:11:23:246 updatemgr(1): continuing to update ZPs
2017/04/03 00:11:23:246 updatemgr(1): updating ZP RINCON_000E5813E6A401400 ((Unknown)) http://update-firmware.sonos.com/firmware/Gold/35.3-39190-v7.2-jkqqah-GA-1/^35.3-39010, milestone=0
2017/04/03 00:11:27:363 updatemgr(1): error 11 upgrading ZP http://10.0.1.35:1400/xml/zone_player.xml during phase DOWNLOAD (upgrade file download failed)
2017/04/03 00:11:27:364 updatemgr(1): reboot sent to all ZPs

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Any fix? I have the same issues.
In my case, OS version 2.2 was too old to be updated online, so their customer rep took remote connection to devices via my PC and took care of the updating. Now everything works normally.