Unable to play xxxxxxx. Lost connection to spotify - over and over and over again...


The connection to Spotify is lost over and over again when I try to play songs on my Sonos system. It happens again and again. Sometimes it manages to play half a song, but then stops. It goes on like this for days. Some days it works. Some not.

Diagnostics no: 3735414

I have a Netgear CG3700 modem connected to an Airport Extreme 802.11n 5th generation and extended wireless network with an Airport Express 802.11n 5th generation. Bandwith is 100mps.

Please help, I have had this problem for a long time now.

Best regards, Per

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

158 replies

Jasonbarone,

Often the issue isn't with the speed of the fiber coming in, it's the local network issues that cause disconnects. Most frequently, it's an IP conflict on your router, although it could also be simple wifi interference. Due to the constant nature of music, the Sonos environment needs a robust and solid wifi connection, and is significantly less tolerant to issues than many other wifi devices are.

If it's the wifi interference, I'd recommend either making sure that the speakers aren't near any other wifi device (webcams, wireless printers for example), and that if you have a bridge/boost device, it's at least 2 to 3 feet away from your wifi router. Also, try changing the channel your Sonos devices are using, either by changing the wifi router's channel, or if you're in boost mode (one speaker is connected to the router with ethernet cable) using the app.

It's a little more work if you have IP conflicts in your local wifi system. Most of us recommend turning off all devices that connect to your wifi, as well as the router itself, and then bring them back up, one at a time, starting with the router, and allowing each device enough time to receive a new IP address. This could be mitigated in the future by assigning reserved IP addresses to your devices, since every time Sonos does a new software release, it causes all of the speakers to reboot. Check the router's manual on how to set up reserved IP addresses, you can find the MAC addresses for your speakers in the "About my Sonos System" in the app.

Finally, if you want "better" help, it would be wise to submit a system diagnostic and post the number in the thread. If done within 10 minutes or so of the issue, it would likely be able to capture the problem in the log files that are submitted, and posting the number in the boards would help the Sonos folks to know what they're looking for.
Same issue. Sonos is the absolute worst piece of technology I think I've ever purchased. No product in history has caused so much frustration. Constant disconnects, every other day, on a perfect business fiber connection.
Hi smahoney, thanks for submitting the diagnostic. The report is showing communication issues between your PLAYBAR and the router, to the point where the PLAYBAR gets temporarily disconnected from the network. This is likely caused by some sort of wireless interference and will definitely affect the playback. This link will outline common sources of interference. Please review the link and check to see if you have anything in your house that could be interfering with the router's communication to Sonos.
Jeff/Ryan,

I, too, am having the same issue as described. Sometimes I am unable to make six songs in a row play, while other times the app skips to the next song on the playlist in the middle randomly, providing the same "unable to play... lost connection" error. Other times it works just fine for a few songs. I will also note that this development is fairly recent, and I am 90% sure it did not occur before I updated to the most recent version of the Sonos app.

I tried restarting my router, removing Spotify from the Sonos app, then reconnecting them, and it immediately had the same issue. I ran a diagnostic at that point: 7254070.

Thanks for your help.
Jeff - thanks for the patch and the quick reply. Will report on progress with this, but the immediate issue is that playing to the Sonos from the Spotify app seems to be completely broken now....
Badge
So as i said i work and your support is only 9-5 Monday to Friday..Not helpful . So do you suggest I take time off work to spend on the phone to a tech to fix what's clearly an issue at your end..(please just look at the forums , the evidence that it's your problem is there!)
You reference tired old help desk resolutions (it's the router change the channel, it just needs a reboot etc). Done all this, have rebooted, there's no IP a conflicts or devices with the same IP, the router is on a fixed channel (as it as pre update), i have tried different channels across the spectrum, disabled firewall temporarily , added the Sonos bridge, and factory reset the speakers so it's basically a new system now and nothing else on the network has issues therefore i have done your fault finding for you.
Please please look at the forums, look at the people that are reportiny Spotify cut outs, Apple music cut outs and tunein radio cutting and skipping and then with only the smallest amount of intuition you may see the problem is with yourselvea and funnily enough its since the last update.
Come on guys and get you act together - love the Sonos kit but this is really poor service.
Userlevel 7
Badge +26
Hey Ricky, we're always looking to find any issues that might exist in the Sonos software, so when it comes to connecting dots to find related cases we're always keeping an eye open. Audio cutting out in some way, especially across multiple services can be caused by a number of different things. Immediately following an update, the most common issues are wireless interference (often because of a router in the area on automatic channel scanning mode) or IP address allocation issues on the network.

We want to help, and always happy to look into any potential trouble. That's why we'd love to get you working with a technician live, as Jeff set up above. It's always best to have us work with you one on one so that we can get a really good look at the network, environment, and anything else that might be playing up. Once all variables have been isolated, we can really start to get good data on if anything else is going on.

I understand it's frustrating when things aren't working, but we're here to help get you up and running.
Badge
That's kind of unhelpful as i do work and am guessing i will need to be by the speakers?
This doesn't address the ongoing issue with tunein dying on me like its buffering and then giving up either. Surely you guys know you have a problem as a quick browse of the forums shows people having the same issues with tunein, Spotify and Apple music - it's not isolated so clearly is a problem since your last update. Wouldn't be so bad if you guys could just put your hands up and say you know and are working on a fix!
Userlevel 7
Badge +20
Here you go 7244707

In your diagnostic report I see that your system is timing out when trying to connect to Spotify. It would be best to work with our phone team on a resolution to this issue. Please give us a call. I've added your information to your support ticket: 170327-001383. You can find our phone number and hours here.
Badge
Here you go 7244707
Userlevel 7
Badge +20
So been trying to play a single from Spotify but it just won't have it. Have even tried using Spotify app and connect to speaker but it won't have it. But, adding the track to a play list and then playing it that way works.... Surely identifies a problem with Sonos' connection with Spotify??? This really needs fixing for all of us asap!!

Hi rickyhall11,

Please submit a diagnostic report from your system then reply with the confirmation number.
Badge
So been trying to play a single from Spotify but it just won't have it. Have even tried using Spotify app and connect to speaker but it won't have it. But, adding the track to a play list and then playing it that way works.... Surely identifies a problem with Sonos' connection with Spotify??? This really needs fixing for all of us asap!!
Userlevel 7
Badge +20
If you have a patch for this problem, why don't you release it in a firmware update? Not a single one of these solutions seems to work, and I'm starting to think that this expensive toy is just a shower of S%$@ at this point.

So like all the others, ref 7244202 if there is any help to be had...


Hi jel8282,

We have a patch available but it addresses a specific issue with some network hardware. It isn't catch-all solution. In the 7.2 release we added a fix for a different issue which can cause the same error. In your system's case, there's an error which the patch should help with. You should now have an update available which will apply the patch. Please update your system and let me know if any issues continue.
If you have a patch for this problem, why don't you release it in a firmware update? Not a single one of these solutions seems to work, and I'm starting to think that this expensive toy is just a shower of S%$@ at this point.

So like all the others, ref 7244202 if there is any help to be had...
Userlevel 7
Badge +20
Hi benger5 and rickyhall11,

I've added patches to your system accounts. Please check for updates on your Sonos app. Once updated, test out Spotify again and let me know how it goes.
Badge
Same issue here for a few weeks now. Plays for a bit and then the dreaded connection to Spotify was lost. Reset router, power cycled speakers, changed WiFi channel, added bridge back to system to rule out my WiFi and out of ideas now!

Diagnostics submitted under ref 7226615
7225945
Jeff S, Managed to play full queue through with no issues. Very nice to have my music back.
Userlevel 2
Badge +1
Hi Amadeus1756,

Your Sonos units are still connected but they have lost their network addresses. Most of the time rebooting your router and this wireless speakers will fix this. If not, please try the other steps in this guide to get your speakers back.


Thanks for the very quick reply Jeff.
I discovered it was a problem with IPTV - I discovered some time ago that Sonos doesn't seem to deal well with that. I've tried 3 routers and the same problem - as soon as ipTV starts recording, sonos devices disappear from the network. Never worked out why - think it's an STP thing but that's not my area of expertise.
Many thanks for the guidance Jeff.
Userlevel 7
Badge +20
I'm having the same issues. None of my services will play. Not the radio, pandora or Spotify or even music off of my phone. Plays 10 seconds of the song and then cuts out and says "lost connection to Spotify unable to play track"

Hi benger5,

Please reproduce the issue then send in a diagnostic report and reply with the confirmation number.
I'm having the same issues. None of my services will play. Not the radio, pandora or Spotify or even music off of my phone. Plays 10 seconds of the song and then cuts out and says "lost connection to Spotify unable to play track"
Userlevel 7
Badge +20
I upgraded to 7.2 yesterday and now I keep losing all my (5) zones.
I have reset my router, wireless access points, and my Sonos controller. It sometimes comes back for a few mins but then everything disappears again. The only change I'm aware of is the Sonos controller update (i.e. no firmware updates on my router or wireless access points).
I've submitted diagnostics - 7220789

Many thanks


Hi Amadeus1756,

Your Sonos units are still connected but they have lost their network addresses. Most of the time rebooting your router and this wireless speakers will fix this. If not, please try the other steps in this guide to get your speakers back.
Userlevel 2
Badge +1
I upgraded to 7.2 yesterday and now I keep losing all my (5) zones.
I have reset my router, wireless access points, and my Sonos controller. It sometimes comes back for a few mins but then everything disappears again. The only change I'm aware of is the Sonos controller update (i.e. no firmware updates on my router or wireless access points).
I've submitted diagnostics - 7220789

Many thanks
Userlevel 7
Badge +20
I've re-installed Spotify again. Still the same problem. The diagnostic information has been sent. Your confirmation number is: 7219135.

I've added a patch to your system, please run updates again and test out Spotify once updated.
I've re-installed Spotify again. Still the same problem. The diagnostic information has been sent. Your confirmation number is: 7219135.