Unable to play xxxxxxx. Lost connection to spotify - over and over and over again...



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

158 replies

Badge
That's kind of unhelpful as i do work and am guessing i will need to be by the speakers?
This doesn't address the ongoing issue with tunein dying on me like its buffering and then giving up either. Surely you guys know you have a problem as a quick browse of the forums shows people having the same issues with tunein, Spotify and Apple music - it's not isolated so clearly is a problem since your last update. Wouldn't be so bad if you guys could just put your hands up and say you know and are working on a fix!
Userlevel 7
Badge +26
Hey Ricky, we're always looking to find any issues that might exist in the Sonos software, so when it comes to connecting dots to find related cases we're always keeping an eye open. Audio cutting out in some way, especially across multiple services can be caused by a number of different things. Immediately following an update, the most common issues are wireless interference (often because of a router in the area on automatic channel scanning mode) or IP address allocation issues on the network.

We want to help, and always happy to look into any potential trouble. That's why we'd love to get you working with a technician live, as Jeff set up above. It's always best to have us work with you one on one so that we can get a really good look at the network, environment, and anything else that might be playing up. Once all variables have been isolated, we can really start to get good data on if anything else is going on.

I understand it's frustrating when things aren't working, but we're here to help get you up and running.
Badge
So as i said i work and your support is only 9-5 Monday to Friday..Not helpful . So do you suggest I take time off work to spend on the phone to a tech to fix what's clearly an issue at your end..(please just look at the forums , the evidence that it's your problem is there!)
You reference tired old help desk resolutions (it's the router change the channel, it just needs a reboot etc). Done all this, have rebooted, there's no IP a conflicts or devices with the same IP, the router is on a fixed channel (as it as pre update), i have tried different channels across the spectrum, disabled firewall temporarily , added the Sonos bridge, and factory reset the speakers so it's basically a new system now and nothing else on the network has issues therefore i have done your fault finding for you.
Please please look at the forums, look at the people that are reportiny Spotify cut outs, Apple music cut outs and tunein radio cutting and skipping and then with only the smallest amount of intuition you may see the problem is with yourselvea and funnily enough its since the last update.
Come on guys and get you act together - love the Sonos kit but this is really poor service.
Jeff - thanks for the patch and the quick reply. Will report on progress with this, but the immediate issue is that playing to the Sonos from the Spotify app seems to be completely broken now....
Jeff/Ryan,

I, too, am having the same issue as described. Sometimes I am unable to make six songs in a row play, while other times the app skips to the next song on the playlist in the middle randomly, providing the same "unable to play... lost connection" error. Other times it works just fine for a few songs. I will also note that this development is fairly recent, and I am 90% sure it did not occur before I updated to the most recent version of the Sonos app.

I tried restarting my router, removing Spotify from the Sonos app, then reconnecting them, and it immediately had the same issue. I ran a diagnostic at that point: 7254070.

Thanks for your help.
Hi smahoney, thanks for submitting the diagnostic. The report is showing communication issues between your PLAYBAR and the router, to the point where the PLAYBAR gets temporarily disconnected from the network. This is likely caused by some sort of wireless interference and will definitely affect the playback. This link will outline common sources of interference. Please review the link and check to see if you have anything in your house that could be interfering with the router's communication to Sonos.
Same issue. Sonos is the absolute worst piece of technology I think I've ever purchased. No product in history has caused so much frustration. Constant disconnects, every other day, on a perfect business fiber connection.
Jasonbarone,

Often the issue isn't with the speed of the fiber coming in, it's the local network issues that cause disconnects. Most frequently, it's an IP conflict on your router, although it could also be simple wifi interference. Due to the constant nature of music, the Sonos environment needs a robust and solid wifi connection, and is significantly less tolerant to issues than many other wifi devices are.

If it's the wifi interference, I'd recommend either making sure that the speakers aren't near any other wifi device (webcams, wireless printers for example), and that if you have a bridge/boost device, it's at least 2 to 3 feet away from your wifi router. Also, try changing the channel your Sonos devices are using, either by changing the wifi router's channel, or if you're in boost mode (one speaker is connected to the router with ethernet cable) using the app.

It's a little more work if you have IP conflicts in your local wifi system. Most of us recommend turning off all devices that connect to your wifi, as well as the router itself, and then bring them back up, one at a time, starting with the router, and allowing each device enough time to receive a new IP address. This could be mitigated in the future by assigning reserved IP addresses to your devices, since every time Sonos does a new software release, it causes all of the speakers to reboot. Check the router's manual on how to set up reserved IP addresses, you can find the MAC addresses for your speakers in the "About my Sonos System" in the app.

Finally, if you want "better" help, it would be wise to submit a system diagnostic and post the number in the thread. If done within 10 minutes or so of the issue, it would likely be able to capture the problem in the log files that are submitted, and posting the number in the boards would help the Sonos folks to know what they're looking for.