Unable to play xxxxxxx. Lost connection to spotify - over and over and over again...



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

158 replies

Userlevel 7
Badge +20
I have precisely the same issue. Tried updating to the beta version but that didn't help at all.

Hi DaveyS,

Please send in a diagnostic report from your Sonos app then reply here with the confirmation number.
The connection to Spotify is lost over and over again when I try to play songs on my Sonos system. It happens again and again. Sometimes it manages to play half a song, but then stops. It goes on like this for days. Some days it works. Some not.

Diagnostics no: 3735414

I have a Netgear CG3700 modem connected to an Airport Extreme 802.11n 5th generation and extended wireless network with an Airport Express 802.11n 5th generation. Bandwith is 100mps.

Please help, I have had this problem for a long time now.

Best regards, Per
Hi I am having the same issues.

Only Spotify is having this issue. TuneIn radio is working as normal.

I have tried changing the wireless channel. I have tried spacing out the units. I have tried removing potential interference.

I have tried deleting and reinstalling Spotify using a device password and log in (rather than facebook)..

It has been an ongoing issue for a year or two and getting progressively worse to the point now that I can play one song every time but it won't move onto a second song, ever.

Attached is a diagnostic report. Hopefully you can help. I'm about to ditch the speakers and never use Sonos again, which is a shame because when they worked, I loved them.

Hi, Currently experiencing the same issue going on third week now. Submitted my diagnostics today, confirmation number: 7207330.

Please advise. Thank you.
Userlevel 7
Badge +20
Hi I am having the same issues.

Only Spotify is having this issue. TuneIn radio is working as normal.

I have tried changing the wireless channel. I have tried spacing out the units. I have tried removing potential interference.

I have tried deleting and reinstalling Spotify using a device password and log in (rather than facebook)..

It has been an ongoing issue for a year or two and getting progressively worse to the point now that I can play one song every time but it won't move onto a second song, ever.

Attached is a diagnostic report. Hopefully you can help. I'm about to ditch the speakers and never use Sonos again, which is a shame because when they worked, I loved them.



Hi toneharper,

I've added a patch to your system which will install if you run updates on your Sonos app. Test out Spotify after the update and let me know how it goes.
Jeff S - I've submitted the diagnostic with number 7207449
Userlevel 7
Badge +20
Jeff S - I've submitted the diagnostic with number 7207449

Hi DaveyS,

Please try updating your Sonos system then remove Spotify from it and add the service back. If you're still unable to play Spotify, please send in a new diagnostic report and reply with the confirmation number.
Thanks Jeff S... just played a whole album without freezing. So excited...cheers
I've re-installed Spotify again. Still the same problem. The diagnostic information has been sent. Your confirmation number is: 7219135.
Userlevel 7
Badge +20
I've re-installed Spotify again. Still the same problem. The diagnostic information has been sent. Your confirmation number is: 7219135.

I've added a patch to your system, please run updates again and test out Spotify once updated.
Userlevel 2
Badge +1
I upgraded to 7.2 yesterday and now I keep losing all my (5) zones.
I have reset my router, wireless access points, and my Sonos controller. It sometimes comes back for a few mins but then everything disappears again. The only change I'm aware of is the Sonos controller update (i.e. no firmware updates on my router or wireless access points).
I've submitted diagnostics - 7220789

Many thanks
Userlevel 7
Badge +20
I upgraded to 7.2 yesterday and now I keep losing all my (5) zones.
I have reset my router, wireless access points, and my Sonos controller. It sometimes comes back for a few mins but then everything disappears again. The only change I'm aware of is the Sonos controller update (i.e. no firmware updates on my router or wireless access points).
I've submitted diagnostics - 7220789

Many thanks


Hi Amadeus1756,

Your Sonos units are still connected but they have lost their network addresses. Most of the time rebooting your router and this wireless speakers will fix this. If not, please try the other steps in this guide to get your speakers back.
I'm having the same issues. None of my services will play. Not the radio, pandora or Spotify or even music off of my phone. Plays 10 seconds of the song and then cuts out and says "lost connection to Spotify unable to play track"
Userlevel 7
Badge +20
I'm having the same issues. None of my services will play. Not the radio, pandora or Spotify or even music off of my phone. Plays 10 seconds of the song and then cuts out and says "lost connection to Spotify unable to play track"

Hi benger5,

Please reproduce the issue then send in a diagnostic report and reply with the confirmation number.
Userlevel 2
Badge +1
Hi Amadeus1756,

Your Sonos units are still connected but they have lost their network addresses. Most of the time rebooting your router and this wireless speakers will fix this. If not, please try the other steps in this guide to get your speakers back.


Thanks for the very quick reply Jeff.
I discovered it was a problem with IPTV - I discovered some time ago that Sonos doesn't seem to deal well with that. I've tried 3 routers and the same problem - as soon as ipTV starts recording, sonos devices disappear from the network. Never worked out why - think it's an STP thing but that's not my area of expertise.
Many thanks for the guidance Jeff.
Jeff S, Managed to play full queue through with no issues. Very nice to have my music back.
7225945
Badge
Same issue here for a few weeks now. Plays for a bit and then the dreaded connection to Spotify was lost. Reset router, power cycled speakers, changed WiFi channel, added bridge back to system to rule out my WiFi and out of ideas now!

Diagnostics submitted under ref 7226615
Userlevel 7
Badge +20
Hi benger5 and rickyhall11,

I've added patches to your system accounts. Please check for updates on your Sonos app. Once updated, test out Spotify again and let me know how it goes.
If you have a patch for this problem, why don't you release it in a firmware update? Not a single one of these solutions seems to work, and I'm starting to think that this expensive toy is just a shower of S%$@ at this point.

So like all the others, ref 7244202 if there is any help to be had...
Userlevel 7
Badge +20
If you have a patch for this problem, why don't you release it in a firmware update? Not a single one of these solutions seems to work, and I'm starting to think that this expensive toy is just a shower of S%$@ at this point.

So like all the others, ref 7244202 if there is any help to be had...


Hi jel8282,

We have a patch available but it addresses a specific issue with some network hardware. It isn't catch-all solution. In the 7.2 release we added a fix for a different issue which can cause the same error. In your system's case, there's an error which the patch should help with. You should now have an update available which will apply the patch. Please update your system and let me know if any issues continue.
Badge
So been trying to play a single from Spotify but it just won't have it. Have even tried using Spotify app and connect to speaker but it won't have it. But, adding the track to a play list and then playing it that way works.... Surely identifies a problem with Sonos' connection with Spotify??? This really needs fixing for all of us asap!!
Userlevel 7
Badge +20
So been trying to play a single from Spotify but it just won't have it. Have even tried using Spotify app and connect to speaker but it won't have it. But, adding the track to a play list and then playing it that way works.... Surely identifies a problem with Sonos' connection with Spotify??? This really needs fixing for all of us asap!!

Hi rickyhall11,

Please submit a diagnostic report from your system then reply with the confirmation number.
Badge
Here you go 7244707
Userlevel 7
Badge +20
Here you go 7244707

In your diagnostic report I see that your system is timing out when trying to connect to Spotify. It would be best to work with our phone team on a resolution to this issue. Please give us a call. I've added your information to your support ticket: 170327-001383. You can find our phone number and hours here.