Question

Unable to play the same source on Connect and Play:5 at the same time


Hi Guys.
I have been having this problem with my setup for quite some time now, and i hope to get some advice to get it solved.
I have a Connect, a play:5 and a Play:1. And when I want to play the same source on all at the same time, the Connect stops playing. There is no problem playing the same source on the two Play units, and it also ok to play radio on the Play units while playing an album from Tidal/Spotify on the Connect. But as soon as I try to play the same music on the Connect and any of the Play units, the Connect goes silent.
They are all hooked up to the same wireless network, from an Apple AirPort Extreme, with a 60Mbit internet connection.

Any advices?

13 replies

Hello Nightowl. Do you get any error messages when the music stops? We'd like to take a look at a diagnostic from your system to see what may be happening. Would you mind recreating the issue, then submitting a diagnostic following these instructions? Please post the confirmation code here.
There are no error codes. The Connect just goes silent.7365153 is the diagnostics number submitted. Thanks for looking into it!
Userlevel 4
Badge +3
Nightowl wrote:

There are no error codes. The Connect just goes silent.7365153 is the diagnostics number submitted. Thanks for looking into it!


I've reviewed your diagnostic and found peaks of WiFi interference that may lead to communication errors. Due to the issue, the system can experience audio drops.

Would it be possible to wire the CONNECT with an Ethernet cable (to the router) and try again?
I would have to get a 12m long first, and even if it would solve my problem, it wouldn't be a solution I could live with. Is there any alternative, change settings or something, that I could try instead? Or turning off my 5G wifi network? For me, the tethered solutions is fundamentally against the concept of Sonos, and I will consider an entirely different entertainment solution, if that is the only way to make it work as intended.
Finally I got my Connect tethered with a 15m long cable, but unfortunately the outcome is the same. As soon as a gruop with my Play:5 or Play:1, the Connect goes silent. I have send a diagnostic, numbered 7689479, if someone can please see if there is any difference when the Connect i cabled...
Badge +1
Thanks for the update. After checking the new diagnostic it looks like Sonos may be connecting to the network via multiple wireless access points. To confirm we'll need to know if your network as any wireless extenders or wireless access points other than your primary router?
Yes, it is connected via my AirPort Extreme routers wifi, which is tethered to my fiber-modem which also has its own wifi. Should I try and connect it directly to the modems wifi instead?
Do both of your routers have DHCP enabled? If so you have probably split your network. One router must be configured in 'bridge' or 'access point' mode.
Hi john, I've now disconnected the airport router, and connected the Sonos system directly to the fiber modems wifi. Unfortunately the result is exactly the same as before. I've sent a diagnostics report, number 7834458, via the controller. Please review and advise
John B isn't a Sonos employee, and doesn't have access to the diagnostic. Sonos employees are marked as Sonos Staff, much like Tyler M above.
Hopefully a Sonos employee will pick up the diagnostic even so. But when you say you have disconnected the Airport router do you mean you have removed it completely from your network, i.e. powered it off, or something else? All this info will be useful to Sonos.
And whatever change you made you would need to reboot everything on your network afterwards.
Userlevel 6
Badge +3
John B wrote:

Do both of your routers have DHCP enabled? If so you have probably split your network. One router must be configured in 'bridge' or 'access point' mode.



This looks to be the case. The first diagnostic showed players with a 10.0.x.x range, which is from the Apple router (that's their default range). The second diagnostic is showing your 192.168.x.x range, from the main (first) router. If possible, we'd suggest setting your Apple router into a Bridge mode so that you only have one DHCP pool there.

Reply

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)