Answered

Unable to play.... the connection to Spotify was lost

  • 24 February 2017
  • 62 replies
  • 27382 views

This has been happening regularly over the past month. I can play music stored on my iPad, can access Radio by Tunein but cannot get access to Spotify....very frustrating. can you help. I have tried everything I can on this side, powered off the various units, but to no avail. I have submitted a diagnostics ( even though it says don't unless you are instructed to by a sonos support team member) number is 7135487. I also note there is no phone support over the weekend ?? why ? this is when most people have time to correct these items, but sales is available ?? Appreciate your help ASAP
icon

Best answer by Jeff S 1 March 2017, 23:50

Hope this helpful, but I am also getting intermittent error coded 1002 when trying to play music that is found but upon clicking to play receive the 1002 code, thanks



Hi GerryOS,



There are some network communication errors showing up. How are your Sonos units connected to your network? Are they wired into a switch or directly into your router?



It may help to reboot your router, Sonos units and any other network hardware you have connected. This may clear up the network errors and help with Spotify playback and the 1002 timeout errors.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

62 replies

Hope this helpful, but I am also getting intermittent error coded 1002 when trying to play music that is found but upon clicking to play receive the 1002 code, thanks
I'm also having the same issue !
Userlevel 7
Badge +20
Hope this helpful, but I am also getting intermittent error coded 1002 when trying to play music that is found but upon clicking to play receive the 1002 code, thanks

Hi GerryOS,

There are some network communication errors showing up. How are your Sonos units connected to your network? Are they wired into a switch or directly into your router?

It may help to reboot your router, Sonos units and any other network hardware you have connected. This may clear up the network errors and help with Spotify playback and the 1002 timeout errors.
Badge
Hello I am having the same issue for the past few months. Pandora Apple and music from my phone works fine and I can choose occasional song on Spotify but invariably after a couple of songs even mid playlist it keeps saying that connection lost. It's so annoying as wifi is working perfectly. Definitely a problem with Sonos and Spotify. Please can you tell me how to fix it. Thanks.
Badge
My diagnostic number is 7161151
Please reply. Thanks
Userlevel 5
Badge +10
Hey Deb,

You can likely speed up the process by submitting a diagnostic using the controller app, recording the number, and posting it back here so Sonos staff like Jeff can look at it and reply to you as to what, if anything, they can see in the diagnostic that may be generating the issues you are having. Then they can provide potential solutions. You should submit the diagnostic within a few minutes of having the system actually having the issue.
Badge
Thansk sharkb8t :)I have forwarded a diagnostic number. THANKs 🙂
Userlevel 5
Badge +10
... forwarded a diagnostic number. ...

Forwarded?

Just checking for clarity: Do you mean you Submitted the diagnostic?

...or That you have posted the number in a private message to someone at Sonos?

I don't believe the Sonos staff are able to connect the diagnostic submission to you unless you provide them the number. Most of the time people simply post the number the system gives them in this forum so the Sonos staff can reply to them and connect.... There are a few specific detail they may need (Like make and model of router, etc...) but they will ask you that... or may ask you to contact their call centre if they need to connect live.

Hope you get it sorted soon!
Badge
my diagnostic number is 7161163
is that enough info ? thank you very much!
deb
Userlevel 7
Badge +20
my diagnostic number is 7161163
is that enough info ? thank you very much!
deb


Hi Deb,

I've applied a patch to your account. Please run updates on your Sonos system then test out Spotify again.
Badge
Hi Jeff. This issue has been ongoing since last year. I have updated the system many times. Installed and uninstalled Spotify etc. pandora plays no problem at all. My problem is the same a solution everyone's. I may getbto play one song. PR maybe 2 but then it says connection is lost and I get about 20 messages saying that sonos is unable to play x song in queue because connection to Spotify is lost. So frustrating. This was the only reason I got sonos. Now every opportunity I have to enjoy music with friends has become a stressful situation as we can't choose any songs we like. 6 months later feeling super disillusioned with sonos. So many people have had the issue. You must know the solution or at least could tell Ian it's a known problem and that ur working on it. Thank you 🙂
Userlevel 5
Badge +10
Debb... I think you may have misunderstood what Jeff is saying.

Based on the details seen in your diagnostic, Sonos has provided you, specifically, a customized modification of the software that the Sonos Players run. If you run updates on your system now, you will get an update that I will not get. (I might, perhaps, get the same code base in the next public release of code). This update is only available to you now, since they have made it available to you based on the details in your diagnostic and presumably Jeff perceives that this "patch" will help you with your current situation.

You should now update your system ("Sonos"... "Check for updates"... or whatever the specifics are based on the OS your controller is on... and you should find an update for you.) and see if it indeed solves your current problem. If the problem does re-occur, submit a diagnostic and come back and post that diagnostic number so Sonos can look deeper to see why their identified solution for you hasn't worked. 🙂

Hope this helps,
Hi everyone, this is also happening to me. Intermittent connection with Spotify and the error: Cannot play xxxx the connection to Spotify was lost. I've just submitted diagnostics straight after the error occurred. Diagnostics confirmation number is: 7534453. Please help!!
Userlevel 7
Badge +20
Hi, Lads47. In your case, logging into your router and changing the channel should suffice. Having done so, please reboot your Sonos speaker.
I'm having the same issue with sonos losing connectivity with spotify sporadically. submitted diagnostics #7631740
Userlevel 4
Badge +3
I'm having the same issue with sonos losing connectivity with spotify sporadically. submitted diagnostics #7631740

Please submit another diagnostic within 10 minutes of a drop out and reply with the confirmation number.
Same issue here. Unable to play... connection to spotify was lost. This has only been happening for the last couple weeks, but it is a persistent problem, not intermittent. I sent diagnostics info, number is 7700030
Userlevel 1
Badge +1
Same issue here. Unable to play... connection to spotify was lost. This has only been happening for the last couple weeks, but it is a persistent problem, not intermittent. I sent diagnostics info, number is 7700030

Hello, thanks for reaching out. It appears the diagnostic is showing your Sonos system on version 7.3. We've released version 7.4 not too long ago and were curious if this issue has persisted since updating your Sonos system? Does it occur with other music services or the Music Library?

If you've performed the update and are still having issues please send another diagnostic shortly after the problem occurs and we'll take a closer look.
Hi
Same issue here and never had a problem before......worked no problem yesterday but wont play anything from Spotify today.
Can you help please?
Diagnostics info number is 7865774
Hello. Having the same issue here on new Sonos account. Diagnostic 7902243
Hello, same issue "unable to play xxxxx the connection was lost. I tried changing the channel on the router already without success. This is an intermittent problem but no matter what I have tried it keeps happening again, please assist.
Your confirmation number is: 7931079.
Userlevel 7
Badge +19
Hello matthewslaterinc & pbrshp: Just reaching out to see if you are still having these problems with Spotify. since your post, we have released a few updates regarding Spotify. Should you still be experiencing these issues, please submit another diagnostic report after reproducing the problem.

Thanks in advance.
Thanks, resolved after spending another $100 to buy a Boost.
P.s. would love a store credit of some portion of that to buy our next speakers.
Hi I've been having this problem since the latest firmware update. My system is almost unusable at this stage. I have 3 play 5s 4 play 1s 2 play 3s a sub and a boost so a lot of expensive kit dpimg nothing. Tonighti derefistered spotify rebooted all speakers and wireless router akd it lasted about 30 minutes. Ive previously tried all worrless channels. Can you please help. Diagnostic number is 8055879
Userlevel 7
Badge +19
Chrismcc409: Thanks for the diagnostic report. I noticed that you have quite a few zones. Are you experiencing this in a specific room or does this happen in all zones? Additionally, could you tell us a little more about your local network? I see your BOOST is plugged into the network. What is the make and model of the device the BOOST is plugged into? Is this your main routing unit? If not, what is the make and model of your routing?