Answered

Unable to play.... the connection to Spotify was lost

  • 24 February 2017
  • 62 replies
  • 27394 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

62 replies

Badge
Same problem. Songs don't start or stop playing after a while. I had several contacts with Sonos helpdesk, but the problem was not solved. I have 2 Sonos Connect devices. What did I do?

- changed modem and bought Netgear Orbi router. I have over 200Mbps now over wifi (wired 300Mbps)
- changed to Google Public DNS
- adding sonos bridge
- removing it again
- wired one of the devices and wired both (and changing that again)
- disconnected Spotify from Sonos and reconnected
- put my Sonos back to factory settings and started all over
- remark: when using Spotify directly from the app or desktop, there is no problem
- remark: I don't have any problems connecting to Sonos Radio

Some things helped a bit, mainly shortly after doing it, but then it deteriorated again.

This week I took a Tidal HiFi free trial (lossless, so needs more bandwith). And guess what: no connection problems at all.

So, by deduction and having tried almost anything I can imagine (or that Sonos helpdesk proposed), I come to think there must be a problem in the way Sonos connects to Spotify. I don't want to quit my Spotify subscription, but I guess I'll have to and change to tidal.
Userlevel 7
Badge +19
Hi there, Godfried. Thanks for posting and for all the troubleshooting effort. I was able to pull up your correspondence with our team and would recommend continuing to work with them. Alternatively, you could also give our support technicians a call to troubleshoot this in real time instead of over email. They can get a closer look at Spotify connectivity through a remote session.
1769557559
I am still getting the same errors. Today I have shut everything down and restarted in turn. I have removed my Spotify account and re-added it. I’ve contacted you to try and solve it but still I am not winning. It is so frustrating. Radio works. Line in works but Spotify and my own music is constant drop outs
Userlevel 7
Badge +19
Hi there, Simon_85. Thanks for posting and sharing your diagnostic report. I was unable to locate a case or support ticket on our end under the email address you have registered on the Community. While I recommend giving our technicians a call when you have the opportunity to do so, we can try a few things here.

Based on the diagnostic report you submitted, it seems that the Bridge is having a hard time with communicating with the rest of Sonos. Out of curiosity, if you were to remove the Bridge from the equation completely and switch it out with the Office Play:5, do the problems continue? This will help us to determine if the problem is the Bridge that feeds the rest of Sonos.

Thanks again!
same issue here, case #299640940 please help!
Same thing is happening to me. 630773114
I am having the same issue - I sent diagnostics - 1745190855 . I would appreciate any help you could give me.
See my other reply!
After a frustrating weekend of this situation, my fix was achieved through going into sonos settings>advanced settings>wireless settings and connecting the sonos one via Ethernet cable to my router.

Closed The sonos app and reopened searching for the network, it prompted for the wireless password, and connected straight away.

I then disconnected the Ethernet cable.

Opened the Spotify app and it prompted as locating the sonos one, pressed play on device and it started playing again straight away.

Hope that helps!
Badge
Same problem with Apple Music and Pandora. The system has been unusable for MONTHS.

... very frustrating. Music cuts in and out. Repeated “can’t communicate with controller” errors. Over 100 hours of troubleshooting invested (invluding a helpful effort by Derek), but still no progress in getting $20,000 of Sonos equipment to begin to function. Marissa now indicates Derek is “out of the office” for the next several weeks.

Working with Derek we completed extensive troubleshooting and re-configuration to no avail, including:

- verified >1GB/sec Internet download and >200 MB/Sec Internet upload speeds;
- verified no network or WiFi system errors on commercial grade network;
- reviewed network settings for possible Sonos compatibility issues;
- verified 300-500MB/sec consistent Internet download throughput and less than 16ms of Internet latency throughout WiFi network;
- set all 2G WiFi radios to channel 11;
- set all Sonos to channel 6;
- purchased, installed, upgraded and connected 3 Sonos Boost units;
- factory reset 20+ Sonos devices;
- verified latest firmware and software on all devices;
- reinstalled each Sonos device.

Disconnections, instability, “can’t connect with controller” errors, continue on both hard-wired MAC controller and iPhone controllers.

Controller resets seem to temporarily fix the problem for up to two or three hours before the system begins to hang and disconnect. ... very frustrating.

Latest Diagnostic # 889689848
We have an Orbi System along with Fiber so bandwidth should not be an issue. Pandora works just fine but Spotify has had issues for weeks.

1736469468