Answered

Unable to play.... the connection to Spotify was lost

  • 24 February 2017
  • 62 replies
  • 27382 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

62 replies

Hi Keith. Thanks for the reply. It is all zones but most frequently the zone called Ryan. The BOOST is plugged into a sky fibre router. Manufacturer is sky and model is ER110. This is indeed my main routing unit. Thanks again.
Hi. I’m having the same or similar problem. Sonos plays a track for 20 or 30 seconds and then says unable to play xxxx the connection to Spotify was lost. Then it plays the next track for 20 or 30secs. Diagnostic run. Number 8095299. Thanks in advance. I have Optus broadband.
Userlevel 7
Badge +19
Chrismcc409:Understood. If you haven't already, I would recommend giving our technicians a call on the phone. This way we can troubleshoot in real time and get you back up and running reliably. Our contact information can be found here.

Hey there, tomshaw247. Have you already tried removing Spotify and re-adding Spotify on Sonos? The diagnostic report you submitted is showing lost connection errors but I can only see about 10% of data is being dropped from the Router to the Family Room. If you plug the player into the router via Ethernet cable do the issues persist? Thanks!
I've never really had an issue with my system but the last couple of weeks I'm running into the same issue. It will play a few seconds of the song (10-20 seconds) through Spotify and then shuts off with an error message "Unable to play xxx. Connection to Spotify was lost". I've tried turning the system on & off, restarting the router and still nothing. Super frustrating. The diagnostic confirmation number is 8125827.
Userlevel 7
Badge +19
Hi there, ChristyL. Thanks for the diagnostic report. I am seeing a bit of interference between your BRIDGE and the Living Room player. More specifically having to do with what is physically around the BRIDGE unit. Can you describe the immediate area around the BRIDGE?

I can see the Spotify errors but before we address them, we will need to make sure we have a solid network connection to have the service work on. We can achieve this quickly by, plugging the PLAY:3 into the BRIDGE using an Ethernet cable. If the playback works without issue, then we know the problem is how the player is getting the signal wirelessly. If the issues persist, we will likely need a closer, more real-time look at the network.
Same issue. 8200223
Same issue: 8201388
I am having the same issue - 8207238.
I am having the same issue with Spotify dropping out and message "lost connection to Spotify". My diagnostic number is 8269449.
Thanks.
I don't know if this helps clue into a solution, but I've been having the same problem for a quite a while and have tried the suggested solutions to no avail.
Interestingly it seems to only happen when using our phones (both iOS and Android). When we use the controller on our computers to play Spotify, things work well. Go figure.
Is anyone home?
Having the same issue - diagnostics confirmation number is 8389960.
Badge
I've got this problem with my Sonos One, it'll play Amazon Music just fine.
Inhave the same issue: 8507606
Same issue: 970428905
Same issue- nothing has changed in my house/setup. 306888783 is my diagnostic confirmation. I was literally going to order the sonos 1 bundle in two days but will hold off until this is resolved. Very frustrating. Pandora and other services still work fine, not sure why Spotify has an issue.
Userlevel 7
Badge +20
Hi sharkyjoe and Myrinx,

There are authentication errors showing up in your reports. Please try removing Spotify from your Sonos systems, then add it back. This should get the authentication working properly. If that doesn't help, please double check your subscription levels and make sure they are still set to Spotify Premium.
I solved the issue by logging on to Spotify.com and doing "logout on all my devices".
Every time I play Sonos it's stopping and starting Connection to Spotify issue
Diagnostic number 2104739364
HELP....
Same issue. Trying to play from the Spotify app on Mac or on iOS and selecting my Sonos PLAY:5 Gen2 speaker just glitches the app and will sometime pause the music, or play for a couple seconds on the speaker before disconnecting. When it does manage to connect for a few minutes, moving the volume slider or seek slider causes it to disconnect. Code 839830914
same problem here. Code 566373248
Is this the best way to resolve this issue?
I lied in my earlier message. "Connection to Spotify lost" has been occurring across all of our devices. Even using the Controller app and playing on a Sonos box that is connected directly to the internet via an ethernet connection. I still lose Spotify.

I've done everything, from disconnecting the Spotify account to resetting up my Sonos network from scratch. Nothing works. Very frustrating.

When I search this problem it appears to have been going on for many years. There are complaints from 2012!

------
"I don't know if this helps clue into a solution, but I've been having the same problem for a quite a while and have tried the suggested solutions to no avail.
Interestingly it seems to only happen when using our phones (both iOS and Android). When we use the controller on our computers to play Spotify, things work well. Go figure."
And why does this thread say "answered" at top? This problem hasn't been sufficiently answered for anyone as far as I can tell. There is no thread that gives a true solution.

It has to be a Sonos software problem if so many users are having trouble.
Userlevel 7
Badge +19
reachdavenow: The thread is labeled answered because the original post was answered. The "Answered" tag refers to the original post, not to other users adding to an already existing/answered topic. This specific topic started from a known issue with Spotify over a year ago, that has since been resolved in subsequent updates. In most cases where the connection to Spotify is lost, it can be attributed to the connectivity between Sonos and the outside internet. Sometimes this can be interference from wireless broadcasting or from larger electronic devices (such as amplifiers). I've even seen problems with this where users have had each player wired to their network. In those cases, the problem came from the configuration of the network itself.

That being said, how about we start by replicating the problem, submitting a diagnostic report and replying here with the confirmation number it gives at the end? This will give me a closer look at the error logs and advise on next steps. Additionally, any insight into how your local network is set up including the make and model of the router would be most helpful.

Alternatively, if you'd like to troubleshoot in real time, feel free to give our support technicians a call. They are able to set up a remote session and get a closer look at how data is being routed along the network.

Thanks!