Question

Unable to play ... - the connection to Saavn was lost

  • 22 April 2020
  • 60 replies
  • 1370 views

Badge

I have been using Saavn service since a couple of years. Since about mid Apr 2020, Sonos can no longer play music using the Saavn (now called JioSaavn) service and throws and error like, “Unable to play <’song name’>... - the connection to Saavn was lost”.

  1. I have a pro jiosaavn subscription.
  2. Jiosaavn app works fine on the phone
  3. I have reinstalled jiosaavn app after clearing cache/storage
  4. I have removed and reauthorised the jiosaavn app several times on Sonos app. It  gets reauthorised with ‘success’ message.
  5. Other online services are playing fine on Sonos speakers through the app. There are no router/ wifi issues.

60 replies

After rebooting the router to pick up any DNS changes from upstream, and the Sonos devices after the router to do the same, I would recommend that you submit a system diagnostic within 10 minutes of experiencing this issue, and contact Sonos Support to discuss it.

I usually suggest the phone folks, they have more tools available, but are available Monday through Friday during business hours. Twitter support folks are available 24/7.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution. 

Badge

Hi all other music services are working fine so it does not seem to be a router or DNS issue.

Thanks

Sorry, the internet doesn’t work that way. DNS issues can, and often affect a single address between you and where you’re attempting to reach. I would still encourage you to take all of the steps I recommended. 

Badge

I appreciate your response.

I rebooted my router and then Sonos system after that. I again tried to play some music using the service but got the same error.

I will submit the fresh diagnostic #1789160978 to Sonos.

Incidentally, the standalone Saavn app works fine plus live saavn search results are showing up in the saavn service within the Sonos app. It is only when I attempt to play I get the error,  “Unable to play <’song name’>... - the connection to Saavn was lost”.   

Good information to provide to Sonos, for sure. I don’t know whether Saavn uses a different server for a Sonos vs their own apps, but many services do, which could be why one is working and the other isn’t. Additionally, it’s two different devices, and paths, the Saavn player on your device vs the computer on the speaker reaching out for the stream. So if something is blocking the speaker’s ability to reach the Saavn endpoint, it may not be blocking the device you’re running the Saavn app itself on. 

I’ll look forward to a forum moderator to have the time to look at your diagnostic and provide more data. If you happen to choose to contact Sonos Support directly to discuss it, I’d appreciate it if you would come back here and inform us, so we can all learn. 

Badge

I have emailed to Sonos support yesterday and await their response.

Until then, I wonder that if there was a DNS issue causing the error, then wouldn't the app not show updated music playlists etc? All the content within the service is getting successfully retrieved and being displayed along with images which may indicate that the DNS is working fine. The lag in the retrieval of images suggests that the images are not cached.

Badge

I have the exact same problem for the last two days. This means that it is not a local issue. Either Sonos or jiosaavn has to resolve this.

Facing the exact same problem with JioSaavn. 

I'm having the exact same issue with JioSaavn. It was working fine a few days ago. Now whenever I try to play something through Jiosaavn I get an error,  “Unable to play <’song name’>... - the connection to Saavn was lost”. No such issue with soundcloud, Amazon prime music, spotify etc.

Seems to be a general bug with everyone. Hoping there's a solution soon.

Userlevel 7
Badge +21

So how many of the posters in this thread have contacted Saavn for support? It is their problem to fix.

Badge

So how many of the posters in this thread have contacted Saavn for support? It is their problem to fix.

I have. No response from them yet.

Hello All ,

 

I am also facing the same issue.  DidSonos have any update on this issue.

I just saw a similar post but with different service ( Spotify ) . Looks like Sonos team have to look in to this ASAP. Thank you .

Badge

No reponse from Sonos yet.

Since this issue is being faced by numerous Saavn (aka JioSaavn) users or who knowns maybe ALL the users, and that the issue has been earlier experienced by other services users as well, it is almost certain that the issue is at Sonos end.

Even if the issue if due to JioSaavn, Sonos should at least diagnose the issue.

Thanks
Sumeet

 

Badge

I contacted all my friends who have Sonos and use Saavn. They all have this issue. It does seem like all Saavn users are affected.

I have the same issue. Saavn doesnt work but all the other apps work fine. 

Same issue, started facing this issue after I upgraded the Sonos app to 11.1

Badge

I suggest to all to also raise a ticket on Sonos customer support apart from this forum. That might draw their attention to this issue.

Badge

I am also facing the same issue with Saavn. I also use Amazon music that works fine.

I have been using Saavn service since a couple of years. Since about mid Apr 2020, Sonos can no longer play music using the Saavn (now called JioSaavn) service and throws and error like, “Unable to play <’song name’>... - the connection to Saavn was lost”.

  1. I have a pro jiosaavn subscription.
  2. Jiosaavn app works fine on the phone
  3. I have reinstalled jiosaavn app after clearing cache/storage
  4. I have removed and reauthorised the jiosaavn app several times on Sonos app. It  gets reauthorised with ‘success’ message.
  5. Other online services are playing fine on Sonos speakers through the app. There are no router/ wifi issues.

I have been facing the exact problem for almost 2 weeks now , tried everything sonos customer support told me to do nothing seems to work.

Sonos development team should look into this as the issue started after the uprgrade of Sonos App to 11.1.

Userlevel 7
Badge +21

What do Saavn have to say about it? Its their service that is failing. Can someone post a link to the issue on their support forum?

My father in Goa India is facing the exact same issue, also for the past few days. It is persistent and not intermittent. We too tried all the techniques outlined, including hard-wiring the Sonos speaker to the router - nothing works. Interestingly my Sonos in Bellevue WA works fine with the same Saavn service. All the others that have posted here - which region are you located in?

I too facing the same issue.. Did sent diagnostic report to them. They are failing to update....

Badge

My father in Goa India is facing the exact same issue, also for the past few days. It is persistent and not intermittent. We too tried all the techniques outlined, including hard-wiring the Sonos speaker to the router - nothing works. Interestingly my Sonos in Bellevue WA works fine with the same Saavn service. All the others that have posted here - which region are you located in?

 

I have tried from Gurgaon and Calcutta. Not working in either place.

Reply