Answered

Unable to play "Song Title" - the connection to Spotify was lost


Userlevel 1

I emailed Sonos with details of an error at the weekend - got a message promising a reply within 24 hours but have heard nothing - so though I would try here.

In the past few week Spotify (Premium Family members) has become completely redundant on our Sonos system.  None of us are able to play any Spotify tracks on Sonos - either from the Spotify app or from the Sonos Controller app.

We have been through all of the suggestions (rebooting, removing Sonos, removing Spotify, checking Wi-Fi connection etc) and nothing has fixed it.

We can stream from our Music Library to all devices (so we assume wi-fi is working fine ) and we can stream internet radio stations (so we assume Sonos has internet connection).

I have submitted support diagnostics reference 1445143747.

Any suggestions much appreciated

icon

Best answer by ghostsup 14 June 2020, 10:37

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

57 replies

Badge

Well, Sonos’s new S1 update rolled out and still not fixed.  Looks like this isn’t a big deal for either company. Too bad I can’t simply roll back the software to when it did work.  Look’s like Amazon Music will be my main go to.  Any recommendations for services available in Spotify’s price range with a large librairy available?


I have to agree with you S1 did not change anything for me whatsoever, still get the issues on a regular basis. Funny how I get no issues when airplaying from my mobile to the speakers from Spotify.

Come on SONOS, sort this out please, it’s clearly an issue as several have now reported it!!!

Badge

Add me to the list of frustrated Sonos/Spotify users.   Similar problem (using NetGear WNDR4300 router) “Unable to play "Song Title"… “Connect to Spotify was lost.”   For me, it’s curious that the interruption terminates the current song, then skips over exactly one more song in the play list, and launches the following song on the playlist.   The error messages are varied, but the skipping phenomenon is consistent.  

Thanks to seeing the note from “ghostsup”, I updated my ORBI mesh firmware to 2.5.1.16 and the problem has also gone away. I recently upgraded to Sonos S2 with a Port and the Spotify connect problem became very noticeable before the ORBI firmware upgrade.

Userlevel 1
Badge

Well. I just upgraded my firmware for my ORBI mesh to 2.5.1.16 and the problem “Cannot connect to Spotify connection was lost” has seemed to have disappeared. After a month of not being able to connect to ONLY Spotify it seems to have resolved the problem!

Userlevel 1
Badge

Just cancelled my Spotify Premium until one of the two gets their act together.

“Phone team” link takes you to the same 800 number everybody else gets. I’m about to try the HQ number (Santa Barbara, 805-965-3001) to see if I can get anywhere.

I’ve been having the same Spotify issue since the last update. Hours on the phone with tech support have finally gotten my case “escalated” to an engineer. They blamed my router, they blamed my modem, they blamed my wifi channel...everything they could to distance themselves from culpability. Bare in mind, all my other devices play Spotify fine on the same network and all my other streaming choices work fine on Sonos.

So yes, EVERYBODY should call in and generate a trouble ticket. Hopefully it will force them to act, if nothing else allow us to retrograde their stupid update.


Sounds about like what I expected to get from phone support...which is why I hesitate to even call.  I’m a network engineer by trade so blaming the network gets frustrating lol.  But I’ll call in as well so it’ll help the greater good.

Same, every other service works fine except Spotify.

So is the solution to drop Spotify or drop Sonos?

Getting rid of Sonos is obviously an expensive exercise because we’ve all sunk money into Sonos devices.

Will I upgrade to the new Sonos Arc now with this still unresolved? No way!!

Maybe if I write a sentence about how Spotify doesn’t work on Sonos and that Spotify definitely won’t work on the new Sonos Arc then this page will rank in Google for Sonos Arc and we might get this fixed.

So we should all call in and file separate cases for this issue?  Anything else we should know before calling?  What’s the phone number?

 

thanks!

Userlevel 4
Badge +11

Mind letting me know the brand and model of your modem (ISP) and your Orbi Mesh system (for example, RBk33, RB5K50, etc.) as well if it is a separate device? 

I think if you click on the link in his post, called ‘phone team’, you’ll be taken to where the phone number for your region is listed. 

Thanks...totally missed the link.

This is clearly a Sonos issue, as it began after the latest update. Spotify plays fine on every other device in my home. The Sonos app shows all my Spotify data (playlists, liked songs, followed artists, suggested playlists, new releases, etc…) and will occasionally play a few song before losing the connection, both wired AND wifi I’m now finding.

I’m betting that it’s an issue with the handling of Spotify’s preferred amount of cache or some type of keep-alive interval problem.

We could easily troubleshoot this by being allowed to retrograde to the last rev but no, they claim they “...don’t have the ability to do that.”

Userlevel 4
Badge +11

Greetings,

I am sorry to hear that you are still having issues after attempting to reset the network and Sonos. Does Spotify play outside of Sonos without issues?

 

Please provide the following information to have a better understanding on how your Sonos setup works, there are many reasons that could explain the issue you are experiencing and this will help to pinpoint the cause:

 

1. The make and model of the Router you are using.

 

2. Please list the controllers you have attempted to connect to the Sonos system (iPhone, iPad, Android device, PC or Mac).

3. Do you have any additional networking devices? This could include wireless network extenders, network switches and power line adapters (not other Laptops, Gaming Consoles, NAS drives). If so please provide the make and model numbers (usually found on the device).

 

4. Are you using any VPNs on your mobile controllers or a PiHole?

 

As a test I would ask you to temporarily connect one of your Sonos products into the router (or mesh provided you are using Wi-Fi from the mesh system), and try again.

Userlevel 2
Badge

I have the same exact issue and use an Orbi wifi setup too.  Spotify works without issue independently, but I cannot play Spotify over Sonos.  This happens about 5 times out of 7.  Some days it works ok.  The frequency of the error seems to have dramatically increased since updating to the latest Sonos OS.  Prior to the update, this error would happen maybe 1 out of 50 times.

 

I can confirm that the Orbi settings above have all been checked as well.

Same problem here. Started happening a month or two ago after years of working fine. Also on an Orbi mesh wifi network, but nothing has changed about our setup in a long time. Songs will fail to play 9/10 times, and occasionally work. Works fine when on a wired connection, but that is not an option for the room where we have our Sonos device. We have tried all the normal power off/on of Sonos and router, changing wifi channels, etc. Music from other services will play fine -- it's just Spotify over WiFi that is broken. Super weird and frustrating.

Userlevel 4
Badge +11

Hi folks,

 

This is frustrating and understand that. At this point, I would like to move your cases over to our phone team , we can do more advanced troubleshooting with you in live time at your earliest convenience.  

Badge

I’ve been having the same issue for weeks, since the last Sonos Update probably. Is there anyway I cal install an old Sonos version to check against?

I’ve a Draytek router, 4 x Linksys Velops, 2 x Sonos One, 2 x Sonos Play 5 and when playing from the Sonos App from my PC to my Sonos Play 5 it will play some but before you know it will come up with “Unable to play ‘xxx’ - the connection to Spotify was lost.”. I’ve rebooted router, changed wifi channel, rescanned wifi channels on Velops, everything is on the latest firmwares and its just a real PITA.

Even when you ask Alexa to play lets say Coldplay on the Sonos One she replies with “Playing Coldplay from Spotify” and I now applaude if it actually plays because more often than not it just goes silent! Yet ask Alexa to play Coldplay on Amazon Music and perfect, every time.

Come on Sonos, fix this issue please, I want my Spotify working again!!!

Colin.

Userlevel 2
Badge +2

Similar issue that I’m having is discussed here:  https://en.community.sonos.com/music-services-and-sources-228994/spotify-song-not-encoded-correctly-6841068

Not an Orbi user though.  I’ve got Eero, but using SonosNet.  I’m convinced it’s ongoing issues between Sonos and Spotify and not any issue in my home.  I’m hopeful that Sonos Engineering is focused on launch of S2 app instead of fixing bugs and that this will magically go away in the new app.

Just wanted to add my thanks for this. After weeks of searching through google for a fix (including other threads on this forum!) I finally found this thread, and updating my Orbi router did work! It has been working for a few weeks now.

Today I bought a new Orbi satellite and plugged it in near the Sonos. The issue returned… but of course, the new satellite came with an older firmware version. So I updated it and once again, it started working.

It would have been really helpful if Sonos had this information surfaced a little more visibly on their website somewhere. Maybe they can add it to their support pages, to save anyone else the many frustrating hours I experienced trying to fix it!

“Phone team” link takes you to the same 800 number everybody else gets. I’m about to try the HQ number (Santa Barbara, 805-965-3001) to see if I can get anywhere.

I’ve been having the same Spotify issue since the last update. Hours on the phone with tech support have finally gotten my case “escalated” to an engineer. They blamed my router, they blamed my modem, they blamed my wifi channel...everything they could to distance themselves from culpability. Bare in mind, all my other devices play Spotify fine on the same network and all my other streaming choices work fine on Sonos.

So yes, EVERYBODY should call in and generate a trouble ticket. Hopefully it will force them to act, if nothing else allow us to retrograde their stupid update.

Another Orbi/Sonos usere here… I am experiencing the same problem - when I try to play a song using Spotify Premium via a mobile app or Desktop app I get an error ("Unable to play song-name - the connection to Spotify was lost").

 

My setup and symptoms are very similar to what other folks are reporting here: 

  • Orbi Mesh in use
  • Cisco DPC3825 
  • Orbi RBR50, V2.3.5.30
  • Sonos/Spotify combo worked flawlessly since 2015 until about 2 weeks ago (Early May 2020)
  • Tried dozens of fixes: rebooting, removing accounts, updating, trying different accounts
  • No VPN in use
  • No other networking devices in use
  • Orbi: Parental Control, Access Controls and Pausing is set correctly
  • One in 30 attempts to play a Spotify song will work, the issue returns then
  • Spotify app works fine - Spotify works fine on Google Nest, Google Home and Echo devices
  • All other music services work fine on Sonos (e.g., Amazon Music, Google Play, Pandora, etc.)
  • Given a major runaround by Sonos support
  • I have a 5, two 3s and four 1s in my home config
  • My controlers are: iPhone, iPad, two PCs and two Mac devices
  • This is a side note but I have to squeeze it here - I’ve spent over $10K on Sonos gear over years (home and business) and I was an evangelist - loved the co and the product with all my heart. I pursuaded numerous folks into buying Sonos - I loved it and wanted to share the experience…. Today, I am frustrated and this fanboy is turing into a disgruntled user...

 

 

Userlevel 1
Badge

I’m experiencing this issue too. Anyone have any luck addressing it?

 

I saw there was a new Spotify update today for IOS, however it did not fix the problem. Just out of curiosity ERJ_Teach, do you have the ORBI system as well? 

I’m experiencing this issue too. Anyone have any luck addressing it?

 

I saw there was a new Spotify update today for IOS, however it did not fix the problem. Just out of curiosity ERJ_Teach, do you have the ORBI system as well? 


Nope! I’m on RCN internet with a regular old modem/router combo, an Arris.

Spent about 1.5 hours with Spotify chat support yesterday. They escalated my issue but they don’t seem to get it. I’m waiting for them to tell me it’s just a Sonos issue.

I’m having this problem on all sorts of devices.

The issue of Spotify Connect not playing through my Sonos is present on:

  • Spotify web player (in Mozilla Firefox) Spotify desktop app on two different laptops (both are Windows 10, one is on a wired connection, one is on wifi - one Spotify client can "see" the Sonos but can't connect, the other doesn't "see" the Sonos at all)
  • Spotify Android app (Sonos is visible in Spotify connect, but it doesn't connect)
  • Sonos Android app (can browse library, but when I attempt to play the song I get the error: "Unable to play SONG NAME. Connection to Spotify has been lost.")
  • Sonos Desktop app (can browse library, but when I attempt to play the song I get the error: "Unable to play SONG NAME. Connection to Spotify has been lost.")   Everything worked fine until about 5/15 when the issue spontaneously began occurring.

“Phone team” link takes you to the same 800 number everybody else gets. I’m about to try the HQ number (Santa Barbara, 805-965-3001) to see if I can get anywhere.

I’ve been having the same Spotify issue since the last update. Hours on the phone with tech support have finally gotten my case “escalated” to an engineer. They blamed my router, they blamed my modem, they blamed my wifi channel...everything they could to distance themselves from culpability. Bare in mind, all my other devices play Spotify fine on the same network and all my other streaming choices work fine on Sonos.

So yes, EVERYBODY should call in and generate a trouble ticket. Hopefully it will force them to act, if nothing else allow us to retrograde their stupid update.


Sounds about like what I expected to get from phone support...which is why I hesitate to even call.  I’m a network engineer by trade so blaming the network gets frustrating lol.  But I’ll call in as well so it’ll help the greater good.

Userlevel 1

Hi Sebastien

Thanks for the reply.  I have since had a case logged (#01709691) which suggested changing my wfi to Ch11 - but this has not fixed the problem and I have emailed back but not heard anything.

I can confirm that Spotify works outside of Sonos (on my our Android devices, PC and can connect phone to TV speakers and Bluetooth speakers) but continues to not work on Sonos - we can play a max of 6 tracks and then the error message keeps returning ‘Unable to play "Song Title" - the connection to Spotify was lost’.  All other Sonos services seem to be working fine.  I will add that Sonos had been working perfectly with our current set up for quite some time - we have not changed anything (so assume an update somewhere has caused the issue?)

To answer your questions:-

  1. Internet > BT Homehub (with wifi disabled) > Netgear Orbi RBR20 (as router) > and then three Netgear Orbi RBS20 around the house (as Satellites)
  2. Android phones (x4) - all now have the same issue (had been working fine), PC (same issue)
  3. Only as described in 1
  4. No

Its not practical to try connecting Sonos using a wired connection at the moment (my wife is wfh and we cannot play with the network until this evening) - I will try that later today.

I look forward to hearing any suggestions that you may have - I’m sure you appreciate just how frustrating it is for us to not be able to listen to music on Spotify at the moment.

Regards

Mark

Userlevel 1
Badge

I think Sonos has enough clout to contact Spotify and ask what’s up?

 

How do you know they didn’t?

How do you know they did?  Because it isn’t fixed.

Userlevel 1
Badge

One would think that Sonos would take some issue with this resolve considering all the people that have problems with this. I for one am not going to spend hours on the phone with some tech that knows nothing about resolving this issue, as I’m not getting paid to do so.  Fix it.