Unable to load all my music from a NAS Share

  • 24 December 2013
  • 11 replies

I have used a NAS as the source for all my music for several months without issue. I recently moved my music folder to a new NAS on the same network subnet but after setting up the relevant 'share' my Sonos system will only load a small percentage of the music folder. All permissions are the same as my previous NAS ('everyone' has full access) and the Sonos can browse to sub-folders in my music directory which it won't subsequently load unless i specifically load the single folder. My Sonos system still loads the original NAS music share OK but no matter how may times i delete and re-add the new share the same small amount of music folders appear.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

Userlevel 7
Badge +26
Hello Dave,

Is the name of the old NAS and the new NAS the same? And is the old NAS still on the network? This thread has some great information on missing tracks that you can check. Can you check that the new location is showing up properly inside your Music Library > Folders?

If you're still having trouble, can you please submit a diagnostic from the system and reply back with your confirmation number?

Thanks for the reply.  The NAS have different names although i did have the same 'share' folder name which i changed; the path name was always different; old NAS \\Mediaserver1\Media\Music new NAS \\Diskstation\mastermedia\music, i changed the share folder from media to mastermedia on the new NAS.  My music library is not too large and all the tracks are of the right format.  If i point Sonos to 'mediaserver1' i get the entire library; this has worked perfectly for several months.  If i delete that path then point to 'diskstation' i get about 2% of the library.  I suspect something has corrupted the metadata when i copied the music folder across because when i point iTunes to the diskstation music folder (having mapped to it as my default library location) it only loads the same 2% of music folders.  Ironically, i have iTunes server running on my new NAS (Synology DS1513+) and that picks up the entire music library which i can browse to via iTunes under 'shared' libraries.  Any ideas?        
I should have added. If i delete the Sonos path then point it to any of the 'unloadable' folders it loads it and plays it fine.  The same happens from iTunes as well.  I can manually load 'missing' folders from the NAS.  As an example, pointing both Sonos and iTunes to the root mastermedia/music share won't load my Deep Purple folder containing 26 albums.  If i point them to mastermedia/music/Deep Purple they load and play the contents OK.  A check of the applicable metedata for Deep Purple on diskstation shows the same attributes as the same folder on Mediaserver1.       
Diagnostic Number is 3315971
Userlevel 7
Badge +26
Hi Dave,

Thanks for that diagnostic. The diskstation share looks fine on in, so I think you might be looking at a metadata issue, or a corruption during transfer. If you go into Sonos under Music Library > Folders, do you see all of your tracks? If all of them are there, it's a problem with the metadata on the missing tracks.

If you want to see the Music Index on your system, unless the IP changes you can go to The IP address there is the IP of your PLAYBAR, but you could use the IP of any of your Sonos components.

The Music Library > Folders only shows the 2% of my library.  The PLAYBAR tracks list is the same.  I have copied my music library from my new Synology NAS back to my old Buffalo LinkStation NAS into a different folder so i now have the same music library in two folders on the LinkStation.  Sonos picks up the entire library from that new folder.  It appears clear to me that it is not a metedata issue but an issue with file permissions on the Synology.  This is the situation as it stands as i know people follow these threads:

New NAS - Synology DiskStation DS1513+ (5x WD 4Tb Black HDDs set up as a SHRA) has 1 share called Mastermedia with a music subfolder containing 4493 folders (as a reference for later 73 'A' folders and 86 'B' folders).  If i run the internal iTunes server on the NAS it picks up the entire library and i see it as a share on my Windows (XP) laptop and iMAC (OSX10.9).  If i map the XP iTunes to the folder (SMB share) as the default library location it picks up about 10% of the library e.g. 73 folders for Artists beginning 'A' and 45 'B' folders; all the 'A's and some of the 'B's!  If i map the iMAC to the same folder (AFP over TCP share) iTunes picks up even less than XP; 23 of the 'A's and 30 B's! It's the same if use a SMB share.  I also have Plex Server running on the Synology and that picks up the entire music library which i can use from my Smart TV and Popcorn Hour A300.  When i map the Popcorn Hour direct to the Diskstation share (SMB or NFS share) it picks up the entire library as well and generates the relevant NMJ database which i can control from my smart phone or iPAD.  If i point Sonos at this share it only picks up about the same as XP

Old NAS - Buffalo LinkStation Quad (4x WD 1Tb configured as RAID 5) has 1 share called Media with a music subfolder with the 4493 folders.  If i map XP and iMAC iTunes to this folder they pick up the entire music library.  The LinkStation is DLNA compliant so it shows up as a share in iTunes as well which also has the entire library content.  If i map my Popcorn Hour A300 to this share it picks up the entire library.  If i point Sonos at this share it picks up the entire library.

Both NAS have the same group and user setups; MediaUsers group with user accounts set up as members using the same passwords to maintain access control across my LAN devices.  On both NAS there are no access restrictions applied to this group and for SMB, AFP and NFS there's no need for user and password access anyway.  The Guest account is active on both for anonymous access.

There's clearly a difference in the way that the Synology NAS is treating external file access from Windows, OSX 10.9 and Sonos although it is OK from my Popcorn Hour A300 which i think has an Android OS but works fine using SMB or NFS shares.  Both Windows Explorer and iMAC Finder show the entire folder and file structure of both NAS.  I'm totally confused and will raise a query with Synology if you've got no other suggestions.  
By way of an update - I solved the problem which you might want to note for similar queries.

Analysis:  I also experienced the same limited file download when using a 3rd party file renaming software called Bulk Rename Utility (BRU) from my XP laptop.  It would load the entire contents of the Buffalo NAS music folder but only all the A’s and some of the B’s from the Diskstation music folder.  The limited load was coincidental with the limited load using SONOS and iTunes. I noticed one difference in the BRU file load sequence from the Diskstation in that it was in alphabetical order as opposed to random from the Buffalo NAS.  

Solution:  On the Synology DS1513+ NAS I disabled “Enable DirSort VFS module” in the Windows File Service Advanced Settings and now have full access to the entire music library using SONOS, iTunes (from XP and MAC) and all the files load into BRU.  I but don’t know why having the Diskstation present the directories and files in alphabetical order would cause such an issue using XP and OSX 10.9 plus SONOS.  My Popcorn Hour A300 (Java OS) has been unaffected and worked perfectly throughout.
Hi I have a problem getting my popcorn hour a300 to play 5.1 through sonos it says stereo on the app, I have my sonos going through a hdmi switch which works perfectly with xbox think it's settings in popcorn ? Any help please
I have my switch set to 5.1 but it also has options for pass and 2.0
Hi I have a problem getting my popcorn hour a300 to play 5.1 through sonos it says stereo on the app, I have my sonos going through a hdmi switch which works perfectly with xbox think it's settings in popcorn ? Any help please
Off-topic necroposting. You already posted this query elsewhere.
Ok sorry